Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
+ T +

Final Burn Legends 1.7

Recommended Posts

This is just a small update to fix some games that were broken in 1.666. Thanks to gamez fan for bringing them to my attention.

 

+ T +

 

What's New:

 

- The following games were broken in 1.666 and have been fixed:

 

Bonk's Adventure

Blaze On

1000 Miglia

Mille Miglia 2

Explosive Breaker

The Berlin Wall

Magical Crystals

DoDonpachi Dai-Ou-Jou (Black Label)

Knights of Valour 2

Knights of Valour 2 Plus

 

Downloads:

The usual places.

Share this post


Link to post
Share on other sites

still havin problems with dodonpachi 3 black label im still gettin the rom error message after the game has loaded but it could just be my rom is wrong

no big deal as dodonpachi 3 works fine plus its great to have kov2 working again love that game

Share this post


Link to post
Share on other sites
still havin problems with dodonpachi 3 black label im still gettin the rom error message after the game has loaded but it could just be my rom is wrong

no big deal as dodonpachi 3 works fine plus its great to have kov2 working again love that game

Almost definitely a problem with your ROMset. It's working perfectly here.

Share this post


Link to post
Share on other sites
still havin problems with dodonpachi 3 black label im still gettin the rom error message after the game has loaded but it could just be my rom is wrong

no big deal as dodonpachi 3 works fine plus its great to have kov2 working again love that game

Almost definitely a problem with your ROMset. It's working perfectly here.

 

ok not makin a big deal out of this since ddp3 master version works for me and im not really bothered about it but just want to know what i did wrong

 

i got a new ddpblk rom from the fba section of a french site built it up using romcentre.dat to be the parent as i prefer it that way

loaded up fbl tried the new rom the game starts but loads to black screen with rom error! in green writing so to be double sure

i stripped the rom back to just being a clone again to see if it works that way but same thing as before loads to black screen etc

as i said not bothered but i do luv a mystery why do you think this is happening +T+

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...