Jump to content

FBA_XXX_Pro_1.29_BETA release (codename "Banana Hammock")

- kenshiro -

Recommended Posts

  • Replies 823
  • Created
  • Last Reply

Top Posters In This Topic

So this is the truely last FBA from Kenshiro, right?

So far, all of the CPS2 roms I've tried boot in 720P and run better than they do on 1.28. I have tried all of the bigger ones like Progear, Xmen:cota, the Marvel games, SFA3, and Vampire Savior. I am still testing/playing, so I will be back.


Happy to know it works... :thumbsup1::thumbsup1: but now i'm really frustrated with the issue :thumbsup1: lol, but that's minor it will be solved!


And no, that's not the last build. I need to work on Neogeo games which have issue in HD. Moooooooooo!


The best thing to do is etablished a list of Neogeo issues, then i will track them down.



I will be back with a list of NeoGeo issues when I get off work. Since it's not the last build yet, then maybe you can also address the 'others/cave' section for 720P mode too :thumbsup1: I know I am pushing my luck. :clapping:


You truly are an awesome coder. I almost got no sleep at all from playing so much. See you in a bit.

Link to comment
Share on other sites

'shiro, couple of thoughts.


PGM - how about merging the graphics together in one file and adding an offset to the second half? This should allow everything to be read from the standard vmm and could prove faster (especially not having to seek two seperate files...).


About your CPS2 bug, it seems that cps2init is doing something before cpsinit is called. I'd suggest throwing some fprintf's to log how far it gets before catching fire. You can work out what's wrong/missing.


All, of course, if you give a damn about this crap. :thumbsup1:

Link to comment
Share on other sites

Back from work.


I almost have a list of NeoGeo issues completed that need to be fixed for HD mode. Sometimes when you start a game, it will cause an "error starting game screen" to come up. Once this happens, no more games will start up -- even ones that worked before. If I do not select certain games, then the problem does not happen.


Here is an example: I can play all of the Metal slugs, but as soon as I exit and try to start Waku Waku 7, the game will give the "error starting game" screen. If I go back to Metal Slug after that, then it will do the error screen too and so will all games after that.


Waku Waku 7 is one of the games that always causes this issue. I will post back with the rest of them.

Link to comment
Share on other sites

Ok I got it.


NeoGeo HD test 05/27/09


aof3.zip -- will hang at the "Launching game..." message after selecting it


The rest of the games below will give the "There was an error starting rom" message and the flashing background screen:










If you select one of these, then it will fail to launch it. From there, you will have to reset the emulator because no more NeoGeo games will work until you do. This seems like an easy issue to track down, Kenshiro.


CPS1 and CPS2 are all working great.

Edited by neoryu
Link to comment
Share on other sites

i had that issue with cps2 before the fix, it was almost as if all vm or available memory was used but stored and not flushed/dumped after exiting the rom. Only a reboot would sort it out. If you know what i mean !

Edited by cba.gy
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...