Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
+ T +

Final Burn Legends 1.4

Recommended Posts

So are you saying that 1.4 is behaving precisely the same way as 1.3 in this regard? From what you say it doesn't seem like doing anything to the default base screen size values will do anything other than mess things up for you so I'll hold off on that until I hear what conclusions you come to from your respective testing.

 

Not exactly. Could you PM me with a chat client name that you use? (AIM, Gchat, MSN) It would probably be easier to discuss that way.

 

Also, I did notice a bug - I think. For some games in 480i/p mode, a combination of 10x11 pixel mode and widescreen fix (which is awesome btw) can 'correct' widescreen games like 1943. However, I noticed that when you return to a game like this, it says that 10x11 is ON in the video settings, but it is not. You need to turn it OFF, then back ON for it to take effect. Is that something that can be fixed? I'm not sure if its actually a bug or not.

 

Thank you again, +T+

 

Sparda, sorry to hear you got hurt - that sucks. Rest up. If you want, I can send you the first batch of PP INIs. All the numbered games. Just PM me if you're up for it.

Edited by PhilExile

Share this post


Link to post
Share on other sites
i dont have much time to try .inis....i had a crash with my bike yesterday...need some rest :(....2 weeks before my wedding..life is a b... :)

Sorry to hear that. I ride a bike myself. Hope you're not badly hurt.

 

if i could make a game request +T+ for fbl 1.5.

http://www.1emulation.com/forums/index.php?showtopic=33074

thank you.

I'll ask iq if he can help us there. :)

 

Not exactly. Could you PM me with a chat client name that you use? (AIM, Gchat, MSN) It would probably be easier to discuss that way.

 

Also, I did notice a bug - I think. For some games in 480i/p mode, a combination of 10x11 pixel mode and widescreen fix (which is awesome btw) can 'correct' widescreen games like 1943. However, I noticed that when you return to a game like this, it says that 10x11 is ON in the video settings, but it is not. You need to turn it OFF, then back ON for it to take effect. Is that something that can be fixed? I'm not sure if its actually a bug or not.

Chat client is an easy answer; I don't use one, sorry. I have my email open most of the time for work though so you'll usually get a fast response there if I'm anywhere near the computer.

 

I picked up on the 10x11 bug earlier in the thread. Will fix it for the next release. There was a similar bug with game-specific hardware filters not applying on startup, but I managed to catch and fix that in 1.4.

Share this post


Link to post
Share on other sites
Chat client is an easy answer; I don't use one, sorry. I have my email open most of the time for work though so you'll usually get a fast response there if I'm anywhere near the computer.

 

OK, send me an email to remind me. I think you have mine. :)

 

I picked up on the 10x11 bug earlier in the thread. Will fix it for the next release. There was a similar bug with game-specific hardware filters not applying on startup, but I managed to catch and fix that in 1.4.

 

Oh, OK, great - I didn't realize that was previously reported.

 

I'm going to go through the As and let you know how it goes.

 

Talk soon

Share this post


Link to post
Share on other sites

Phil,

 

I did try the 480p setup in my LCD 720p and

got just bad results. The scanlines itself look

exactly as in 720p mode, however I was not

able to find the pixel perfect width settings for

a CPS1 game, for example.

 

I did reach "the correct width" point only

if the image is very very very very wide,

with SO MUCH overscan, or with the image

very very very very narrow, completely

wrong regarding the correct CPS native screen.

 

 

* * *

 

Darknior,

 

I just arrived back home from a dinner in a friends

house and I am too sleepy (to not say drunk) at the moment to play

things on the Xbox. I need to setup a hub to be

able to connect via FTP, since I moved the

console to the living room.

 

Tomorrow morning I will send you the DD stuff.

 

Regards!

C.

Edited by Cospefogo

Share this post


Link to post
Share on other sites
Phil,

 

I did try the 480p setup in my LCD 720p and

got just bad results. The scanlines itself look

exactly as in 720p mode, however I was not

able to find the pixel perfect width settings for

a CPS1 game, for example.

 

I did reach "the correct width" point only

if the image is very very very very wide,

with SO MUCH overscan, or with the image

very very very very narrow, completely

wrong regarding the correct CPS native screen.

 

 

I wonder if this is your TV's doing. I just made a bunch of perfect pixel INIs that work for me in 480p mode. I'll email them to you now so you can try them out.

 

------------

 

+T+, while testing I noticed one weird thing: the game Action Fighter (FD1089A 317-0018) has garbage graphics on the title screen when you first launch it. If you start the game and then go to the menu and reset it, this seems to correct the problem. I don't know if this is a ROM issue, FBL issue, or something else entirely - but I thought you should know.

 

------------

 

Regarding the perfect pixel INIs: Anyone who would like to try them, please PM me. I was only able to get through the #s and As today - so this is going to take some time. People should test though to see if they are working universally.

 

------------

 

+T+, none of the 1.3 perfect pixel INIs transferred without needing to be tweaked to some degree. At this point, I don't think this is a big deal since I never go through all the games anyway. My only concern is the possibility that the 'universal' screen size somehow is affecting the custom INIs that I'm creating. I don't think it is, but we should find out for sure.

 

Also, I noticed that when the WIDESCREEN FIX is applied, it does affect the 'pixel perfect' sized screen. For instance, if I set the perfect pixel size for 1943, then apply 10x11 pixel, and finally, Widescreen Fix, the vertical size of the screen is slightly reduced, along with the horizontal. This is easily fixed by just adjusting it manually. Again, I don't think this is a problem, but I thought you should know. Overall, I think that Widescreen fix works really well.

 

OK, that's about it.

Share this post


Link to post
Share on other sites
+T+, while testing I noticed one weird thing: the game Action Fighter (FD1089A 317-0018) has garbage graphics on the title screen when you first launch it. If you start the game and then go to the menu and reset it, this seems to correct the problem. I don't know if this is a ROM issue, FBL issue, or something else entirely - but I thought you should know.

Thanks for reporting this. Seems to be a driver issue. I'll look into fixing it for 1.5.

 

I think I may have mentioned this before but I'll do so again anyway just so everyone knows how the screen sizing works. Here comes the science bit... FBL has a set of hardcoded base values that determine the default screen size, these cannot be changed by the user at all. When you run a game it creates an ini file which contains 4 lines named zLeft, zRight, zTop, zBottom. These values aren't independent size values, they are modifiers that get applied to the hardcoded base values. So since I did not change the base values for the default screen size in FBL1.4, I see no reason why the modifiers in your ini files would produce a different result to 1.3.

 

When you use the global screen size setting, all it does is create a set of these modifiers in Screen.ini which get applied to any game that does not already have an ini file. So again, the base values are not altered, only the modifiers. The Widescreen Fix option however DOES use an separate set of hardcoded base values, so any modifiers in Screen.ini or a game ini will be applied to these alternate base values and will produce an entirely different result to having the Widescreen Fix option off.

 

If any of that makes sense then hopefully it will help you give me an idea of what you think needs to be changed to accommodate what you're trying to achieve.

Share this post


Link to post
Share on other sites

Anyone else get slow, stuttering sound in 1942? For me, it's noticeable at the very start of the game when it plays the little tune during & after takeoff. (game itself is running at 59.9~/60fps)

Share this post


Link to post
Share on other sites
Anyone else get slow, stuttering sound in 1942? For me, it's noticeable at the very start of the game when it plays the little tune during & after takeoff. (game itself is running at 59.9~/60fps)

 

Hi JL,

 

I think that is a sound driver issue. Something similar happens with GHOSTS & GOBLINS. I remember IQ told me it had something to do with how the sound was emulated, but I'm not sure exactly what it was. Mabybe he could chime in. :)

 

Let us know how those INIs work!

 

Thanks

Share this post


Link to post
Share on other sites
Thanks for reporting this. Seems to be a driver issue. I'll look into fixing it for 1.5.

 

No problem - thanks!

 

I think I may have mentioned this before but I'll do so again anyway just so everyone knows how the screen sizing works. Here comes the science bit... FBL has a set of hardcoded base values that determine the default screen size, these cannot be changed by the user at all. When you run a game it creates an ini file which contains 4 lines named zLeft, zRight, zTop, zBottom. These values aren't independent size values, they are modifiers that get applied to the hardcoded base values. So since I did not change the base values for the default screen size in FBL1.4, I see no reason why the modifiers in your ini files would produce a different result to 1.3.

 

OK, well, its not a huge deal anyway. Usually things were off by only a few XY coordinates. As long as I can give these INIs to anyone else using 1.4 and they can use them without issue - that's all that matters.

 

When you use the global screen size setting, all it does is create a set of these modifiers in Screen.ini which get applied to any game that does not already have an ini file. So again, the base values are not altered, only the modifiers.

 

Great, sounds perfect.

 

The Widescreen Fix option however DOES use an separate set of hardcoded base values, so any modifiers in Screen.ini or a game ini will be applied to these alternate base values and will produce an entirely different result to having the Widescreen Fix option off.

 

That's what I noticed. Overall, I think it works really well.

 

If any of that makes sense then hopefully it will help you give me an idea of what you think needs to be changed to accommodate what you're trying to achieve.

 

Like I said, as long as anyone with 1.4 can use the INIs I'm creating (with the help of Cos!) - then I think everything should remain as-is. I sent out some of the INIs to people to test late last night, so hopefully we'll hear back soon on how its working out.

 

Talk soon

Share this post


Link to post
Share on other sites

just a thing i noticed that could explain this issue importing the inis from fbl 1.3:

the skin

in the skin folder there is a file called arcade.ini wich contains the 4 lines mentioned above

zLeft0=1.150000

zRight0=-9.480121

zTop0=-5.350028

zBottom0=5.270025

 

these values are differents of the values used by the default skin of fbl 1.3

just a clue, im trying to understand with you guys

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...