Jump to content

FBA-XXX Pro v1.28


+ T +
 Share

Recommended Posts

Did this show up on previous builds of pro or just 1.06, i might have to go back to 1.01

Don't bother. I'm hoping to have a fixed build out soon. However the kf2k3upl problem doesn't look like a driver issue. Thraxen, do you know if it does the same thing in MAME?

Link to comment
Share on other sites

  • Replies 638
  • Created
  • Last Reply

Top Posters In This Topic

Did this show up on previous builds of pro or just 1.06, i might have to go back to 1.01

Don't bother. I'm hoping to have a fixed build out soon. However the kf2k3upl problem doesn't look like a driver issue. Thraxen, do you know if it does the same thing in MAME?

 

+T+ just curios how does this happen to certain games when you add some sets and fix small bugs?

Link to comment
Share on other sites

+T+ just curios how does this happen to certain games when you add some sets and fix small bugs?

This particular problem is due to the addition of the MAME sets. Some of the bootlegs added to MAME are unlike any of the sets that have been supported by FBA-XXX Pro previously in that they use encrypted C ROMs as well as a seperate S ROM.

 

To be more specific, sets that have encrypted C ROMs usually do not need an S ROM since the text layer data is contained in the C ROMs and is extracted as part of the decryption process. However when you try to load a seperate S ROM as well as decrypting the C ROMs it seems to cause a conflict which is why you get the graphics corruption you see on the screen.

 

So there are two possible solutions. 1) Go back to using decrypted C ROMs for the affected bootleg sets (easy to do) or 2) find a way of decrypting the C ROMs that does not cause conflict with the custom S ROM (no chance without help from iq).

 

Will keep you posted as things progress.

Edited by + T +
Link to comment
Share on other sites

+T+ just curios how does this happen to certain games when you add some sets and fix small bugs?

This particular problem is due to the addition of the MAME sets. Some of the bootlegs added to MAME are unlike any of the sets that have been supported by FBA-XXX Pro previously in that they use encrypted C ROMs as well as a seperate S ROM.

 

To be more specific, sets that have encrypted C ROMs usually do not need an S ROM since the text layer data is contained in the C ROMs and is extracted as part of the decryption process. However when you try to load a seperate S ROM as well as decrypting the C ROMs it seems to cause a conflict which is why you get the graphics corruption you see on the screen.

 

So there are two possible solutions. 1) Go back to using decrypted C ROMs for the affected bootleg sets (easy to do) or 2) find a way of decrypting the C ROMs that does not cause conflict with the custom S ROM (no chance without help from iq).

 

Will keep you posted as things progress.

 

+T+ so the last few builds were using the decrypted c roms (such as the C's from Mslug4d). I think thats what you mean. Because in the latest dat its borrowing the C's from the main set(mslug4)

Edited by lawnspic
Link to comment
Share on other sites

+T+ so the last few builds were using the decrypted c roms (such as the C's from Mslug4d). I think thats what you mean. Because in the latest dat its borrowing the C's from the main set(mslug4)

Yes, up until v1.05 ms4plus and ms5plus were using decrypted C ROMs. But it's more correct to use encrypted ones because that's how they are on the actual board.

 

I think what I might do once this bug is fixed is add decrypted and fully decrypted sets for any bootlegs that use the parent set's encrypted C ROMs so users that want to play them don't have to put up with the load times and filesizes if they don't want to.

Link to comment
Share on other sites

Did this show up on previous builds of pro or just 1.06, i might have to go back to 1.01

Don't bother. I'm hoping to have a fixed build out soon. However the kf2k3upl problem doesn't look like a driver issue. Thraxen, do you know if it does the same thing in MAME?

 

I'm honestly not sure as I haven't tried it yet. I'll try to test it later tonight unless someone else does it first.

Link to comment
Share on other sites

Did this show up on previous builds of pro or just 1.06, i might have to go back to 1.01

Don't bother. I'm hoping to have a fixed build out soon. However the kf2k3upl problem doesn't look like a driver issue. Thraxen, do you know if it does the same thing in MAME?

 

 

OK, I can now confirm that MAME has that bug seen in kf2k3upl too. I played the game in the latest MAME 0.104 and it did it too. Maybe it's just a bug with the game itself?

Edited by Thraxen
Link to comment
Share on other sites

thought i'd give a heads up on whats going on with my newsgroup post, almost to the end of the romset which should be done by tomorrow since it is done with most of the bigger games (currently u/l svc) and the rest should go up easy til it gets to the par2s which might slowdown again when dealing with the bigger ones.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...