Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
+ T +

FBA-XXX compile help

Recommended Posts

I got an e-mail from djohng today. He says he is cleaning up a few things in the code and having to get ready for visitors this weekend.

Share this post


Link to post
Share on other sites

It's uploaded both patch and source code.

 

Have fun, play around with it, etc.

 

DATs are included, patch, jpg, etc. etc.

 

Thank Thraxen for hosting the files!

 

-djohng

 

Links are:

 

http://www.thraxen.com/emu1/fbaxxx_djohng1.rar

 

http://www.thraxen.com/emu1/fba_src_091704.rar

Share this post


Link to post
Share on other sites

well just tested it with 2 encrypted games (cthd2003 and mslug4) and both ended up with a black screen and freezing the xbox.

 

oddly enough, even the decrypted cthd2003 gave me the black screen freeze so something is wrong.

 

i'll try deleting ini and the save info and see what happens

 

No Change, still get a black screen for neogeo

Edited by Prican25

Share this post


Link to post
Share on other sites
well just tested it with 2 encrypted games (cthd2003 and mslug4) and both ended up with a black screen and freezing the xbox.

 

oddly enough, even the decrypted cthd2003 gave me the black screen freeze so something is wrong.

 

i'll try deleting ini and the save info and see what happens

 

No Change, still get a black screen for neogeo

You have to enable sound in the neogeo menu before starting the game. It's FM interpolation...then everything works fine.

Share this post


Link to post
Share on other sites

djohng, if you replace the file 'burn_ym2610.cpp' with the one from the 08-02-2004 version source then it fixes this problem. I don't know why but it works. :D

Share this post


Link to post
Share on other sites
djohng, if you replace the file 'burn_ym2610.cpp' with the one from the 08-02-2004 version source then it fixes this problem. I don't know why but it works.  :D

It's the way the ini file is written at startup. If no ini exists, then the default setting for sound is 0....which is none...so neogeo will lock, because it's looking for FM interpolation...its a bug...but I wasn't worried about this one...I figured everyone knew about it...go figure?!

 

If more bugs are found, I may update, and fix this setting...

Edited by djohng

Share this post


Link to post
Share on other sites

I'm getting bad sound in mslug4nd.zip. Anyone else have this problem? It worked with previous versions of FBAXXX. My other Metal Slug games work fine.

Share this post


Link to post
Share on other sites

Bad sound (that is to say slightly crackly at times) in the larger games is something that got noticeably worse when the VMM routines were changed in the 08-02-2004 release. If you try the 06-04-2004 version you'll hear that it still occurs only to a lesser degree. A good place to check this is in SvC Chaos on the character select screen. Notice how when you move the selector to each character the 'bleep' that sounds is broken up and crackly, however if you move it back over a character you've already highlighted then it sounds fine.

 

I did try to re-implement the original VMM routines into my own build which I'm continuing work on but I think it would take a level of coding skill that I'm not yet capable of. Perhaps djohng might consider giving it a go. But I really don't know why Manto changed the VM routines in the first place, there was nothing wrong with them as they were. >_

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...