Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
+ T +

FBA-XXX compile help

Recommended Posts

Bad sound (that is to say slightly crackly at times) in the larger games is something that got noticeably worse when the VMM routines were changed in the 08-02-2004 release. If you try the 06-04-2004 version you'll hear that it still occurs only to a lesser degree. A good place to check this is in SvC Chaos on the character select screen. Notice how when you move the selector to each character the 'bleep' that sounds is broken up and crackly, however if you move it back over a character you've already highlighted then it sounds fine.

 

But mine isn't just "slightly crackly". The sound is very bad. It's constantly crackly and it sounds muffled. Also, the sounds worked fine for this very same ROM in the 8-02 release, so I don't think it's the VMM routines causing this issue. It think it's a bug in djohng's build.

 

So do you, or you sammaz, or anyone else have this same issue? From what you said sammaz it sounds like you do have the same issue. I want to make sure it's the emulator and not the ROM I have. Start up mslug4nd and check it out.

Edited by Thraxen

Share this post


Link to post
Share on other sites

Make sure you're using decrypted V roms. A while ago I tried to use a set that had the V roms encrypted with the 09-01 release and the results were just as you describe.

Share this post


Link to post
Share on other sites

Rom Center shows that the V roms are fine. The only difference I have is that my P rom has a different CRC than the one listed in the DAT. Everything else shows up perfect. But like I said, this exact ROM worked fine with the 8-02 release.

Share this post


Link to post
Share on other sites

i too hear the sound breaking up a bit here and there with mslug4 encrypted and this problem was gonna get fixed by manto but as you all know he has left the project. so unless any of you really know how to mess with the code, we're stuck with what we got.

 

also i like to say that djohng's patch works nicely but i wonder why cthd2003 encrypted has that gfx glitch, oh well :evil:

Edited by Prican25

Share this post


Link to post
Share on other sites
i too hear the sound breaking up a bit here and there with mslug4 encrypted and this problem was gonna get fixed by manto but as you all know he has left the project.

 

But my problem is with the decrypted version. It worked fine in the 8-02 release.

Share this post


Link to post
Share on other sites

First of all thanks for all your work here.

 

I used the ips-patch with fbaxxx in order to play Samurai S. 5 SP but the rom didn´t work so I used CLRMamePro with the dat from djohng and checked my samsh5sp.zip. The result was, that some files where missing or CRC-Check failed.

 

I merged the 4 V roms into 2, renamed them according to the dat-file entry for CLRMame to "272-v1d.bin" and "272-v2d.bin" and they seem to be OK.

 

But the only ROMs I couldn´t fix are the p and C roms. In every samsh5sp.zip-file that I find there´s only one p-rom with 8 MB - splitting them into 2 and renaming them does not work.

And the C roms have CRC-errors.

So how can I fix this???

 

Thanks in advance

Share this post


Link to post
Share on other sites

N3oGhost , so you mean there´s no way at the moment to get it to work with perfect sound and everything? And the correct C-ROMS and those 2 p-ROMs aren´t even released yet??

I tried these ROMs with kawax and they worked quite fine, except for sound...

But in FBAXXX I get the message that the C-ROMS have CRC-error (and of course one p ROM is missing)...

Share this post


Link to post
Share on other sites
N3oGhost , so you mean there´s no way at the moment to get it to work with perfect sound and everything? And the correct C-ROMS and those 2 p-ROMs aren´t even released yet??

I tried these ROMs with kawax and they worked quite fine, except for sound...

But in FBAXXX I get the message that the C-ROMS have CRC-error (and of course one p ROM is missing)...

One P rom isn't missing since the P1 already contains the data for the P2. The only thing that is really missing is the decrypted M1.

Share this post


Link to post
Share on other sites

the p1 contains the data for p2? But I split it into 2, renamed them but then Clrmame reported CRC-errors with these, too.

And what about the C-roms? Could it be that every set I download contains (according to Clrmame) the wrong C-roms?

And by the way, thanks for all your fast answers.

Edited by herbalb

Share this post


Link to post
Share on other sites
the p1 contains the data for p2? But I split it into 2, renamed them but then Clrmame  reported CRC-errors with these, too.

And what about the C-roms? Could it be that every set I download contains (according to Clrmame) the wrong C-roms?

And by the way, thanks for all your fast answers.

There is only one set of C roms out there, AFAIK. I could be wrong though.

 

CRCs always change if you tamper with files, and most of the time you won't get the CRCs you want unless you hack the contents of the file.

Edited by Agozer

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...