Jump to content

For the first person to be working on a new version of FBA-XXX


Recommended Posts

Thanks Gavin ;) . I've found a nice one: like before, launch a neogeo game and launch Gaia crusaders. Can you try this please?

 

I tried several games with Gaia but couldn't get a crash. One that I did find was Blazing Star to Action Fighter always crashed. Some other combinations -

 

Andro Dunos > Alex Kidd

Baseball Stars Pro > Outzone

Double Dragon > Truxton

Super Spy > Superman

Ninja Combat > Rastan

NAM 1975 > Battle K Road

CTHD > Action Fighter

 

All worked ok.

 

For the crash concerning system16 drivers don't worry about that, this drivers were very preliminary (so unstable) when they were added to 1.28 , all seems ok now :D

 

Well, it looks like a problem. Obviously, i never noticed a crash when launch a CPS1 or CPS2 games after a Neogeo game (i remember that it happened sometimes with 1.28, with launching a set of Punisher). BTW it is a thing of the past, cause CPS code was completly updated :) (and currently updated)

 

Thanks Gavin ;)

Link to post
Share on other sites
  • Replies 358
  • Created
  • Last Reply

Top Posters In This Topic

Sorry Cospefogo i forgot to reply to your post :) I'll ckeck for that issue. Thanks for noticed that :)

 

Hey Kenshiro!

Thanks for your reply. The coin button bug was confirmed to me (through PM messages)

by + T + himself, so it is there.

 

And I have something more - can you please test the NEO-GEO macros? There

is no way to make them work here in my FBA-XXX 1.28.

 

I just assign the normal/default macros, but my NeoGeo games does

no recognize them. What am I doing wrong?

 

Example:

A+B assigned to WHITE

C+D assigned to BLACK

 

I was playing Samurai Spirits 2 and they don't work!

 

* * *

 

And a suggestion:

Can we have (for God's sake) a LOCK MODE OPTION for the controller settings

regarding if it is ARCADE or ANALOG?

 

For example: You go to settings and there is a option like

- LOCK CONTROLLER SETTINGS: in ARCADE MODE

- LOCK CONTROLLER SETTINGS: in ANALOG MODE

- LOCK CONTROLLER SETTING: unlocked (BOTH MODES)

 

Why I ask this?

Everytime I have friends plying here they find a way to mess

with my config options (changing from arcade to analog).

 

I use only Hori Arcade sticks in the house or classic

not-analog pads (PSX, Saturn).

 

Well, that's it.

I am happy to hear that SHINOBI is working fine now.

 

Regards,

Cospefogo.

Link to post
Share on other sites

so what do you think would be the chances of getting turbo outrun to work kenshiro? :)

or maybe thats asking to much for the xbox to do.possibly a ram issue.

Link to post
Share on other sites
so what do you think would be the chances of getting turbo outrun to work kenshiro? :)

or maybe thats asking to much for the xbox to do.possibly a ram issue.

 

Turbo Outrun uses the same hardware and driver as Super Hang On and the original Outrun. I assume if one works, they should all work.

Edited by gavin19
Link to post
Share on other sites

so what do you think would be the chances of getting turbo outrun to work kenshiro? :)

or maybe thats asking to much for the xbox to do.possibly a ram issue.

 

Turbo Outrun uses the same hardware and driver as Super Hang On and the original Outrun. I assume if one works, they should all work.

the arcade version of turbo outrun actually used an upgrade to the hardware,so i think it needs more ram than the xbox has to get emulated.

ever wonder why it was never emulated on mame for the xbox.

but it might work on fba,im no expert but seeing as mame uses software emulation and as such would probably use more of the ram to emulate the game,then maybe fba could emulate the game.

Link to post
Share on other sites

so what do you think would be the chances of getting turbo outrun to work kenshiro? :)

or maybe thats asking to much for the xbox to do.possibly a ram issue.

 

Turbo Outrun uses the same hardware and driver as Super Hang On and the original Outrun. I assume if one works, they should all work.

the arcade version of turbo outrun actually used an upgrade to the hardware,so i think it needs more ram than the xbox has to get emulated.

ever wonder why it was never emulated on mame for the xbox.

but it might work on fba,im no expert but seeing as mame uses software emulation and as such would probably use more of the ram to emulate the game,then maybe fba could emulate the game.

 

The 'upgrade' was available as a plug-in board for the original Outrun with just the new roms for Turbo, but it used exactly the same cpu etc. The reason it wasn't on mame for the Xbox was because it wasn't added until 0.88u5, the Xbox core being 0.84.

Edited by gavin19
Link to post
Share on other sites
so what do you think would be the chances of getting turbo outrun to work kenshiro? :)

or maybe thats asking to much for the xbox to do.possibly a ram issue.

 

In reality, Out Run Hardware needs a small amount of RAM , and runs at full speed on Xbox :) , like others Sega hardware BTW (System16A, System16B, Space Harrier Hardware, X Board).

 

However, Y Board is an exception: Y Board Hardware

 

This one is more powerful than previous hardware, look at the CPU specifications :) In this case, the problem is not the amount of RAM, but the power of Xbox CPU . So games like G-Loc, Rail chase runs beetween ~ 45-60fps, with sometimes slowdowns to 40fps. The slower game i noticed is Galaxy Force 2, with slowdowns to 35fps. Honestly i don't if Y Board could run better with some Xbox optimisations, who knows? :huh:

 

For Turbo Out Run, i can't test it due to that bug in FD1094 encrypted games, however Out Run is playable :) ( stiil need to make inputs properly) :)

Link to post
Share on other sites

Sorry Cospefogo i forgot to reply to your post :) I'll ckeck for that issue. Thanks for noticed that ;)

 

Hey Kenshiro!

Thanks for your reply. The coin button bug was confirmed to me (through PM messages)

by + T + himself, so it is there.

 

And I have something more - can you please test the NEO-GEO macros? There

is no way to make them work here in my FBA-XXX 1.28.

 

I just assign the normal/default macros, but my NeoGeo games does

no recognize them. What am I doing wrong?

 

Example:

A+B assigned to WHITE

C+D assigned to BLACK

 

I was playing Samurai Spirits 2 and they don't work!

 

* * *

 

And a suggestion:

Can we have (for God's sake) a LOCK MODE OPTION for the controller settings

regarding if it is ARCADE or ANALOG?

 

For example: You go to settings and there is a option like

- LOCK CONTROLLER SETTINGS: in ARCADE MODE

- LOCK CONTROLLER SETTINGS: in ANALOG MODE

- LOCK CONTROLLER SETTING: unlocked (BOTH MODES)

 

Why I ask this?

Everytime I have friends plying here they find a way to mess

with my config options (changing from arcade to analog).

 

I use only Hori Arcade sticks in the house or classic

not-analog pads (PSX, Saturn).

 

Well, that's it.

I am happy to hear that SHINOBI is working fine now.

 

Regards,

Cospefogo.

 

Ok i'll check that (one more thing to do lol) :P

 

Thanks Cospefogo ;)

 

 

Edit:

 

Example:

A+B assigned to WHITE

C+D assigned to BLACK

 

I was playing Samurai Spirits 2 and they don't work!

 

It works fine for me, i tried on Samurai Shodown 5 :( I'll try another game.

 

 

 

Edit 2: To be more specific, Neogeo macros works fine, but there's a bug. Try to change macros and launch a game. Newer macros are not recognized. Then quit FBA ,go back and launch a game, and changes works now.

Edited by - kenshiro -
Link to post
Share on other sites
To be more specific, Neogeo macros works fine, but there's a bug. Try to change macros and launch a game. Newer macros are not recognized. Then quit FBA ,go back and launch a game, and changes works now.

 

I'm completly out of it lol. Sorry for that ;) Seriously it works fine for me :P

However (tell me i'm wrong), i noticed you can't access to Neogeo Macro directly in a game, in configure buttons menu, but have to go in in game menu/ controller option/ controller configuration. Can you confirm that Cospefogo? :(

 

For the coin button, can you be more specific? when i changed mapping from main menu it's always work, but during a game it does not work, even after a game reboot. I have to quit the game, relaunch it and it works ;) Do you have the same issue?

 

Thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...