Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
theelf

Raine + DOS = bad sound

Recommended Posts

Oh!! Neartdenthal technology, I love that one! i have in my NT box login! is a true classic joke from late 90s

 

 

 

My favorite ever is this one

 

chiste3.jpg

 

- Window hangs again!

- Kids, help dad to press CTRL-ALT-DEL

 

:rofl:

 

 

if one day we have free time, we can open a OS war thread

Edited by theelf

Share this post


Link to post
Share on other sites

No no I don't do os wars, if people are happy with windows it's fine for me, it's just that I want to remain free to do what I want, and they are also free to do what they want, force no one !

Share this post


Link to post
Share on other sites

Ok, here is what is supposed to be the final dos build, I have tested it in dosbox and everything seems fine AFAIK :

http://raine.1emulation.com/archive/rained-0.64.7.7z

 

So the changes are : seal initializes the mixer to max volume

and I have restored a very old setting "use emulated ym3812", you can now find it in the sound options dialog and it's saved if you change it. Until now raine has always used an emulated ym3812, except in the very old days. The reason being that even when I continued the development starting from 2000, I hadn't any hardware ym3812 so I could never test this setting. If you uncheck the box and so you say you don't want to use an emulated ym3812, it will try to use a hardware one, I guess you are the kind of person to still own a soundcard which has the real hardware chip ! Test this with bublbobl for example.

If you happen to set this to use the hardware chip and it can't find it or can't use it, then you'll simply hear no music at all when starting the game (when really starting the game after inserting a coin, the few notes when starting the game emulation do not count here).

 

Tell me if you succeed to use this hardware emulation, I was never able to on my side !

I don't think I'll restore the setting to the non dos versions, it's very unlikely to have this hardware chip nowdays and people would probably not understand why it produces silence on some games !

 

Of course the advantage of using this setting if you really have the chip is that you'll get super fast sound processing, plus this will be the real thing, not an emulation !

Edited by Tux

Share this post


Link to post
Share on other sites

 

Ok, here is what is supposed to be the final dos build, I have tested it in dosbox and everything seems fine AFAIK :

http://raine.1emulation.com/archive/rained-0.64.7.7z

 

So the changes are : seal initializes the mixer to max volume

and I have restored a very old setting "use emulated ym3812", you can now find it in the sound options dialog and it's saved if you change it. Until now raine has always used an emulated ym3812, except in the very old days. The reason being that even when I continued the development starting from 2000, I hadn't any hardware ym3812 so I could never test this setting. If you uncheck the box and so you say you don't want to use an emulated ym3812, it will try to use a hardware one, I guess you are the kind of person to still own a soundcard which has the real hardware chip ! Test this with bublbobl for example.

If you happen to set this to use the hardware chip and it can't find it or can't use it, then you'll simply hear no music at all when starting the game (when really starting the game after inserting a coin, the few notes when starting the game emulation do not count here).

 

Tell me if you succeed to use this hardware emulation, I was never able to on my side !

I don't think I'll restore the setting to the non dos versions, it's very unlikely to have this hardware chip nowdays and people would probably not understand why it produces silence on some games !

 

Of course the advantage of using this setting if you really have the chip is that you'll get super fast sound processing, plus this will be the real thing, not an emulation !

 

Hi! ohhh thankssss!! great build!!!

 

Ok, here are my tests, with neogeo, CPS1/2 and buuble booble game

 

- Neogeo and CPS1/2 games, work great whitout emulated ym3812 on AWE64 and SB16

- Bubble with real ym3812 dont have any music, even on SB16, i need to select emulated one

 

 

Neogeo/CPS games with emulated ym3812 are still playable but slower, and sound crack here and there. Not too bad, but much better using real opl

 

The funny thing is that the AWE64 *dont* have a any real yamaha, is emulation the yamaha with the wavetable board, but is a hardware emulation

 

Is amazing works with raine! in other emulators, like no$ ones, it seems they use the yamaha directly, and they hang or not have any music with AWE64 if i select direct hardware, since of curse, they dont find any yamaha chip

 

 

I love the option to use real hardware!

 

 

 

One thing i realize, is that the emulator, I dont know if just dont save the option, or reset to 22khz, but even if select 44khz, if I go to sound menu, it revert to 22khz, but i *believe* the games are still using 44khz

 

Not a big problem at all to be true... :msnwink:

 

 

raine4.jpg

 

 

 

 

Oh, one more thing, this IS NOT A PROBLEM, just for the record. I was playing bubble booble, and i wanna use 256x224@59hz

 

I make the resolution with Unirefresh, but raine refuse to use custom 256x224 in vesa2+ modes. Finally i made a 256x232 resolution, and this work great (maybe raine have a internal vesa resolution database?)

 

 

raine5.jpg

 

 

raine6.jpg

 

 

raine7.jpg

 

 

 

Nice to pay in original resolution and original hz!!! :-)

 

I just need to atach a scanline generator to VGA out, but for now, is ok

 

 

 

 

 

No no I don't do os wars, if people are happy with windows it's fine for me, it's just that I want to remain free to do what I want, and they are also free to do what they want, force no one !

:banghead: you look like a great guy to talk about technical stuff, sad not many like you over there! jaja

Edited by theelf

Share this post


Link to post
Share on other sites

For the 44100 Hz, it's because there was an old uncommented hack in the code replacing the frequency by 44098 if it was > 44098.

There was no comment explaining why. So I enabled it again but I think the sound dialog doesn't check 44098 and enables 22050 when it sees 44098, too bad.

If you want to test the real 44100, use the build from yesterday (it's slower than 22050 of course).

 

Oh well I'll probably revert this to 44100 then...

Nice to know everything else is working though, and 44100 is not really useful for dos anyway, it's useful mainly for neocd music, even neogeo music is not at 44100 Hz.

 

From memory raine reads its list of modes from the vesa bios for all the vesa categories (not modex and vga).

Edited by Tux

Share this post


Link to post
Share on other sites

Hi, Tux. I'd like to know whether these changes would perhaps improve speed on my Intel integrated HD 3000 graphics using the SABR shader.

 

Thank you in advance for your time.

 

Ok, here is what is supposed to be the final dos build, I have tested it in dosbox and everything seems fine AFAIK :

http://raine.1emulation.com/archive/rained-0.64.7.7z

 

So the changes are : seal initializes the mixer to max volume

and I have restored a very old setting "use emulated ym3812", you can now find it in the sound options dialog and it's saved if you change it. Until now raine has always used an emulated ym3812, except in the very old days.

 

Share this post


Link to post
Share on other sites

lol, it's specific to the ym3812, there is no ym3812 in cps1/cps2 or neogeo hardware, plus I doubt anyone with a modern setup would have an hardware ym3812 (or the equivalent).

So no, no luck for you on this side, unless you want to buy a new dos machine at 400 MHz, but if you do, say good-bye to the shaders !

Share this post


Link to post
Share on other sites

Tux, thanks for new version!

 

 

One idea, maybe is possible to add a item in video or gameoption, to disable neogeo rasters? a per game option

 

 

For example, rasters in Sengoku 2, slowdown the game a lot in slow machines. But rasters effects are not necessary to play the game at all, like in tother games

 

 

Thanks!

Share this post


Link to post
Share on other sites

Yeah I know it'a actually the main problem of the gui in dos, most of the time adding a single button is a mess, where it's extremely easy to do with the modern gui.

 

I'll see if something can be done without too many problems. Meanwhile you can do it by editing raine.cfg, normally you have a [neocd] section in it now, this setting is "disable_irq1", so to disable rasters you must have :

[neocd]

disable_irq1 = 1

 

By the way I re-uploaded the dos 0.64.7 version without the 44100 Hz hack, so you should be able to use 44100 Hz now if you re-download it (but it will be slower so it's probably not a good idea).

Edited by Tux
  • Like 1

Share this post


Link to post
Share on other sites

I just test the new DOS version, and at least in my celeron 366mhz, the speed is perfect, thanks! it seems at least 44khz is not overkill for the good celeron

 

 

 

Yeah I know it'a actually the main problem of the gui in dos, most of the time adding a single button is a mess, where it's extremely easy to do with the modern gui.

 

I'll see if something can be done without too many problems. Meanwhile you can do it by editing raine.cfg, normally you have a [neocd] section in it now, this setting is "disable_irq1", so to disable rasters you must have :

[neocd]

disable_irq1 = 1

 

By the way I re-uploaded the dos 0.64.7 version without the 44100 Hz hack, so you should be able to use 44100 Hz now if you re-download it (but it will be slower so it's probably not a good idea).

 

 

Oh cool! thanks, i preffer command line or edit cfg than UI anyways for options

 

Anyways, i tried the option you say disable_irq1 = 1 in neocd section, but nothing happen, raster still there, and when i quit raine, the line dissapear from raine.cfg

 

I tried to add in games.cfg under sengoku2 section, but no effect

  • Like 1

Share this post


Link to post
Share on other sites

Ah yes, spoke too fast, sorry the config is not read and restored for neogeo in dos.

I guess I'll need to make an update then...

 

EDIT : it's done, I added 2 checkboxes to the game setup dialog for that, the 2nd one is a bonus to allow/disallow speed hacks, you shouldn't have to touch this one, but anyway...

Who would have believed I would update the cursed gui in 2015 ? I still hate updating this code, but since these were only 2 ridiculous checkboxes, I did it...

And this time the config is saved and restored.

 

EDIT 2 : and re-uploaded the dos 0.64.7 with this update. Since it's something already available in the normal 0.64.7 version, there is no need to change the version number !

Edited by Tux
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...