Jump to content

How to got more FPS in slow machines ... NullDC


Recommended Posts

I think i found something to help users (like me) with slow machines, to get a few (some like 15 on my particular) fps. (this work running a default image on fullscreen)

 

 

first, Refresh rate:

all We know it look better on 85hz. Setting (trought nulldc.cfg) Fullscreen.Refresh_Rate= from 60 to 85 (if monitor is capable of) we can, but i noted this make the emu run slower: so i download and installed http://www.pagehosting.co.uk/rl/ REFRESHLOCK (it´s a tool to force higher display frequence without using the default OS or program impossition.)

 

With this, there are no need to put 85 on nulldc.cfg and it still run on 85.

 

 

And the Resolution:

All you have to do, is open NullDC.cfg and change the default (fullscreen.Res_X= Fullscreen.Res_Y=) to 320 and 240. This is a solution, but... the screen looks on 320 x 240, and its awful!, so, what you must to do, is download the "Universal Resolution Changer v2.0" http://toca.game-editing.net/forum/dload.p...&file_id=88 This handy little progy is; like his name say, a directx9 dll file to "hook" of and force determinated resolution on an executable, "faking" what it show, but not what it run.

 

With this, the emulator run on 320x240, but you see it on 640x480 (or 1600 if you setup resolution.ini for it)

 

Seems to works !!! with daytona i was getting a max of 55 fps, and now im getting up to 65 !!!!!

 

Try it and lemme know

Edited by GameCop
Link to comment
Share on other sites

Another tip:

The Chankast SOUND plugin seems to work better and faster than the nullDC sound plugin. Using it on Shenmue II increased the speed from about 14-16 FPS to 20-22 FPS. Seems to speed up a lot of games. I tried it on Chu Chu Rocket and it went from 60 to like 120 FPS!

Link to comment
Share on other sites

  • 2 weeks later...

What if the gameplay itself is too fast? My games run at freakin 60.3FPS and the game play is ridiculously fast... Here is my PC specs:

 

Northwood Pentium 4 Processor 2.8GHz *OC'd to 3.2GHz*

Windows XP Professional SP2

ATI Radeon 9250 128MB

1GB RAM

 

I'm currently playing Resident Evil Code Veronica on NullDC. Another problem I'm running into is some major graphical errors on this game also...here a picture of what I'm talking about:

Thiscrap.jpg

That pictures shows where Claire has taken the Golden Lugers out of it's holders in the mansion. I also get that graphical error exiting the submarine and going towards the airport *or where you obtained the Biohazard Card*. I think it has to do with the waves that the gas makes in that room and the waves the water makes after exiting the sub...either way, it's a temporary problem...and the only way to maneuver around that is by moving a little bit, then going into the menu screen and looking at the map to see which way your character is facing and how far he/she's walked...it gets really annoying.

 

But my main problem atm is the FPS...I figure I can fix the graphical errors with a better video card...but is there a way to limit the FPS where the games don't go stupidly fast?

Edited by eleminator30
Link to comment
Share on other sites

Do you have Sync Audio enabled in the Aica plugin? Also, if you are using Chankast's audio plugin, the game will be too fast since the plugin doesn't have any settings to sync the audio to the video (happens in most games but some are unaffected).

 

The garbage graphics problem is also present in other games as well, and I think it has to do with certain graphical effects that he Dreamcast's CPU puts out. No, there's no way of fixing it, at least I haven't found a way. Then again, using Chankast's video plugin might help.

 

 

Or it might not.

 

Your graphics card should be adequate enough for DC emulation.

Link to comment
Share on other sites

Do you have Sync Audio enabled in the Aica plugin. Also, if you are using Chankast's audio plugin, the game will be too fast since the plugin doesn't have any settings to sync the audio to the video (happens in most games but some are unaffected.

 

The garbage graphics problem is also present in other games as well, and I think it has to do with certain graphical effects that he Dreamcast's CPU puts out. No, there's no way of fixing it, at least I haven't found a way. Then again, using Chankast's video plugin might help.

 

 

Or it might not.

 

Your graphics card should be adequate enough for DC emulation.

I have Sync Audio enabled in the Aica plugin and gameplay still moves too fast with both the NullDC plugins and the Chankast plugins.

Link to comment
Share on other sites

for those tweaks about refresh lock and everything, just download and use ATi Tray tools, it works on all video cards and it offers alot of other useful tweaks too

I tried that one and the one above...it messed up my screen resolution BAD...I did a system restart *restarted my PC* and the effects stayed...I had to do a full system restore...I guess this only works for some systems?

*not like I need it anyway...lol my games aren't running slow at all....not even the least little bit*

 

Ok I fixed the RECV issue. Took some figurin and it came down to this.....it was a problem with the image LOL. Figured it out cause on CD2, everything started moving normal instead of super fast. So I took my back up CD and remade the image of CD1 and then it started workin fine...so I trashed the first image cause it was CRAP lol.

Edited by eleminator30
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...