Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Haldrie

VisualBoy Advance Save Problems

Recommended Posts

hey..

 

juz starting to enter the world of pokemon...

i'm juz a beginner wid stuff like this..

 

can anyone help me solve my problem..i've been reading posts about my problem but i can't understand a thing..(sorry guyz, juz trying to have fun..)

 

i started fire red and i juz can't save during the game...i save using the "shift f1,f2,f3,f4,f5,f6,f7,f8,f9 thing"...

then when i defeated the elitefour..the game restarted and i it juz asks me to start the game all over!!!

it says smoething like this-"1m sub-curcuit thing...." and when i save the gba way it shows a Save Error post and asks me to have a back-up thing...

juz pls tell what to do STEP BY STEP...hehe

 

btw, my vba is 1.8 and i also don't know what is an IPS patch..hehe..

i juz don't want to start my game all over again..pls help me continue the one i started...

 

thanks!!!! :P

Share this post


Link to post
Share on other sites

Please read this thread from the beginning, especially posts made by Haldrie.

Share this post


Link to post
Share on other sites

As Agozer said, all the info you need is already in this thread. From what I just read you have been using save states which are only to be used as a last resort and only if you cannot save in-game. The game's own save feature should be what you use instead which is done just as if you were playing the game on a real GBA.

 

When you beat the Elite Four the game saves and the resets and has you load your save again to start the next section of the game. This is the main problem that people have with these games and the step listed in the various post in this thread are all you need to fix the problem.

 

Since you said you don't know about an IPS patch then chances are you don't have one so you can ignore any reference to it as it only deals with those people that may be using the awful save patches that are floating around for these Pokemon games. You can get more info from the link at the bottom of my signiture if you are still curious about them though.

Share this post


Link to post
Share on other sites

Same problem here, I've just beaten the Elite four in Pokemon FireRed and after credits, i am not able to continue. I have read your guide, but I want to ask if it's possible to continue in the game, if i make that vba-over.ini or the only chance of continuing after beating the elite four is to start a new game?

 

I used save stats and normal saves also.

 

And another question.. with what i am supposed to fill that vba-over.ini file? If I play pokemon FR do I have to fill there:

Pokemon FireRed (U)

[bPRJ]

flashSize=131072

 

just these lines?

 

 

What i did after reading your guide is, that i have deleted all my save stats, then created vba-over.ini, filled it with lines above, opened VBA.exe, opened pokemon firered, loaded save closely after beating elite four, but i still receive 1M-sub... error message. Ye and 1 time I haven't received that message, I just saw some kind of parallel lines insteod of that error message but when i pressed start button it has done the same thing again, restarting the game.

Edited by Wilcox

Share this post


Link to post
Share on other sites

The only way it will work is if you start the game all over again from the begining. I know it is unfortunate but the current save file that VBA is loading is still set to the old format and cannot be fixed at this time. The only way the vba-over.ini file will take effect is if there is no other save file to load so it can create a new save file in the correct format.

 

[EDIT]

By "start the game all over again" I mean that you have to delete (or backup elsewhere for possible future fixing) the .sav file for FireRed (and any other Pokemon games you have saves for as they too are most likely corrupted). If someone manages to find a way or write a program to fix these corrupted saves (or the save states) this will be the first place I mention it but in the years since posting this I have not found any other solution.

Edited by Haldrie

Share this post


Link to post
Share on other sites

Hi guys

 

I'm fairly sure I'm missing something obvious but I've read all 10 pages of the thread and tried following the instructions therein, but I'm getting nowhere. Hopefully, by giving you the opportunity to dance on a noob's head, I'll make some progress on getting this yoke working.

 

I'm using VBA 1.8.0 beta 3.

I'm trying to get a 128K save in Fire Red, Ruby, Emerald or Leaf Green.

I've set up a vba-over.ini file as directed in the thread, and confirmed that the settings are being picked up for each game by the emulator in Options \ Emulator \ Game Override. I've confirmed that the game codes in the over.ini match the codes seen in File \ ROM information. For good measure I've also set the default save type to Auto / 128K since I'm not emulating any other games at the moment. There are no pre-existing saves, battery files, quick-saves etc. and I'm starting a new game from scratch every time I attempt this. Auto IPS patching is off.

 

I start a new game then save through the game interface after going through the intro. I get a 64K save file every time and a corrupt save message on every reset. I've tried inflating the save file to 128K by appending a copy of the save onto itself and ensuring all options in the emulator are looking for a 128K save but it's the same, as soon as I save in-game it goes back to 64K. I've no idea if the ROMs are patched, but they're from different sources as I figured that would give me a fighting chance of getting at least one that wasn't in some way patched.

 

Have I missed something? Failing that, if I can get my hands on a working 128KB save and use that to start the game up then create a new game, would that overcome the problem? (if so, any offers?)

Share this post


Link to post
Share on other sites
Hi guys

 

I'm fairly sure I'm missing something obvious but I've read all 10 pages of the thread and tried following the instructions therein, but I'm getting nowhere. Hopefully, by giving you the opportunity to dance on a noob's head, I'll make some progress on getting this yoke working.

 

I'm using VBA 1.8.0 beta 3.

I'm trying to get a 128K save in Fire Red, Ruby, Emerald or Leaf Green.

I've set up a vba-over.ini file as directed in the thread, and confirmed that the settings are being picked up for each game by the emulator in Options \ Emulator \ Game Override. I've confirmed that the game codes in the over.ini match the codes seen in File \ ROM information. For good measure I've also set the default save type to Auto / 128K since I'm not emulating any other games at the moment. There are no pre-existing saves, battery files, quick-saves etc. and I'm starting a new game from scratch every time I attempt this. Auto IPS patching is off.

 

I start a new game then save through the game interface after going through the intro. I get a 64K save file every time and a corrupt save message on every reset. I've tried inflating the save file to 128K by appending a copy of the save onto itself and ensuring all options in the emulator are looking for a 128K save but it's the same, as soon as I save in-game it goes back to 64K. I've no idea if the ROMs are patched, but they're from different sources as I figured that would give me a fighting chance of getting at least one that wasn't in some way patched.

 

Have I missed something? Failing that, if I can get my hands on a working 128KB save and use that to start the game up then create a new game, would that overcome the problem? (if so, any offers?)

If you've gone to these lengths to get a correct save file then chances are that your rom is patched. I can only suggest at this point to try and find a new copy from a better source. I cannot tell you where since it is against the rules to do so. If you still want to try to use a 128K save (which will work as long as it is in the correct folder and is named the same as the rom file) then I can upload one for you.

Edited by Haldrie

Share this post


Link to post
Share on other sites
If you've gone to these lengths to get a correct save file then chances are that your rom is patched. I can only suggest at this point to try and find a new copy from a better source. I cannot tell you where since it is against the rules to do so. If you still want to try to use a 128K save (which will work as long as it is in the correct folder and is named the same as the rom file) then I can upload one for you.

 

Whaddyaknow? I borrowed a different rom from a mysterious benefactor and I get a 128K save straight away. I can't believe I was that unlucky that I've pulled 4 patched ROMs from 4 different sources but at the same time it's working now and it wasn't working before - It's always that one thing you don't bother double-checking... Ta very much!

 

Edit - out of interest, I appended a 64K save on to itself with "copy /b" to make a 128K save, then renamed it to match the unpatched ROM name. When you load the unpatched ROM you get the corrupt save error as normal, but after saving in-game it created a 128K save that doesn't give errors on startup. Don't know if that's news or not but the impression I got from earlier in the thread was that this wouldn't work and you'd have to restart your game... Ta daaaa!

Edited by nunberry

Share this post


Link to post
Share on other sites
If you've gone to these lengths to get a correct save file then chances are that your rom is patched. I can only suggest at this point to try and find a new copy from a better source. I cannot tell you where since it is against the rules to do so. If you still want to try to use a 128K save (which will work as long as it is in the correct folder and is named the same as the rom file) then I can upload one for you.

 

Whaddyaknow? I borrowed a different rom from a mysterious benefactor and I get a 128K save straight away. I can't believe I was that unlucky that I've pulled 4 patched ROMs from 4 different sources but at the same time it's working now and it wasn't working before - It's always that one thing you don't bother double-checking... Ta very much!

 

Edit - out of interest, I appended a 64K save on to itself with "copy /b" to make a 128K save, then renamed it to match the unpatched ROM name. When you load the unpatched ROM you get the corrupt save error as normal, but after saving in-game it created a 128K save that doesn't give errors on startup. Don't know if that's news or not but the impression I got from earlier in the thread was that this wouldn't work and you'd have to restart your game... Ta daaaa!

 

I have a VBA and I am new, I had the same problem not being able to save battery saves whatsoever, however I have fixed that area and now have another question: can my save state (.sgm) from before the changes be made to work after the changes? Because I had made it quite far on fire red version and I would hate to have to start again from the beginning.

Share this post


Link to post
Share on other sites

IIRC, like many other emulator regardless of system, VisualBoy Advance stores SRAM contents in savestates, so that would probably mean "No".

 

Don't take my word for this though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...