Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Haldrie

VisualBoy Advance Save Problems

Recommended Posts

I realize there have been many fixes to the problem I am about to describe in this thread, but nothing seems to work for me.

 

I am playing Pokemon Emerald 386, a hack that allows you to catch every pokemon in the game...as long as you can get past the Elite Four.

 

Unfortunately, when I beat the Elite Four, allow the game to save my achievement, and restart the game to continue playing, the message "The save file has been erased due to corruption or damage" appears.

 

I realize this is because the emulator is saving the file in a 64K flash format, whereas it needs to 128K. However, even though I have the Flash 128K Option checked for the emulator, it is not able to save the game as a 128K flash file. Yes, while saving manually in the game, the file is 128K, but when I am forced to save after beating the Elite Four, the file is overwritten as 64K.

 

I thought maybe placing a vba-over.ini file in the same directory as the VBA would help override the game's tendency to switch back to 64K. I originally took a file linked from the beginning of the thread:

 

Pokemon Emerald (U)

[bPEE]

rtcEnabled=1

flashSize=131072

 

But this did not work. I thought maybe the first part was wrong, so I changed it slightly:

 

Pokemon Emerald 386

[bPEE]

rtcEnabled=1

flashSize=131072

 

Again, nothing changed. I could save as 128K until the game automatically switched back to 64K in the save after the Elite Four.

 

I don't think this Emerald 386 rom is different from others. Everything else works perfectly.

 

I've checked the game code, using VBA's Rom Information option, and it is [bPEE]. However, the Rom Information says that the game's title is POKEMON EMER.

 

I have the Real Time Clock setting on, if that matters at all.

 

Well, I've tried to be as specific and thorough as possible to show the exact nature of my problem. Thank you all for your time and trouble.

Share this post


Link to post
Share on other sites

If the game is a hack, it is different from others. Hell, even the game code can be hacked, as well as all the other header information as well.

 

Try VBA-M and see if that fixes anything.

Share this post


Link to post
Share on other sites

I now understand the problem. It seems that if you start out the game with the 128K option checked, you can load any savestates you make and then save in-game as 128K.

 

I think I started my game as 64K. If I load any savestate from that game and then save, it saves as 64K.

 

Is there any way to alter these old savestates so that they don't force in-game saves to be 64K?

Edited by snoopcat

Share this post


Link to post
Share on other sites

If you know how to hack savestates and SRAM, yes, otherwise no.

Share this post


Link to post
Share on other sites

ok, im a newbie here

 

happened to stumble upon this wonderful topic through another site

 

and i'd really hope that website you are creating will be up soon

 

it will definitely help the emulation community!

 

 

ok, here's my problem:

 

i get the usual message for my emerald game

"the save file is corrupted, the previous save file will be loaded"

and my leaf green:

"the 1mb circuit board...."

 

so for my emerald game:

so i basically have gotten to the elite 4

 

completed it and after the credits, the game said

 

"the save file has been deleted due to corruption"

 

ok, so my save file is deleted

 

but fortunately, i still have a save state of me outside Evergrande city

 

so of course im happy.

 

and i read all of your posts

 

saying that one has to delete his save file

 

but my save file has already been "so-called" deleted

 

but i still have that save state, which only saves the frame i was at, rite?

 

so can i put in ur .ini file and continue into the e4?

 

 

and also: i have found some strange files in my emerald folder

 

namely:'trm-pmeu.ips', and 'trm-pmeu.sa1'

(my emerald game is called 'trm-pmeu.gba', if u're wondering why it has that strange name)

 

what are they?

and, can they do anything to salvage the situation?

 

and my vba does not have a .ini file,

so do i have to create such a file?

and add in the extension .ini when i save that file?

 

and, if i see the 'Corrupt save' message on pkmn emerald

does that mean that my game cannot continue after elite 4?

_____________________

and i read that in this topic

 

the game changes itself to a 64k save just when u are saving during the hall of fame

 

so can i change it to a 128k just at that time so as to avoid the game deleting itself?

 

really need help...

 

and if all else fails, can someone send me a vba with that .ini file? my e-mail is er_yz94@yahoo.com or er_yz@hotmail.com

 

coz mine is rather old (version 1.4)

 

and my pokemon emerald is named 'trm-pmeu.gba', if that is needed for the construction of the .ini file.

Edited by eryz

Share this post


Link to post
Share on other sites

Hey there is even a simpler method I thought up to fix the 64k -> 128k problem... The games just really need 64k of save (at least those for those a patch exists, otherwise the ips patch could not work, it can't just shrink data down to 50%)

 

So that means: one part of the 128k is 64k-OLD and the other is 64k-NEW so the game really just backups savegames.

 

This makes it very easy...

 

just open up a command prompt and go to the right directory

 

in windows you need to do:

copy /b savegame.sav+savegame.sav fixedsave.sav

 

in linux or any other unix compatible os:

cat savegame.sav savegame.sav > fixedsave.sav

 

where savegame.sav is the current 64k save and fixedsave.sav will be the resulting 128k

 

those commands just will "glue" the 64k file to a copy of it and make a new file with the name fixedsave.sav

 

then just use the unpatched rom in a emulator correctly setup (128k flash support etc.) and the 128k save file (in VBA you can do Import>Battery File) ... Pokemon might complain about a damaged save the first time you load that new 128k one, but after that everything works fine :(

 

This was all tried with my Emerald on another flashcard that needed 64k (to do evolving by trading - which I can start now :clapping: )

Share this post


Link to post
Share on other sites

hi,

I'm new here and I'm having a problem with my pokemon emerald and ruby saving files.

I tried to follow the instructions on page one, but I'm on a mac and I'm not really familiar with all that programming language stuff, so can someone help me out?

 

When I play the game and I save it, there is no problem. At least, it looks like there is no problem. because when I quit the VBA, it gives me the following error:

Error creating file Battery Saves/trm-pmeu.sav

And when I re-open the pokemon file, the game has, indeed, not been saved.

 

Here's an image showing my preferences and, well, basically anything related to my VBA files:

http://s36.photobucket.com/albums/e19/Tele...beelding2-1.png

 

I really hope someone can help me out.

Thanks for at least reading this.

Share this post


Link to post
Share on other sites

There is nothing related to programming in that first post. simply create a file named vba-over.ini, then copy and past the contents of the CODE block on the first page into that file. save the file.

 

Regarding that erro message you get, I have a feeling that it doesn't have anything to do with the game, and more to do with you not having write access to the folder where VBA tries to create the save file.

Share this post


Link to post
Share on other sites

Hi, I'm new here, and I was wondering something about Pokemon Mystery Dungeon: Red Rescue Team (U).

 

I started the game unable to save, but just ignored that and saved using the VBA save and load. I got pretty far into my game, but now realize I can't get any wondermails or be at the starting screen.

 

I also realize that there were posts like this before, but I think the case was slightly different.

 

So I followed the instructions on the first post of this thread, and was able to save on a new save file. However when I load my old file, I still can't save. Now my question is, is there any way I'll be able to save on my old file? Or will I have to start over?

 

Thanks very much.

Share this post


Link to post
Share on other sites

You need to start from scratch, and remember to delete all traces of your old saves.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...