Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Last Exile

Some basic questions concerning Kawaks

Recommended Posts

I've always used NeorageX 0.8c and ECGC to run my NeoGeo roms, but the new Kawaks (1.53) has much better rom support than before so I've decided to jumped ship.

 

I'm new to Kawaks so please excuse my noobish curiosity, here are a few things I was wondering:

 

 

1/ Are there Kawaks specific romsets like there are for NeoRage?

 

2/ In the case of kof2000 it accepts the 77MB set (MAME rom) rather than the 40MB one (NeoRage). So is it correct to presume that when it comes to kof2001 & 2002 I will need to find the larger romsets for them to work in Kawaks? I ask this because all I can find are the small romsets for these two games and none of them work in kawaks, even though they are now supported.

 

3/ I've also downloaded Kawaks 1.45 + Loader which allows mslug4 & 5 to work. So to run svcplus/samsho5/kof2003 do I need to find specific loaders for each of them? If so I cannot find them anywhere.

 

4/ Why is it that the same mslug4 rom that works in 1.45 Loader doesn't work in 1.53, even though mslug4 is now apparently supported?

 

5/ I remembered when I used to use MAME a long time ago that everytime an update was released the list of compatible roms would change, which meant re-downloading certain roms to keep up to date (The reason why I gave up MAME). Is this also a problem when using Kawaks? The fact that it takes MAME roms and is regularly updated suggests yes...

 

6/ Am I a frickin' idiot? :banghead:

 

 

Sorry about this dumbass post, but I've been wondering about these points ever since I first tried kawaks, I only gave it up cos NeoRage roms were much easier to find. I'm interested because Kawaks is obviously a much better emulator technically and I want to use it, I just need to know which roms to get.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Not to offend But you should stay with NRX and it decrypted sets (Not Correct Sets)

 

 

The kawaks 1.45 ( Loader ) works for some of the neogeo games simply because it uses decrypted sets like NRX Where Kawaks 1.53 and Mame use encrypted sets which are bigger in file size.

Since you only care about playing the game then I suggest you stay with NRX .

 

Any neogeo game made after 1998 were encrypted That is why NRX died and is no longer offically supported Because it only emulates decrypted sets

Share this post


Link to post
Share on other sites

Out of curiousity, what is ECGC?

Share this post


Link to post
Share on other sites

To answer each question as best I can:

 

1. Usually the same as mame but not always

 

2. I wouldn't presume anything. I can tell you what roms are needed, but as to whether they are encrypted or not, I couldn't say.

 

3. don't know

 

4. Loaders are unofficial, they are usually different from an official release.

 

5. Yes

 

6. No

 

The rom requirements for kawaks are very similar to mame. All that matters is that each zipfile has the correct name, and that each rom is the correct size and crc. The filename of an individual rom is irrelevant. Kawaks, like mame, has parent and child relationships.

 

The changes per version are not as profound as with mame. For example, the other day I downloaded the complete set for kawaks 1.53 ; when checked against 1.52 there was one game changed (matrim). Against 1.50 there was 4 games missing. Against the unofficial 1.48dev, there are dozens of differences.

 

Kawaks is good on older computers; on my 333 all kawaks games run at what appears to be full speed (no fps display available). On mame, most neogeo games run at 4 fps, which is noticeably slow.

 

I think Kawaks is a good emulator, it all depends if you consider the rom requirements too difficult.

Share this post


Link to post
Share on other sites
Out of curiousity, what is ECGC?

I think it's the name of the team that hacked NRX to allow those games.

I tot it is an emulator :banghead: Oh well.....

Well, it is an emulator; EGCG NeoARGEx is it's name. EGCG is the name of the team that made it.

 

Last Exile: 3. No, one loader will work for all games.

 

6. No, but like James said, if you only care about playing the games rather that correct emulation, stay with NRX.

 

Personally I could never get kawaks Loader to detect my sets that I added into the DAT. So I switched to Nebula Loader and it works fine. If you want to play you NRX sets in Kawaks Loader/Nebula Loader, so can do so without getting new sets just by modifying Asr.dat or Neogeo.dat

Edited by Agozer

Share this post


Link to post
Share on other sites

Also, you should get RomCenter to check your ROMs against MAME and Kawaks dats. It's a very useful tool. Get it at -bleh-

Mod's edit: You know, as horrible as it sounds, the RomCenter homepage has links to rom sites.

Edited by Agozer

Share this post


Link to post
Share on other sites

Last exile, if you're quite familiar with computers, I might suggest compiling your own version of FBA or MAME. That way you'll be using a non-crappy emulator and be able to use the roms you have.

BTW. there are ways to convert decrypted roms to encrypted ones if you have enouh ram and care about correct emulation. :banghead:

Share this post


Link to post
Share on other sites

Oh crap, I forgot about RomCenter's rom link. I thought they were legit... :banghead:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...