Jump to content

MAMEoX with 090 CPS2 Support!


djohng
 Share

Recommended Posts

Have you edited driverlist.h to add the new drivers?

 

I also only use orignal encrypted p roms for my MAMEoX build, and use both dercypted v and decrypted c. And I still named them nd set. That doesnt matter in fact:)

I am indeed editing driverlist.h. I can replace the drivers already listed there with new ones and they show up fine. But if I just add a driver from scratch it doesn't show up at all. Older versions of FBA-XXX listed the drivers in burn.cpp and you could add new ones by editing this file, but the newer builds don't do this. :D

 

Yeah, I know the set names don't really matter but I'm picky like that. Sets like s1945pd and nitdd use this naming convention so I thought other Decrypted C sets should as well. Keeps things nice and consistent. :rolleyes:. As soon as I figure out how to add drivers properly I'll have it so the build supports sets with either name.

Edited by + T +
Link to comment
Share on other sites

  • Replies 208
  • Created
  • Last Reply

Top Posters In This Topic

My SS5 Special romset works fine with no sound problems. Make sure you have the latest V and M rom dumps since, in earlier releases of the romset, these roms were taken from SS5 resulting in messed up sound.

 

Quick update: I've also now acquired the correct mslug5 encrypted P ROMs (many thanks Thraxen :) ) so the source has been changed so mslug5nd is now mslug5d in keeping with the other romsets.

Edited by + T +
Link to comment
Share on other sites

Have you edited driverlist.h to add the new drivers?

 

I also only use orignal encrypted p roms for my MAMEoX build, and use both dercypted v and decrypted c. And I still named them nd set. That doesnt matter in fact:)

I am indeed editing driverlist.h. I can replace the drivers already listed there with new ones and they show up fine. But if I just add a driver from scratch it doesn't show up at all. Older versions of FBA-XXX listed the drivers in burn.cpp and you could add new ones by editing this file, but the newer builds don't do this. :(

 

Yeah, I know the set names don't really matter but I'm picky like that. Sets like s1945pd and nitdd use this naming convention so I thought other Decrypted C sets should as well. Keeps things nice and consistent. :). As soon as I figure out how to add drivers properly I'll have it so the build supports sets with either name.

 

You can edit driverlist.h; but this file is actually autogenerated by the scripts listed in the fbaxxx tools section. It also alphabetizes the games.

 

I'm not sure why your added games don't show up...even editing by hand should make them show up, as long as, the names are unique and match the driver names...this is the method I use for beta testing, and then I run the scripts once everything works with a new driver.

 

Remember...in driverlist.h, there are 3 sections which require having the driver listed. Are you sure you are adding the new driver name in each section??

 

-djohng

Link to comment
Share on other sites

Remember...in driverlist.h, there are 3 sections which require having the driver listed. Are you sure you are adding the new driver name in each section??

Perhaps that's it. I'll double check and give it another try. Thanks djohng :(.

 

Oh and one other thing I forgot to mention about my build, romsets that use decrypted C roms all now use the set's S rom for the text layer rather than having FBA-XXX extract the data from the Cs. This speeds up load times a little but the main reason for it is just because I'm strange and prefer it that way :).

 

EDIT: Yes I obviously wasn't adding the driver names in all the required sections. It works fine now. I'll update the source soon with a version that supports the 'nd' sets once again just for the sake of completeness.

Edited by + T +
Link to comment
Share on other sites

And just in case anyone who doesn't have the necessary tools to compile wants to try this build, I've made an IPS patch:

 

http://www.thraxen.com/emu1/fbaxxx_t_patch.rar

 

This is intended to be applied to the unpatched 02.01.2005 release. So basically you just download fbaxxx_02_01_2005.zip, replace the included default.ips file with this one, and run patchme!!.bat.

 

Keep in mind that the DATs generated by this build will no longer be accurate. So to find out which CRCs you need either turn CRC check on and let the emu tell you what you're missing or download the source and look in the d_neogeo.cpp file.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...