Jump to content

Raine 0.93.4 using keyboard autofire only work for 1 second


Augusto
 Share

Recommended Posts

Using keyboard and enabling autofire only work for 1 second. After 1 second even pressing the key not input will be done.

I not have information since what version that problem is happening.

Also I not understand if is an WINE problem.

If pressing an key button for charge attack work.

Tested with previous version using PS3 controller autofire works without problems. In moment not tested with current version.

Link to comment
Share on other sites

6 hours ago, Augusto said:

Using keyboard and enabling autofire only work for 1 second. After 1 second even pressing the key not input will be done.

I not have information since what version that problem is happening.

Also I not understand if is an WINE problem.

If pressing an key button for charge attack work.

Tested with previous version using PS3 controller autofire works without problems. In moment not tested with current version.

Well just tested with ddonpach using the keyboard, no problem, ddonpach is good to test that because continually pressing the fire button create a concentrated shot as opposed to the effect of the autofire (rapid shots).

Tested with autofire directly assigned to button1, and with autofire using its own input, both on the keyboard, no problem (tested with the linux version, I won't even test with wine for that).

By the way I got a report that fullscreen in the linux version was broken for quite a few window managers in linux, I didn't know that, it seems reports come very slowly for that, it's fixed in git for next version (at least for openbox which I tested directly and probably for kwin).

Edited by Tux
Link to comment
Share on other sites

Posted (edited)

Thanks for reply.
If holding a button not using autofire works, but holding a button for autofire not works.
I not have information if is anything in WINE, but works holding button not having autofire.

Another strange problem with autofire happen in 2 ways where the autofire button stop working.

1 ) Starting Raine randomly autofire not are possible work in an game where in previous started Raine was saved autofire.
That happen in several previous version. In moment I not see happening in 0.93.X.

2 ) Start Raine and save autofire settings for an game. Close and restart Raine.
Now access Input menu and see if the autofire was saved from previous Raine session.

See image 1.


If yes now try access the sub menu "Autofire controls" and return to submenu autofire.
Now autofire not work and not is possible configure the settings.

See image 2 in next reply

When that happen need force and Raine close using task manager or ALT+F4 because using closing normally Raine in next time the autofire config is broken needing delete raine config file.

1.jpg

Edited by Augusto
add text
Link to comment
Share on other sites

Posted (edited)

@Robert

Thanks for hidden, but excuse me the correct reply to remove hidden is the previous

"Please Tux you can remove that reply ?

I had click to post and strangely had posted 2 times. "

 

The second post in sequence not is to be removed hidden because have an image shared to Tux.

Please if possible allow second post to be viewed.

 

Edited by Augusto
edit
Link to comment
Share on other sites

I don't understand everything here, but the 2 pictures are equivalent, it's just the the order of what is displayed which is different, but the information is the same.

Link to comment
Share on other sites

When autofire work the menu is exactly how image 1, but when autofire is broken the autofire menu is shown how image 2.

Even if seems that two images are same trying changing autofire setting when the menu is how image 2 autofire not work.

Link to comment
Share on other sites

12 hours ago, Augusto said:

When autofire work the menu is exactly how image 1, but when autofire is broken the autofire menu is shown how image 2.

Even if seems that two images are same trying changing autofire setting when the menu is how image 2 autofire not work.

this is really going nowhere. 2nd screen is just what is displayed when the settings of the autofire have been saved and reloaded, and it works at least on the game I tested, I never bothered to find why the display order changed by the way, and I don't plan to.

You tried that on kof98 apparently, it's not exactly the ideal game to use autofire, the autofire is done for shoot'em ups usually... !
I guess you would need to at least remap the autofire button to something else so that you can continue to use the normal button without autofire and switch to autofire only when really needed. kof98 is made to use combos, not pressing the same button as fast as possible, it wouldn't make much sense here.

Try that on a shoot'em up, it will be easier !

Edited by Tux
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...