Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Mooney

WARNING: 3.71 M33-2 USERS

Recommended Posts

Older ones carried the OE label. Newer ones are called M33. They're basically the same- made by the same guy. He just changed his name to M33 at one point to avoid the cops.

 

If you install a CFW, you can just as easily install a different one over the top afterward. Just because I'm overly cautious, I'd say install 3.51 M33, get its 3.51 M33-6 update. It's not the latest one out though. If you don't like it you can go to another- this is just the one my gut thinks is the safest right now.

 

Other less paranoid people will tell you to use a newer version. Your call, and like I said you can always jump to another version afterward.

Share this post


Link to post
Share on other sites
Older ones carried the OE label. Newer ones are called M33. They're basically the same- made by the same guy. He just changed his name to M33 at one point to avoid the cops.

 

If you install a CFW, you can just as easily install a different one over the top afterward. Just because I'm overly cautious, I'd say install 3.51 M33, get its 3.51 M33-6 update. It's not the latest one out though. If you don't like it you can go to another- this is just the one my gut thinks is the safest right now.

 

Other less paranoid people will tell you to use a newer version. Your call, and like I said you can always jump to another version afterward.

Thanx guys, and since im new to this, il take the Overly Cautious Route to avoid any Mishaps. But will i be able to do all i want to with 3.51?

 

Also, kind of off topic, does the Nintendo Wifi Adapter work with the PSP wifi?

Share this post


Link to post
Share on other sites
Thanx guys, and since im new to this, il take the Overly Cautious Route to avoid any Mishaps. But will i be able to do all i want to with 3.51?

 

Yep it can play PSP ISOs, homebrew / emulators, and converted PSX games with no problems.

Share this post


Link to post
Share on other sites
Also, kind of off topic, does the Nintendo Wifi Adapter work with the PSP wifi?

I highly doubt it.

Share this post


Link to post
Share on other sites

My PSP is still using the 1.5 firmware when I bought it. I still haven't got the guts to use a custom firmware.

 

Are there really any advantages besides playing PSX games and the newest PSP backup games?

Share this post


Link to post
Share on other sites

It let you use most of the features and updates that Sony official updates have. meaning, you can enable WMA, Flash, Internet, choosing fonts and so on

Share this post


Link to post
Share on other sites
My PSP is still using the 1.5 firmware when I bought it. I still haven't got the guts to use a custom firmware.

 

Are there really any advantages besides playing PSX games and the newest PSP backup games?

 

Not really. But it streamlines the whole process, saves you having to jump around to different firmwares and lets you load everything you can think of from the Game cross bar.

 

Oh and you can encode videos at 480x272 at 768kbps+ with CFWs- you can't with Sony's. You can't even playback AVC on 1.50 actually.

Share this post


Link to post
Share on other sites

My PSP is still using the 1.5 firmware when I bought it. I still haven't got the guts to use a custom firmware.

 

Are there really any advantages besides playing PSX games and the newest PSP backup games?

 

Not really. But it streamlines the whole process, saves you having to jump around to different firmwares and lets you load everything you can think of from the Game cross bar.

 

Oh and you can encode videos at 480x272 at 768kbps+ with CFWs- you can't with Sony's. You can't even playback AVC on 1.50 actually.

Have they been able to implement direct AVI/MPEG playback?

Share this post


Link to post
Share on other sites
It let you use most of the features and updates that Sony official updates have. meaning, you can enable WMA, Flash, Internet, choosing fonts and so on

 

what about game compatibility? (ie, games that require/force a certain firmware)

Share this post


Link to post
Share on other sites
what about game compatibility? (ie, games that require/force a certain firmware)

 

What about it? A CFW lets you play any game that requires the version the CFW is based on. But then try showing me a game that requires 3.60 or higher~

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...