Jump to content

Raine 0.93.5


Tux
 Share

Recommended Posts

On 6/28/2022 at 8:11 AM, Tux said:

and for adaptive vsync, it's used if supported by your hardware, just run a game, then go to video infos. If it's supported you'll have the last line which reads :

Opengl vsync : Adaptive

But it's not a big deal anyway, it's just about enabling vsync when the fps becomes too high and disabling it when it's too low, normally it's never too low in raine.

We don't like to wait for anything in raine, so we use double buffer here, and it's possible to disable it in the menus, it allows to display a frame while we work on another one, and the swapping of frames is done automatically when a vsync arrives. It works well if you don't have a crappy monitor like mine which doesn't support 60 fps, but it's not far, it's 59.88, that's why I added an option to be able to lower the fps used by the drivers.

Hello Tux! I guess I found a good place in a game to clearly see the issue of vertical sync. In this stage in KOF97 there is an energy beam in the center of the stage as well as other beams around the scenario that are clearly affected by the way v-sync currently works. I've recorded a short video using both my desktop environment capture and my webcam. The screen tearing is more noticeable in the webcam, take a look:
https://drive.google.com/file/d/14_WER63Hnp4jSn_9X7olbpMgJ7aD3CeU/view?usp=sharing

As you see, the tearing in the light beams are very noticeable in the webcam, aren't they? You also have tearing when the red and white colors start flashing after a character is defeated. When I go to "Video info" it shows it is using "adaptive", and if I disable double buffer unfortunately nothing is changed.

So I went and tried to add Raine to the programs list in the Nvidia Control Panel and then forced it to use V-sync "On". This way I could no longer see the screen tearing, it becomes virtually unnoticeable.

Would it be possible to do this within the emulator? Maybe you could allow us to change the v-sync to "On" instead of "Adaptive" and this could fix this issue? Anyway, I guess at least it would be more user friendly than messing with the driver settings.

For comparison, here's how it looks in FBNeo:
https://drive.google.com/file/d/1VbwIqy5cF8qXdIcmCDLvet-5-DszSAZd/view?usp=sharing

This is mostly the result I get in Raine when I force the V-sync option to "On" in the Nvidia settings.

Thank you so much for your work.

Link to comment
Share on other sites

Batrider, the intro sequence, is probably the best game to see screen tearing, they have some big text the size of the screen scrolling rapidly horizontally, that's by far the worst thing to display if you have screen tearing, and I don't have some.

Anyway as already said, not the right time to do anything about raine for now.

Link to comment
Share on other sites

  • 4 weeks later...
On 8/12/2022 at 6:09 AM, mer-curious said:

Hello Tux! I guess I found a good place in a game to clearly see the issue of vertical sync. In this stage in KOF97 there is an energy beam in the center of the stage as well as other beams around the scenario that are clearly affected by the way v-sync currently works. I've recorded a short video using both my desktop environment capture and my webcam. The screen tearing is more noticeable in the webcam, take a look:
https://drive.google.com/file/d/14_WER63Hnp4jSn_9X7olbpMgJ7aD3CeU/view?usp=sharing

As you see, the tearing in the light beams are very noticeable in the webcam, aren't they? You also have tearing when the red and white colors start flashing after a character is defeated. When I go to "Video info" it shows it is using "adaptive", and if I disable double buffer unfortunately nothing is changed.

So I went and tried to add Raine to the programs list in the Nvidia Control Panel and then forced it to use V-sync "On". This way I could no longer see the screen tearing, it becomes virtually unnoticeable.

Would it be possible to do this within the emulator? Maybe you could allow us to change the v-sync to "On" instead of "Adaptive" and this could fix this issue? Anyway, I guess at least it would be more user friendly than messing with the driver settings.

For comparison, here's how it looks in FBNeo:
https://drive.google.com/file/d/1VbwIqy5cF8qXdIcmCDLvet-5-DszSAZd/view?usp=sharing

This is mostly the result I get in Raine when I force the V-sync option to "On" in the Nvidia settings.

Thank you so much for your work.

Maybe a problem with adaptive vsync ? Well we both have an nvidia and I almost never see any tearing (except sometimes very briefly in a windowed mode). I can always add an option to just ignore adaptive vsync, and you're gonna be the happy tester...

edit : "forced" is added to the double buffer options, the default is still "yes" which tries to use this adaptive vsync.

Edited by Tux
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...