Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
+ T +

FBL 1.4 pixel perfect ini discussion

Recommended Posts

Hello,

 

Indirectly, that what was causing the issue. This will mainly affect NeoGeo games. Please see the example below:

 

When I opened the WILLOW game with an INI from 1.3, this is what 1.4 did to the last three lines of code:

 

AspectCorrect=13

SNKBIOS=0

XBINPUT_DEADZONE=0.540000

 

It either flops the AspectCorrect and SNKBIOS markups or just doesn't move the 13 down to the SNK line. This must also play havoc with the screen size since FBL is likely reading the '13' as just a '1' which means YES COMPRESS THE SCREEN. Cos, this is why your setting were so out of wack and you couldn't fix them.

 

By manually pre-fixing the INI to read correctly before opening the game, I was able to successfully import the INI to 1.4. It read:

 

AspectCorrect=0

SNKBIOS=13

XBINPUT_DEADZONE=0.540000

 

Hopefully, this can be fixed for 1.5. ;)

 

I know people are probably still saying 'why the heck does this matter' - well, it does! :D

 

Here are two images from WILLOW that show how the screen size is wrong. It focuses on the text, not the horizontal distortion that you would see throughout the game. This is the easiest way to illustrate the importance of accurate screen size. Since old games had limited real estate, the type design doesn't lend itself to much scaling - especially if scanlines are in the picture. This makes the text become blurry and, in some cases, unreadable. See below:

 

INCORRECT:

 

willowincorrect.jpg

 

CORRECT:

 

willowcorrect.jpg

 

Thanks again T for putting up with all our nitpicking!

Edited by PhilExile

Share this post


Link to post
Share on other sites

I am completely lost on this...

Tried again to import INIs and the screen gets messed up.

 

I did pick my DINO.INI from FBL 1.3 and added the line

"AspectCorrect=0" and the game screen was imported 100% perfect

inside FBL 1.4.

 

But I tried same trick with Alex Kidd and Mutation Nation (NeoGeo)

and got no results.

 

Ouch...

I don't know what more to do.

 

=/

Share this post


Link to post
Share on other sites

Cos, if you were using the INIs I sent last night/earlier today, they are incorrect since they were made with 1.4. I just sent you a batch of the old ones we were working on this past winter. Those should work as long as you add that line in the proper place.

 

Talk soon

Share this post


Link to post
Share on other sites

If the problem is definitely the AspectCorrect line in the game ini being set to 13 then that should be an easy fix. So basically you're saying that if I can get FBL to add that line to a 1.3 ini with the correct value of 0 then your problems are solved?

Share this post


Link to post
Share on other sites

I think this is the problem, but lets wait to hear back from Cos - he is the definitive expert in pixel perfection. ;)

 

I'll try to test later today as well, but I have work to do now.

 

Thanks again!

 

If the problem is definitely the AspectCorrect line in the game ini being set to 13 then that should be an easy fix. So basically you're saying that if I can get FBL to add that line to a 1.3 ini with the correct value of 0 then your problems are solved?

Share this post


Link to post
Share on other sites

I took a look at this earlier and the ini problem is an easy fix... or, that is to say, would have been an easy fix.

 

Basically I should have put the AspectCorrect line at the bottom of the ini file. That way it would not mess up other settings if you tried to use an ini that didn't have it. Of course I could easily move AspectCorrect to the bottom of the ini in FBL1.5 and your 1.3 inis would work fine, but this will then mess up other settings in any game that has an existing 1.4 ini. ;)

 

So I face a bit of a dilemma. I should have done this right from the start, but, since I didn't, I can't see a way of going back without screwing up a whole lot of inis for a whole lot of people (which obviously I'm not going to do). Apologies for the oversight, I am still giving it some thought.

Share this post


Link to post
Share on other sites

Well, I can suggest two things:

 

1. Make the fix and put at the start of the read me file that you need to delete any INIs from the ini/emulation directory. This will avoid any hiccups between the revisions.

 

2. You could make two XBEs - one for users upgrading from 1.3 INIs and one for 1.4 users. This could get confusing though.

 

Thanks again, T!

 

 

I took a look at this earlier and the ini problem is an easy fix... or, that is to say, would have been an easy fix.

 

Basically I should have put the AspectCorrect line at the bottom of the ini file. That way it would not mess up other settings if you tried to use an ini that didn't have it. Of course I could easily move AspectCorrect to the bottom of the ini in FBL1.5 and your 1.3 inis would work fine, but this will then mess up other settings in any game that has an existing 1.4 ini. ;)

 

So I face a bit of a dilemma. I should have done this right from the start, but, since I didn't, I can't see a way of going back without screwing up a whole lot of inis for a whole lot of people (which obviously I'm not going to do). Apologies for the oversight, I am still giving it some thought.

Share this post


Link to post
Share on other sites

Nice to see that there is still some xbox development going on... ;)

 

I used to play a lot of FBL and Coinops some time ago, but then switched to MAME on a PC, only because on the PC there is a way of outputing non interlaced 15khz video resolutions to a standard CRT Scart-TV. The picture quality is so much better, and its "pixel perfect" by nature...(Soft15kHz)

 

I see that there is alot of "pixel perfect" stuff going on here. Maybe there is a way to output non interlaced resolutions on a xbox as well, that would make a lot of pixel perfect stuff obsolete. Have a look at http://forums.xbox-scene.com/lofiversion/i...hp/t662368.html

 

I would love to switch back to xbox FBL / Coinops because I totally miss the perfect user interfaces. They were just perfect compared to the PC stuff.

But the playing experience is so much better on a PC due to the low res non interlaced video output....

 

keep up the good work....

Share this post


Link to post
Share on other sites

There is - see the last post from that thread you posted:

 

Since it doesn't look like we'll be getting 240p output from the emulators in question anytime soon, I figured I would post this article:

 

http://scanlines.hazard-city.de/

 

The article explains that you can get an Extron Emotia scan converter to force the Xbox to output 240p.

 

1. You do need to either convert the Xbox's component signal to VGA or just get the Frosty VGA cables.

 

2. You then output the Xbox using VGA to the Emotia and select 480p output.

 

3. Flip a switch on the Emotia to "non-interlaced" and, boom, the flickering is gone and you now have scanlines, 240p.

 

This works great and Emotias are generally cheap, ranging from $50-$60 for the basic model and $120 for the new, "Super" version. Each does the same thing though, so try to get the cheaper one if you can.

 

Many thanks to Tobias!!!

 

Nice to see that there is still some xbox development going on... ;)

 

I used to play a lot of FBL and Coinops some time ago, but then switched to MAME on a PC, only because on the PC there is a way of outputing non interlaced 15khz video resolutions to a standard CRT Scart-TV. The picture quality is so much better, and its "pixel perfect" by nature...(Soft15kHz)

 

I see that there is alot of "pixel perfect" stuff going on here. Maybe there is a way to output non interlaced resolutions on a xbox as well, that would make a lot of pixel perfect stuff obsolete. Have a look at http://forums.xbox-scene.com/lofiversion/i...hp/t662368.html

 

I would love to switch back to xbox FBL / Coinops because I totally miss the perfect user interfaces. They were just perfect compared to the PC stuff.

But the playing experience is so much better on a PC due to the low res non interlaced video output....

 

keep up the good work....

Share this post


Link to post
Share on other sites

Hey Cos,

 

I just tried these same two games. See below for the results:

 

------------

 

ALEX KIDD (Set 2)

 

I launched this in FBL 1.3 to double-check my screen size. I noticed that the horizontal was very slightly off - probably due to my own error. For people that wonder, to check the horizontal screen size, you go into the screen setup screen and move the game screen back-and-forth from right to left with the left thumbstick. If you notice 'waves' appearing in the image as you do this, the horizontal size is either too big or small. By eliminating these waves, it stops distortions from appearing in-game - like a ship flying through an invisible line that offsets its pixels.

 

Anyway, I fixed it, copied it to my PC, added the AspectCorrect line of code, and copied it over the FBL 1.4. Unfortunately when I opened the game in 1.4, I noticed the horizontal screen distortion 'waves' had returned. However, adding the line of code definitely had a positive effect. Without it, the screen size would have been totally off - including the vertical size - which was not the case.

 

MUTATION NATION

 

I launched this in FBL 1.3 to double-check my screen size and it was perfect. I did the same to the INI as with ALEX KIDD and opened it in FBL 1.4. Again, the horizontal was very slightly off and the waves were there.

 

Cos, I think that WILLOW - a 16:9 widescreen game - imported 100% perfect because you already 'crushed' the horizontal pixels to fit the 4:3 space. If the size of the horizontal screen is slightly off, it probably doesn't show up as prominently as in games like ALEX KIDD and MUTATION NATION, which are both native 4:3.

 

------------

 

Basically, I think we solved the larger half of a two-part problem. I'm going to play around with FBL 1.4 skin INI and some other stuff to see if that has any sort of effect - even though I know its not supposed to. You never know. ;)

 

Update: OK - I tried a few things, including altering the INI to match 1.3 values, which Gilou9999 suggested. Nothing seemed to work.

 

Its my guess that something is different in the code that controls how the horizontal size is calculated. My first thought was that it was due to the rotation correction that Neo found, but I loading his build up and it didn't have the screen issue we are seeing in 1.4.

 

T, is there anything that you can think of at this point? It would have something to do with the horizontal size or position of the game screen. The vertical doesn't seem to be affected. Considering how small the variation is - I'm guessing it may be something that is only slightly different.

 

Thank you again!

 

 

I am completely lost on this...

Tried again to import INIs and the screen gets messed up.

 

I did pick my DINO.INI from FBL 1.3 and added the line

"AspectCorrect=0" and the game screen was imported 100% perfect

inside FBL 1.4.

 

But I tried same trick with Alex Kidd and Mutation Nation (NeoGeo)

and got no results.

 

Ouch...

I don't know what more to do.

 

=/

Edited by PhilExile

Share this post


Link to post
Share on other sites

You should add the extra line to the ini before adjusting the screen, not after.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...