Jump to content

Any chance of one libretro Raine core ?


Recommended Posts

Your emulator is very good for Neo Geo and others systems.
I not understand if is simple create an Raine libretro core thus running in Retroarch.
Very good seeing Raine running in Retroarch thus avoiding use WINE in Linux systems.

Thanks for read.

Link to comment
Share on other sites

You are the only one I know and probably the only one in the world using wine to run raine in linux !

There are unofficial builds for most distributions now, and you can get the binaries from the .tar.xz files on this site and you just need to install the dependencies so that it works, really not that hard...

Link to comment
Share on other sites

I had downloaded the source code and compiled, but after Raine need dependencies.

Not information about which are and also I had done a command that list all dependecies for an softwares and had installed the listed dependecies.

Even thus Raine not had worked.

I will try again.

I have done an search with not results about Raine builds.

You known any unofficial builds to say here ?

About libretro core was more to spread your emulator to Retroarch users.

I use Retroarch, but if not have any core using your Raine I not want use Neo Geo or other system there.

I use your emulator for an long time thus is my choice.

Again I not understand if is complex to port Raine to an libretro core since video and sound interfaces are pointed directly to Retroarch and not to OS plataform.

Retroarch is the solution for Linux users.


Thanks very for your reply and have an nice day.

Link to comment
Share on other sites

There is a link at the bottom of the download page about how to compile there : http://raine.1emulation.com/download/install.html

Libretro's goal is to make an interface for emus which don't need a lot of configuration, or almost none. In raine there are quite a lot of settings, most of this would be lost if doing that. I had heard someone had tried to make a module for retroarch from raine at a time, but I never had the opportunity to test it.

What's your distribution ? Most distributions ship a package for raine, even if not always up to date.

In a nutshell for linux you need almost the same packages as described for windows with mingw. I don't know the names exactly, but if it's a distribution with -dev packages like ubuntu it must be something like libsdl2-dev libsdl2-ttf-dev, libsdl2-image-dev, libcurl-dev, libmuparser-dev. By default it will be the 64 bits packages, so compile the 64 bits version, for that you need to edit the makefile and uncomment NO_ASM = 1, otherwise it will try by default to build the 32 bits version. That's about all there is to know. The 1st time you compile it is the hardest one, after that the dependencies almost never change and the compilation is quite fast even for an optimized build, if you have 16 cores, do a make -j15 at least and it should be very fast. After that you only need to update your sources with a git pull from time to time if you got this from git.

Edited by Tux
Link to comment
Share on other sites

Using Lubuntu (Ubuntu with LXQT) 20.04.3.

Downloaded the source from http://raine.1emulation.com/download/install.html
PKGBUILD need makepkg. Makepkg is an Arch Linux tool. Not makepkg download for Ubuntu.
The compiling files not are for Ubuntu.
You say "need to edit the makefile and uncomment NO_ASM = 1" and reading the makefiles not need edit because is uncommented NO ASM.
Trying copy the "raine" from bin to share/raine and not work.

I not understand if you have used Retroarch for few previous versions.
Retroarch current version allow cores to use several options with own core menu if the user need tweak settings.
Is allowed the core to use or change default video driver to own compatible video driver for example if the user have configured video to vulkan and the core not use vulkan when starting the core will change the video driver to an compatible.
Retroarch use SDL.
Have cores with several menus changing how Retroarch use inputs and which BIOS, video, sound and others settings.
Raine need BIOS configuration, cpu speed hacks and more few others settings.
Video scaling, aspect ratio, filters and sounds filters are done using Retroarch internally.
Is possible an Raine core having all required options.

Ubuntu and some others PPA repositories not have Raine =(

I not understand if is simple port Raine to Retroarch, but is the solution for users and also for others systems running Retroarch (PS2, PS3,PSP, mobile phones and others devices with slow cpu) because Raine is very fast and Retroarch only use MAME and another CPS1-CPS2-NeoGeo emulator and how MAME current version have slow performance in "old" devices is created an core using an extremely old MAME build.

I have in moment downloaded some tools to convert the pkgbuild to Ubuntu and see problems at point to continue running Raine using WINE.

I only want see if have an solution to run Raine without WINE and also seeing Raine running in Retroarch is the best solution and spread your emulator to others users having Playstation 2 or 3.
I use Retroarch and need say the systems Atari 5200 (A800), 7800 (ProSystem), 3DO (Opera) and Jaguar (Virtual Jaguar) having errors. Atari 7800 and Jaguar are cores using old emulator versions, but have anothers emulators (A7800 and Phoenix) with accurate and fast performance that not have an Retroarch libretro core.
I not understand if Neo Geo also is in list because I only use your emulator since an long time.

Link to comment
Share on other sites

Posted (edited)

Oh là la, all this is an insane mix of different things, the whole thing in a very bad english, this is going to be almost impossible to explain clearly in these conditions.

Anyway, I'll try at least this time :

 - Sorry I didn't know ubuntu didn't have any raine package, there might be one in the zillions of unofficial apt repositories out there, but no info about that. Oh well...
 - you edited the makefile, great, if the line is already uncommented, even greater, then you didn't even try to type make to see how it goes ?!!!!!! Go figure...
If you didn't try that and didn't tell why it didn't work in the 1st place, maybe it's a good idea to stop this discussion here...
 - you talk about moving the binary to another directory, try to launch it and just "it doesn't work". Sorry when you try to launch a binary, you do it from a terminal to see if there is any output, and in this case you try first to understand the output, if you post it here eventually put it between spoiler marks because it's probably be quite long. EDIT : on 2nd thought, no it should be only 1 line, the name of the shared library it didn't find. In fact you don't even need to run it to get this info, just open a terminal in the directory where the executable raine is and type ldd raine, it will give you a list of the shared libraries it need, and you will see "not found" on the right for those it can't find. So go to a website which allows you to find a package name from the name of a file inside it, and search for the shared libraries it can't find, if the site returns a package name, install this package. If one of the libraries can't be found (which is possible since arch linux evolves quite fast), you are out of luck and you can't run it.
 - I used retroarch once quite a long time ago when I tried a n64 emu, to finally give up and use the emu directly, it was better. The shaders in raine are from an old retroarch version, I don't even know which one, so there is some interesting stuff to get there sometimes. But don't ask me to make a retroarch module, I am just not interested.
 - and yes PKGBUILD is specific to arch linux, these files are not intended to be used in any other distribution, although they are easy to understand, it's just some basic ascii source describing what to do to build the package. I just said to use the tar.xz file, extract the binary from it, and try to run it FROM A TERMINAL OF COURSE so that you can see what's going on... !!! There will probably be some dependencies to install manually, but nothing too fancy, as I already said... Oh well... !!!

Edited by Tux
Link to comment
Share on other sites

Posted (edited)

Ok, since there is probably no way to explain this to you clearly, I have finally built 2 appimage with latest version inside, they are available at the bottom of the download page. These appimage contain the binaries with all their dependencies so they should work anywhere. Just download the one you want, make it executable (chmod +x from a terminal, or use any file manager to change the file permission graphically), and then run it, it should work.

I am not sure I'll build this regularly, depends on the feedback I get...

Well actually there is still a chance it won't work for you because one of the tool says my glibc is too recent, so if you have an old glibc, it's possible you'll get an error while trying to run this, the glibc is not included inside. Well I won't be able to do much about that, there is an old linux computer which has an old glibc also but it's not intended to package anything... Oh well, you'll tell me what you'll get, but I bet your glibc will be too old... ! (run it from a terminal if it doesn't work to see what the error message is !).

After some more digging, and some tests with the old pc here : it seems to require at least libc6-2.34, I have 2.35 in arch here, and your 20.04 ubuntu has 2.31, see there : https://packages.ubuntu.com/search?keywords=libc6
Sorry, you'll need to update, that's the problem with these distributions frozen in time, they get outdated and when it happens it becomes harder and harder to install anything which is not from their official package. You either need to compile it yourself here, or to update your distribution.

Edited by Tux
Link to comment
Share on other sites

... and the 2 appimage were just updated, I took my old laptop which has lost its cmos battery to test that, and I missed a few details yesterday, so these 2 were probably unusable except here.

Updated, for now they still require a 2.34 glibc, but they should work everywhere if you have that.

I might try to create a virtual machine to build with an old glibc, but it would be long and painful, so no promise here.
These distributions are really annoying, even when using debian I was using testing to be sure to be updated regularly... !

Anyway without any feedback on this I will just delete the 2 appimage files after a while and forget everything about this ! (but the appimage format is very good to package easily some application anyway).

Link to comment
Share on other sites

Posted (edited)

... and finally updated the x86_64 appimage to use a very old glibc 2.29 which I got from an ubuntu bionic image, inside a docker image !

The new appimage is named Raine-x86_64.AppImage

That was some crazy stuff to do, but there were almost no bad surprises in the end, except helping the image tool to use the correct libs in the end, but it went quite smoothly, it was just long to do.

For info since bionic is the oldest ubuntu in existence, it uses some very outdated packages by default, so I compiled manually sdl2, sdl2-image, and sdl2-ttf, the rest comes from the apt bionic repository. It also uses gcc 7 (we use gcc 11 now !), so well it might be a little slower than the latest normal binary then... ! I also had to select manually which libs to install for sdl2, I tried to take as much as possible, it seems quite complete.

I tested it using an old pc which has glibc-2.33, it works well, including opengl and the sound (and joysticks mappings are read correctly). So I assume it will work on any pc having at least glibc-2.29... !

Oh well, at least I learnt a few tricks by doing this... !

(I don't plan to do the same for the 32 bits image, you said you used the 64 image, so I'll stop here !).

Edited by Tux
Link to comment
Share on other sites

Posted (edited)


Firstly please excuse me for the long time for reply.
My previous installed OS had problems (Video acceleration using Mesa CPU acceleration instead Nvidia drivers) thus I had to reinstall all again not having internet access.

About your previous replies
"then you didn't even try to type make to see how it goes ?"
Yes doing make not work showing an error message about not having any make files to compile.

"The shaders in raine are from an old retroarch version."
Is possible copy Retroarch shaders to Raine ?
I will test copying from Retroarch current version.

"For info since bionic is the oldest ubuntu in existence, it uses some very outdated packages by default, so I compiled manually sdl2, sdl2-image, and sdl2-ttf, the rest comes from the apt bionic repository."
Have softwares only available version for Ubuntu bionic thus need search dependencies only released for bionic and after installing in Ubuntu 20.04. The software works.


Only to share memories, not demanding.
I known you emulator since 2001 (DOS version running in W9X) and remember having Bubble Bobble player characters in background.
One or other .. Had option to change the screen resolution or require install Scitech Display Doctor.
I remember how was fast your emulator.
After an long time not using computers for gaming. After 2010 had played again an Raine having an new look (current GUI version).
I want play using both digital and analog controls at same type, but not was possible.
Had anothers emulator allowing use both digital and analog controls in input config, but even thus I had continued using Raine because I like it and about your replies in forums.
I like also Retroarch, but not want play some systems if the core not is Raine.
That's the explanation because I had posted about an libretro Raine core.
Retroarch have alternatives, but Raine will continue being my choice.
Thus being Raine will continue being more choice for some systems.
Recently you had added analog and digital controls in input configuration. Amazing feature.
All is good for windows users, but Linux not had Raine version.
Here Raine was possible if using WINE. Is more time to emulator load and performance is fast.

I had tested the Raine previous appimage both 32 and 64 bits and not had worked, but the final version 64 bits works ! Not tested 32 bits version.
I have tested running samsho2 and kof98. Not crashes or etc. Run fast.
Need configure borderless no. If borderless is yes the screen is rendered size downscaled to 25 % of the 1366X768 screen.
Shaders are working.


Edited by Augusto
Link to comment
Share on other sites

Posted (edited)

I don't like very much this appimage thing anyway, the result is huge, about 7 times the size of the normal binary if I remember correctly, it's much better to have a system updated to something more recent.

For the analog inputs sadly very few games use these, mainly racing games (plus those using the equivalent of a mouse). The vast majority are digital only which is a pity in some cases.

By the way you shouldn't need any borderless window, fullscreen works now...

Edited by Tux
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...