Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Tux

Raine 0.91.7

Recommended Posts

whatever you can do, will be appreciated.

 

BTW,almost all hardware is still supported under win7, except maybe a few intel video cards...

Share this post


Link to post
Share on other sites
Posted (edited)

No problems with ryzen chipsets, usb and so on. Don't worry I made peace with my win10, I use it only to launch games or test raine from time to time, and it has all its advertising disabled, a restored and usable start menu, in this state it looks very much like win7 actually !

The best option to work around the display bug in fullscreen : disable opengl double buffer ! There is really a problem when leaving opengl using double buffer, so if you remove the option, the problem disappears.

I tried a borderless window to emulate fullscreen : bug still here, but with a border it doesn't show !
I tried explicitly turning double buffer off before displaying the gui : still doesn't work !

So the easiest way it to disable double buffer in fullscreen for now !

edit again : I was finally able to fix this display bug by using the idea I got while replying to your post : make the gui displayable in an opengl screen, I was lucky, there was some deprecated functions for that, it was not easy, I had to find what made them deprecated, undocumented stuff making them to behave in strange ways, and opengl double buffer which refuses to be disabled, but finally it works !

I can't release now because I made some more changes elsewhere which need to be improved, but it's a relief to finally have fixed this thing ! It's not even committed to git yet...
The gui doesn't look different in opengl, it's just some basic blit function everywhere, but at least now it's never hidden !

Edited by Tux

Share this post


Link to post
Share on other sites
On 7/8/2020 at 3:23 AM, Tux said:

No problems with ryzen chipsets, usb and so on. Don't worry I made peace with my win10, I use it only to launch games or test raine from time to time, and it has all its advertising disabled, a restored and usable start menu, in this state it looks very much like win7 actually !

The best option to work around the display bug in fullscreen : disable opengl double buffer ! There is really a problem when leaving opengl using double buffer, so if you remove the option, the problem disappears.

I tried a borderless window to emulate fullscreen : bug still here, but with a border it doesn't show !
I tried explicitly turning double buffer off before displaying the gui : still doesn't work !

So the easiest way it to disable double buffer in fullscreen for now !

edit again : I was finally able to fix this display bug by using the idea I got while replying to your post : make the gui displayable in an opengl screen, I was lucky, there was some deprecated functions for that, it was not easy, I had to find what made them deprecated, undocumented stuff making them to behave in strange ways, and opengl double buffer which refuses to be disabled, but finally it works !

I can't release now because I made some more changes elsewhere which need to be improved, but it's a relief to finally have fixed this thing ! It's not even committed to git yet...
The gui doesn't look different in opengl, it's just some basic blit function everywhere, but at least now it's never hidden !

This is great news! In your opinion, is this a solution or more like a work-around for that GUI bug?

By the way, perhaps you could reopen your PayPal donations page to feel more motivated to work in your program. As an example, I've recently donated US$5 to Redream emulator to be able to change the internal resolution of the games and I think it was worth it because Dreamcast games look way better in higher resolutions. Anyway, just an idea to another way to show how users are happy with your work. 😊

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, mer-curious said:

This is great news! In your opinion, is this a solution or more like a work-around for that GUI bug?

By the way, perhaps you could reopen your PayPal donations page to feel more motivated to work in your program. As an example, I've recently donated US$5 to Redream emulator to be able to change the internal resolution of the games and I think it was worth it because Dreamcast games look way better in higher resolutions. Anyway, just an idea to another way to show how users are happy with your work. 😊

It's not perfect, it's at the limits and even beyond of what can be done with sdl-1.2 and it shows, it's disabled in linux for fullscreen and borderless fullscreen windows because it creates amazing bugs there, but luckily linux doesn't have any problem with the gui in fullscreen so it's still fine, but you really feel why this api is deprecated here ! I just hope it will work the same in all windows, which is not guaranteed with windows... !

Thanks for the paypal idea, but it's nice to be able to make free things sometimes, and it would require a lot of people to give to make a real difference, so forget it for now, and enjoy the free things ! :)

Edited by Tux

Share this post


Link to post
Share on other sites
Posted (edited)

I just noticed (through emu-france) that you released Raine .91.8. I'll test it and report my findings!

Thanks!

Edited by jvidal

Share this post


Link to post
Share on other sites

Ok, tested it and it works! nice job!

On the other hand, the sound is not so good, you can hear a lot of "pops", especially when a game has just loaded...

Share this post


Link to post
Share on other sites
Posted (edited)
18 hours ago, jvidal said:

Ok, tested it and it works! nice job!

On the other hand, the sound is not so good, you can hear a lot of "pops", especially when a game has just loaded...

no pops here, afaik, 44 KHz, tried mainly bublbobl. If you have something specific to try...

By the way usually sound pops mean heavy cpu load and/or heavy disk usage on the computer...

Edited by Tux

Share this post


Link to post
Share on other sites

I tried a random game, aero fighters 3, and noticed a lot of pops. Could've been due to heavy cpu or disk usage, but that would be a bit strange, since I have an 8 core AMD FX CPU and 16GB RAM, should be no problem at all...

Share this post


Link to post
Share on other sites
Just now, jvidal said:

I tried a random game, aero fighters 3, and noticed a lot of pops. Could've been due to heavy cpu or disk usage, but that would be a bit strange, since I have an 8 core AMD FX CPU and 16GB RAM, should be no problem at all...

Well just tried it in windows, 32 & 64 bits, and fullscreen, no problem at all. I don't remember I ever had any audio problem in raine anyway.

Similar setup, a ryzen 2700, 8 cores too, and 16 Gb of ram, which is way too much for raine, but I have other uses for that ! :)

Share this post


Link to post
Share on other sites
Posted (edited)

it could be that it slows down while loading or when it has just loaded. I didn't hear any pops during gameplay...

is there a key to show current FPS in Raine? (just like F11 in MAME).

Oh, and on a totally different topic, I noticed that somne sets do not comply to MAME, some games, like Terraforce, won't load with the current MAME set (and they did in the past).

Just found another bug, playing Operation Wolf. the speech is played twice, once when it corresponds and then it is repetead immediately. weird...

For example, when you finsih the first stage, the speech plays "succeeded...", but then, when you're shown which is your next mission the speech plays again...

Edited by jvidal

Share this post


Link to post
Share on other sites
Posted (edited)

minimum curiosity, try emulator inputs in "controls", f11 is a good idea yeah, you could have tried.

There might be a problem specific to opwolf, I never really played it. I might check that later, but it's not my kind of game, so it will probably take time !

edit : yeah I could use the cheats to finish quickly the 1st stage, I can confirm the problem, I guess it's the kind of problem without importance for Antiriad since it doesn't impact the playability... This bug has probably been there since 98, and it's the 1st time I hear of it, so I guess there is no emergence to fix it, I might take a look later, but not now...

Edited by Tux

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...