Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Turrican^

Raine 0.64.16 Translation, Bugs, Features Req.

Recommended Posts

here we go, Tux :)

 

 

http://turricandm.altervista.org/temp/raine.zip

 

attached: Raine.zip cointaning:

  • cngitlog.htm - Since there's no more changelog.txt in the Raine Archive, I created a GIThub log of Raine 0.51.6 UP TO 0.64.16.
  • \locale\it\LC_MESSAGES\RAINE.MO - Italian translation (it_IT.po included)
  • raine_logo.png - The image <raine_folder>\bitmaps\raine_logo.png has a big issue with the pixels-dithering and Iride/Rainbow colors HUE. I fix it, take a look if you like this one. No credit required.
  • logo88.pcx, logo89.pcx - Two Raine Background images for Raine DOS (8bit PNG, with the first 128 colors as free, and latest 128 colors for the image).
  • RLogo437.ANS - Alot of time ago I tried to make a TextMode GUI for Raine DOS, never completed. Anyway I still have an ANSI Raine Logo made with standard ANSI 8clr X3.64 (compatible with MS-Dos(CGA+) v2.1 or later (and Linux/Bash, according you're using IBM codepage 437 font or similar) you can print it on screen during Opening or Quitting Raine for MS-DOS. Note that Raine DOS already print a little ANSI X3.64 string during Opening.

 

No need for credits at all.

 

 

TRANSLATION:

 

Italian translation done!

I spent a lot of time to reorganize the file so that you can use it as Template/example for other translations.

1) Now strings are put in the RAINE UI order of appearance, so who starts a new translation can easily understand the context of sentences and immediately check if everything is correct.

2) in your PO file many strings were missing, I added them by taking from the sources (many still missing, but I think they are rarely used).

 

It seems Raine does NOT translate this strings (translation not working), please, can you help me and tell me why?

 

msgid "Year : 2006" <--- ????

msgid "Unable to load: %s"

msgid "You can't have at the same time a scaler + scanlines,\n"

msgid "If it's a steering wheel, then move it to the max"

msgid "Couldn't open iso file:|%s"

msgid "Find NeoCD bios"

msgid "Sprites conversion..." (during loading a rom)

msgid "Bad CRC for ROM %s (%x)\n"

msgid "Bad ROM size for %s: tried to read %xh bytes, got %lxh\n"

msgid "Rebuilding 8x8 layer"

msgid "Rebuilding 16x16 layer"

msgid "Find the NeoCD bios (neocd.bin).\n"

msgid "Without %s you will have no sound"

msgid "Region out of bounds (%d). Possible values :"

msgid "Rom dir"

msgid "Bad CRC for ROM %s (%x)\n"

msgid "Save 1st some custom inputs using\n"

 

Categories (shoot'em-up, fight, etc.) are translated in the GameList *OPTIONS* menu, but not in the Games List.

 

Please, on "Kick Off,Legend of Makai, Makai Densetsu, Thunder&Lighting, Wiggie Waggie, etc" dipswitches change the string "Controls" to anything else (i.e. "Game controls") because it collides with another string in the emulator UI. The same happens for KingdomGrandPrix,Macross 2,Mobile Suite Gundam,Operation Wolf/Bear,PipiBibi, VFive, Whoopee (and other games) for the dipswitch string "Language", change it to "Game language" please.

 

Also, check strings with this comment "????" because I found some strange things.

 

-------------------------------

 

BUGs REPORT:

 

NOTE: Let me know if you need screenshots.

 

GUI:

  • (1-1) Raine -> (Emulator) Options --> "Pause when focus lost" not showed anymore! (works previous raine versions, such as 0.64.0)
  • (1-2) Command line not working at all (raine.exe -h, raine.exe -help, raine.exe /?, raine.exe -gamelist)
  • (1-3) Raine -> Load a Gunbird/CPS1/NeoGeo game -> Game options -> GFX Layers/Sprites viewer --> its section is too tiny to be usable (not all games).
  • (1-4) Sometimes, in the mainmenu, Raine show "Show command.dat info" even if no game is loaded (or the game is not a CPS/NG title). Clicking on it makes exit the emulator. It happens if you load a CPS game, and then another HW game (without run it).
  • (1-5) I have an Italian WinXP and Win10 installed on my PCs. If I put the italian translation as <raine_folder>\locale\it\LC_MESSAGES\RAINE.MO, it does NOT apply the translation automatically, is it because you need to hard-code the new language-file on the gui sources?
  • (1-6) everytime I try to "Game options -> Edit screen" an error occurred: "no 8x16 font available !!!" (missing <raine_folder>\fonts\8x16.fnt, where's this file? I cannot find it on the site)
  • (1-7) Raine -> About --> still reports 1998-2015(?)

EMULATOR:

 

  • (2-1) NeoCD totally unworking, there's a problem loading games in the CUE+ISO+MP3 format (works ok with games in the CUE+IMG format such as Andro Dunos), still working on old versions of Raine and NeoRaine.
  • (2-2) How to enter in the TestMode on games where there is no dipswitch menu in the MainMenu? like CPS2 games, Elevator Action 2, ESP ra.de, Fever, Gekirindan, etc. Can be possible to add a keyboard shortcut to enter in Test Mode? such as the F3 on MAME.
  • (2-3) Raine reports the default key *Rctrl+S* to save screenshots, but on my system I've to press Lctrl+S to save! If I try to change again Rctrl to Rctrl it works like expected.
  • (2-4) How to enable the verbose log output (to Command Prompt/Shell, Raine Console or file-stream) in raine? when there's a crash, at least I can tell what happened. Or am I forced to compile a debug build to see the log?

GAMES:

  • (3-1) Load game -> Arbalester, Cabal, Grand Cross Pinball, MegaTwins, Ninja Kid 2, Play Girls, Red Action -> selecting Dipswitches on MainMenu -> Raine quits.
  • (3-2) MegaBlast, Rodland -> crash on loading.
  • (3-3) Raine -> Load game -> Gunbird -> now, do not start the game -> Raine -> Load game -> Super Bobble boble -> CRASH! (Win10/DX12/nVidia)
  • (3-4) Continental Cirus: There's a little issue on the title screen (in the upper area), and the score panel.
  • (3-5) Elevator Action 2: There's an issue in the main character shadow.
  • (3-6) Ninja Gaiden -> as soon as you start playing controls are unusable, then playing for a while everything became ok.
  • (3-7) Euro Champ 92: In the intro, there's an issue on the Ball sprite zooming (Raine showes 2 balls overlapped instead of 1). During the game, when the ball goes "throw in" and the opposite player is going to pass the ball then the border line disappear, need screenshot?
  • (3-8) Darius 2 -> On the first level (untested on later levels) I'm quite sure there's a missing voice/channel on the music. A little issue on the "jumping angels" enemy (right before the first Boss). And there's a little issue on the boss explosion animation.
  • (3-9) Operation Wolf -> no sound?
  • (3-10) Operation Thunderbolt -> a little issue after the intro level animation (for a second you can see an aeroplane with shades of rose)
  • (3-11) GnG (CPS1) -> on level 1-2, during rain there's a little glitch on the glass (you can see it in Attract Mode, too)

VIDEO:

  • (4-1) Main Menu -> Video options -> "Video info..." (blit/overlay) -> "Using unscaled blits" -> nothing!!! No/yes? (tested on XP/DX9 and Win10/DX12)
  • (4-2) Open Raine, launch a game, Press Esc to come back to the emulator Main Menu, go to Options, you can see the game paused as background and the opened menu is opaque/transparent. Now, come back to the main menu, try a few times to enter various menu (such as VideoOptions, AudioOptions) and come back to the main menu, you'll see at some point Raine losts the opaque/transparency feature on sub-menus (this happens with OpenGL only / WinXP-Latest DX9-nVidia).
  • (4-3) Main Menu -> Video options -> Render options (OpenGL) -> Set "NO" to both "Fix Aspect ratio to 4:3" and "Keep aspect ration", I think I should resize the emulator window in any size and ratio I want, but it does not work in my config (XP, DX9, nVidia 8600M)
  • (4-4) Main Menu -> Video options -> Render options (Normal Blits) -> Change video mode: -> To match 2x game resolution ---> Now the Raine window should be resized only to 2x (and 1x) the game res. size, while actually the user can resize the window at any size and Raine showes rubbish in the extra window border.
  • (4-5) Run Raine, set OpenGL video render with HQ2X shader and aspect ration enable -> load Rygar, start the game, press Esc to come back to Main Menu --> Now the Raine window become large to accomodate the Main Menu UI font text -> press Esc again to come back to Rygar, the raine window does not come back to 2x game resolution --> press Esc again to come back to Menu, then press Esc again to comeback to Rygar --> Now the window resize to 2x game resolution... (OpenGL/nVidiaGTX960/Windows 10 64bit/latest DX)
  • (4-6) I don't know if it's a SDL issue, anyway. Under Windows, Try to load Darius 2 (dual screen), run the game, then click the "Enlarge window" (you know, the gadget near to close in the title bar of windows) to set the Raine window to big. Now you have the game in the upper part of the Screen, and in the bottom you can see other MS Windows applications, but if you click outside the emulator window then Raine do not allow it! Now come back to the game, you will see a black full screen and the game in the bottom-left window, now press Esc to the Menu, you'll see the menu in the upper-left this time.
  • (4-7) Raine (OpenGL) (Windows XP at 1280x800, Rendering=Texture, 4:3=No, ARatio=No, Shader=HQ2x) ---> everytime I launch a Vertical or large-wide game Raine changes the window resolution to the same resolution as the game, while the game is playing at 2x (so I can only see 1/4 of the game) and I must resize to Raine window to fit the 1x game resolution. (Tested with Darius 2, Dangun Feveron), maybe it's because my screen resolution is not enought big for a window with a double resolution of the game ?
  • (4-8) (SavePerGameScreenSettings=No, FullScreen=20, 4:3=No, ARatio=No, Shader=HQ2x) Load CrimeCity, run the game, Now press Esc and load Cookie and Bibi 2, Raine resizes the window but the game is positioned in the left-bottom at a size 75% the Raine window size.
  • (4-9) Raine (test with Daioh but maybe whatever game is the same) -> pressing P to pause the game makes the CPU 50% (on dual-core) or 25% (on quad-core) and maybe 100% (on single core). So, it's better to press Esc to come back to the Main Menu.
  • (4-10) On my old notebook (Win XPSP3, Core2Duo@2.10Ghz, 4GB DDR2 ram, latest DX9, nVidia 8600M) Raine always runs at 50% (single core), no matter which game, enable or disabled with or without Shader and Blend... is it normal? For what I remember Raine runs ok with a Pentium I 133mhz in DOS, now with a computer 100 times faster and OpenGL accelerated graphics it should use a 10% cpu, isn't it? with Blit/Overlay Raine runs at 25/30% cpu on this laptop.
  • (4-11) What's the difference between GameOptions->CPUFrameSkip and VideoOptions->FrameSkip ? is it one for CPU and the other for the gfx videochip emulated? to enable
  • (4-12) To enable Video Throttle (no frame limit) to make a little Raine benchmark do I have to just set to "No" MainMenu->VideoOptions->"Limit framerate <= 60fps" ? setting it to "no" does not allow the game to run at more than 50fps (tested with a few games such as Cleopatra'sFortune)... and how to enable/disable VSync?

 

-------------------------------

 

FEATURE REQUEST:

 

Screenshot for NeoCD games:

 

Actually, in the GameList of RAINE, if you scroll games you'll see a screenshot of the current game as background, nice!

The file's loaded as: <romname>.zip -> ../screens/<romname>.zip

Nice!

But what actually for NeoCD games?

It will be very useful if Raine can use the screenshot if found it in the game folder with the same name as the .CUE (or .ISO, in the case of a single ISO image file, such as the MVS/AES to NCD conversion).

i.e.: MetalSlug\MetalSlug(jap).CUE ---> MetalSlug\MetalSlug(jap).PNG

 

 

Loading zipped ISO for NeoGeoCD: (just like NeoCD Emulator already does)

 

I have the following game files in <raine_folder>\isos\KOF96Col\

KOF96Col.cue (reporting Track01.ISO, Track02.mp3, Track??.mp3)

Track01.iso

Track02.mp3

Track03.mp3

Track??.mp3

Everything is ok, but it will be perfect if I can compress Track01.iso as well.

So, please can you add a function that will load the .ISO file even if it's zipped/7z?

such as:

KOF96Col.cue (reporting Track01.ISO, not the zipped one)

Track01.ZIP (with inside Track01.iso)

Track??.mp3

So if the emulator found <TrackName>.ZIP instead of <TrackName>.ISO (or <TrackName>.IMG), it should check if inside there's a <TrackName>.ISO (or <TrackName>.IMG), if so it decompress the ZIP to load the ISO/IMG file.

Thank you

 

User interface:

 

When a ROM-file is missing and Raine diplays "Unable to load: %s" it should display the CRC as well, such as "Unable to load: %s (CRC:%s)"

 

I don't know what users think about it... anyway....When choosing a ROM path a confermation button (such as '--Ok' or '--Accept path' is required, it's too ambiguous the user should press right-mouse button to confirm (in the Menus is ok anyway, but not in a path requester), is the right-click always the 'Confirm and Come Back'-button ?! If so, how to 'Cancel and Come Back' ? or may be it's necessary a message in the status bar (on the bottom screen) such as "Press right mouse click to Confirm, press Esc key on keyboard to Cancel".

 

 

Thank you

Edited by Turrican^

Share this post


Link to post
Share on other sites

I got a problem uploading raine.zip, I'll upload it on my hosting as soon as possible.

EDIT: Done! download it from: http://turricandm.altervista.org/temp/raine.zip

 

In the meantime I still have a problem downloading your latest DOS test release at:

http://raine.1emulation.com/archive/rained.7z

Everytime I try to download it stops at 85%.

 

Please, can you upload it elsewhere?

 

attrached the ANSI logo preview

post-57686-0-32897400-1549560605_thumb.png

Edited by Turrican^

Share this post


Link to post
Share on other sites

Post too long, it will take me ages to reply !

I already replied to the private one though...

And added the italian locale to github, and tested it, it was a few errors in the po file, I wonder how you wrote it, usually you take an already existing .po from an other language for that but oviously you did it differently otherwise you wouldn't have all the errors. Anyway it's fixed and committed... it's working, I guess you can't compile a binary and would like to see it in action ? Too bad these locale files can't be added without a recompilation, and there was a bug added recently there anyway... !

 

For you super long changelog, it's just some extracted stuff from git, right ? Well the thing about changelogs for users is that you need to filter a lot of things from this to make it usable by a normal user, the git changelog is for developpers, but I am usually too lazy to create a proper one for users, I just summarize things quickly in the release post.

Anyway I guess it could eventually be useful... ! By the way the git changelog doesn't have all the releases, far from it, it started sometime in the sdl version so it was already > 0.43.

 

For the link to the dos version : where did you take that from ? You need to download it from the download page so that it works.

 

For the rest : later !!!

Share this post


Link to post
Share on other sites

I made the Language-file (.po) with Notepad by my hand, looking the emulator in action (to order strings in the same order as the Raine UI emulator), extracting the strings from sources, taking a look on the French translation made by you, and finally compiling it with PoEdit v2.2 for Windows. I tested it replacing the French file with my Italian compiled file (since for now, it seems Raine does NOT switch the language-file according to the Windows XP/10 default language). I spend about 10-12 hours to make it. In my opinion it's really well made.

 

For the errors you're talking about, sorry mate, there's no error in my translation-file (except for the strings I already told you, but I think there're some raine issues). What you see as "errors" are just a Warning, for example, if the original string has the first char a lowcase char and I translate it with the first char as an UPPERcase, then the .PO compiler show you a warning about it, the same if the last char is "." and i remove the final dot. That's not the first time I made a (.po) translation file. If I change some rules it's because the original string is wrong. While, Real errors do NOT allow the PO-compiler to do the job. I compiled it with some warnings because I think my translated strings are more correctly than the original ones. Anyway, tell me if you discover any problem.

 

For the changelog, background, legacy logos, etc... do anything you want, you're free to delete them, no worries mate :) I made it just for fun.

 

I found the DOS Test release in 3 places: the Raine Website (before you removed the News section), in the forum, thread: "Raine + DOS = bad sound" and thread "dos version, vsync & triple buffer" (it's the last thread you saw talking to me).

 

for the rest, take the time you need Tux, I know you have a life out of this shit :)

 

thanks Tux

 

EDIT: I'll try to understand by sources how Raine apply the Translation-file to fix those errors on my translation. Stay tuned

Edited by Turrican^

Share this post


Link to post
Share on other sites

I have fixed the po as I said, you can grab it from git to see the differences from your file by yourself...

Later...

 

For the old dos link, in case you are interested by the fixes inside I am afraid I forgot them completely, this was 4 years ago !

Maybe some of them were merged into the main source, I am not sure about that.

Anyway yes the download link is broken for some weird reason, they seem to have installed something to limit the bandwidth I would say, and as usual it seems to fail miserably... ! Sorry I don't have a backup of this specific file (at least none that I know of !), and I can't retrieve it, even using the ftup access I get the same error, the download begins to stall at about 66% and then it takes forever. It seems to progress though, but very slowly, I'll try to keep it to see if I get a usable file in the end....

Yeah I guess I should migrate all this to a saner place one day, but I miss a free host, you could do that on sourceforge once, but they limited so much the shell access that it was crazy to handle it. Oh well... !

I am at 75%, maybe 1 chance left !

Sorry it's totally broken, it never ends and fills the file with crap.

Well I guess we can only wait at this point !

 

edit : here is a link to the very latest dos version (0.64.16) :

https://mega.nz/#!3JkxWIoA!DEoZ2SwyylRWYLcpaOVCwZaaNvqBavRC6zSTW-xCikc

there is only the exe inside, it needs at least raine.dat from a previous dos installation.

And it includes at least the change for vsync discussed in september 2015, that is, there is an explicit call to vsync for dos now (which probably makes things slower, but it also probably works better now that the allegro hacks are mostly lost).

Edited by Tux

Share this post


Link to post
Share on other sites

I didn't really understand what you meant about the logo, your version has more colors which creates a slower color scrolling, it's nice but I also like the old one (faster scrolling = more "lively").

Both are good...

The ascii version is a good idea, I never tried to create one... But I wouldn't want to use that in the exe though....

 

For the translation, yes all the strings are not translated, because I used some script to guess which strings to translate, and they are now encased in _("...") in the source, all the strings which have no _("...") are not translated (and there are some strings which must not be translated).

Year : 2006 is just the 1st initialisation of the year field, it's overwritten later by the real thing... this one should not be in the po file... !

That's where the fact that you can't edit the sources is too bad, here you could have added the _(...) where appropriate and then propose a patch for that... !

About categories I am thinking about ditching this entierly, I had never any feedback on this and it can make things awkward when handling a lot of game drivers to update and you don't have the information... Getting rid of it is probably the easiest fix here.

For controls / language in the dsw, I don't see why to change the string heree, it's still about controls and language even if it's in the dipswitches...

 

lol for the disappeared "pause when focus lost", I never used this because on my system it thinks it looses focus when switching from gui to game mode in windowed mode, maybe I should add a few frames of lost focus instead of just 1 to make this useful. Anyway I took it back, this dialog is a little crazy taking settings from everywhere and it lost this one when I added the "no hud messages"... !

For the command line in windows I guess it probably works anyway but I can't test it here, you'll have to wait some more for that... !

 

Later again then !

 

edit : a last one, for the sprite viewer for vertical games, just switch to fullscreen !!! By the way this feature is just a curiosity for most games, it was added when trying to translate "samurai spirits rpg" neocd game, and that's the only game where it can be useful... but you can use it on any game anyway...

After testing quickly in wine : of course the command line works even in windows, maybe you just get no output in your console, in this case use it like that :

raine32 -h > output

and then check the output file.

I might test this later in a real windows, but I am sure it will work.

 

For the .po, you decided to create it without asking anything, good, but normally .po files are created from an initial raine.pot file which is created automatically from the sources using some commands. Then you rename the .po to something related to your locale, edit it, and then pass it to some other commands to generate the .mo file which is actually used by raine, this last pass must be done by the makefile and not by any other tool even if you can use another tool for testing, because these files should be generated on demand. That's why there must be no error in this last pass and why I had to edit your .po. I can keep the ordering of course, if some people want to take the italian .po file as a base to create a new one they'll get something to start from, but the tool which creates the default .po file doesn't care about ordering, it just adds a comment to say where the string comes from in the sources, that's all... !

 

1-4 : well I tried to load 1941 first, got the option to appear in the menu, then loaded buble boble, and the option was gone... you'll need to be more specific then !

Edited by Tux

Share this post


Link to post
Share on other sites

1-5 : I don't know how to detect the default language in windows. Raine is multi platform and each platform has a different way to do it, even osx which is an unix doesn't do it the same way as linux (although it's rather similar). But in the case of windows you have to call some windows api function for that apparently, no way to find it from the environment, and since I almost never program the windows api directly I have no idea which one to use. I would need a real windows programmer to take care of the windows version, but again, nobody seems motivated enough for that. So you'll just have to choose the language in the gui, I added the choice for italian now...

 

1-6 : it's a samurai spirits rpg option, only when translating, if you see it anywhere else, report... and you shouldn't try to use it, it's some really low level stuff.

 

1-7 : yeah I know, fed up at editing the year all the years so I just stopped, don't complain, I am still here anyway !

 

2-1 : not for me, and probably for lots of other people, I only tested on 1 game though, I guess something is broken in your cue, send it, just the cue file, you can use mail for that (or send a link to the whole package eventually).

 

2-2 : U key usually, check the raine keys, it's associated with "Test"... !

 

2-3 : default key is LCTRL s, I even removed my config file to check, reported as LCTRL in the gui and working with LCTRL, and indedd if you put RCTRL instead, it works.

 

2-4 : yep it's for those who can compile only, reserved to debug builds, you wouldn't know what to do with this anyway, and the cause of the crash is not always there, most of the time you need a debuger for that.

 

3-1 : if you had a proper console (like the one from mingw, but you are not a dev so I guess it's normal), you would have seen an error when raine quits : "unknown extension 0", it's a collision with some new way to write dipswitches, thanks for finding this one, I'll need more time to look into it... later again then !!!

 

Edited by Tux

Share this post


Link to post
Share on other sites

3-1 : all fixed, these were all very old typo errors in the dsw definition, for the cps1 one (mtwins) it was because my converter didn't like a comment which was added in the middle of the definition and it got lost because of it. Very old bugs, I suspect that at a time they were not making the emu to stop because it's hard to believe they would have gone unnoticed for so long, probably an effect of the not-so-new dipswitches dialog.

 

Much later for the rest, need to get out now !

Share this post


Link to post
Share on other sites

3-2 : 2 very stupid bugs when rewriting stuff in a more compact way... !

 

3-3 : it's about loading a game which has no region after one which has some. Amazing it got unnoticed for so long, you are good at finding these bugs, you probably spent quite a lot of time on this... !

 

Graphic bugs : too long to fix, sorry, it's known raine has some graphic bugs on some games, lately I fixed syvalion (controls and zoom effect on the title screen), but I don't do that often because it takes a lot of time.

Well since I don't kinow the arcade version of darius 2, and I never played it on any other emulator, I never noticed anything, but it's possible I guess... ! Here too, too long to do now, we'll keep that somewhere for some other time...

3-9 : yes I have sound, and from the very first seconds (music during attract mode).

3-11 : More detail ? Is it really obvious ?

 

4-1 : you need to actually run something to get some info here ! You weren't really intuitive on this one... !

4-2 : I'd say that sometimes you loose the background for some unknown reason, yeah I know, hard to track and to fix, maybe one day...

4-3 : ah yes it keeps on fixing the aspect ratio when resizing the window, forgot about this. It's more intended for the difficult fullscreen modes where you want to get rid of these black borders at the cost of some quality.

4-4 : Normal blits are for fullscreen, even if they can work in windowed modes they are not meant to be used in windowed modes, it will work but just don't resize your window all the time then... !

4-5 : the shaders never resize the window ! The hq2x shader produces an hq2x output but then it's resized to fit the window, it's your job to choose a mode where it makes sense, but anyway you usually get a better zoom wihtout even caring about the mode. In this case yeah the window should probably resize to its previous size all the time, the easiest fix is to always have a window big enough so that it won't resize. This kind of thing is a pain to fix, especially with sdl-1.2, switch to sdl2, one day, in distant future... !

4-6 : I'd say it's more a windows bug related to sdl-1.2, it works fine in linux, don't expect a fix soon, I hate tracking windows bugs like this... !

4-7 : ok, there is really a problem here, it seems to use the setting from normal blit to adjust the window size when in opengl, it shouldn't touch the window size at all in this case, I'll try to look into it... !

 

edit : ok, it's done, now the window is resized only when using normal blits and choosing to set the mode automatically, which should always have been the case, sorry ! Actually this code is some old code from allegro adapted to work with sdl, and it's quite messy. Anyway, much nicer to use when in windowed mode now.

Edited by Tux

Share this post


Link to post
Share on other sites

4-9 : can't reproduce. daioh pause -> cpu at around 6% for raine, 100 being 1 core fully loaded. Tried the windows version in wine too with the same result...

4-10 : not at alll normal, raine is super efficient on the cpu, it's more like cpu in power saving mode at 1 GHz and using 2% cpu power... ! No idea what causes this, never seen or heard anything like that. I just booted in win10 to make sure I get the same results as in linux for that : yes of course. I don't have any xp boot so I can't test xp. You can eventually try to play with the UseRdtsc seeting in the config file but it shouldn't change anything, the rdtsc is only used for the profiler display (f11 key 3 times), there is an sdl timer for the synchronization now.

I have run it on quite a few computers now, and never seen anything like that until now...

 

edit : after checking in the code to refresh my memory on this, on its normal behavior it goes explicitely to sleep waiting for the next frame to start which makes cpu usage super low. Start by checking the profiler (f11 key until you see many % numbers in game). The last one, Free should always be the greatest one. If you see it go down while blit goes up, it means your screen has a refresh rate < the game refresh rate, but normally this should not put any load on your cpu, video drivers normally just wait without loading the cpu in this case, unless you have a problem on this side. You can also lower the game refresh rate in this case, 59 fps instead of 60 can be enough for a monitor with 59.25 fps for example.

I can't say anything more on this, you'll have to investigate, I can only say it's not normal at all.

 

A last thing though : raine uses only 1 core, it was made for old cpus so there is not much point to use more than 1 core considering its speed.

Edited by Tux

Share this post


Link to post
Share on other sites

cpu frameskip : it was a way to slow down the game before having something to tune precisely the fps, now using the fps setting in game options is probably better.

 

benchmark : if using opengl just disable double buffer in the opengl options, the limit framerate of course, and you are good to go.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...