Jump to content

Raine 0.64.13


Tux
 Share

Recommended Posts

Wiow, 2 releases in 1 week after 2 months, I would not have believed that !

Anyway these are only fixes, and some quite serious :

- all the neocd games which loaded some data during the game were broken because of a fix for garou (neogeo). Yeah it's quite big, I didn't play any neocd game in 2 months, I really needed a break there !

- Gui : windows doesn't need a colour depth change anymore, and the mode changes should be invisible

- while cleaning up the taito f2 driver (yeah very old stuff, never completely finished), I noticed you couldn't access the pulirula dipswitches, so it's fixed too.

 

That's all for this time, the most serious bugs should be fixed so it should be more quiet for a while now !

http://raine.1emulation.com/download/latest.html

  • Like 1
Link to comment
Share on other sites

congrats & thank you for you reactivity. i keep you informed if i notice some other big bugs.

Please, could you add the Emu-France banner again on the top left part of your site, like before ? thank you a lot.

Edited by greatxerox
Link to comment
Share on other sites

Hi!

 

The color depth does not change anymore (THANKS!!!), but now the GUI menu is invisible once a game is running and escape is pressed to go back to the GUI in full screen. This problem doesn't occur in windowed mode. Tried to turn off "OpenGL overlay interface" and it didn't solve the problem.

 

I already found a quick fix: If you very rapidly press escape 3 times in a row, from a running game, the GUI appear!!! It look like some kind of synchronization problem.

 

Settings:

 

Full screen, 32 bit color

Windows 7 Aero = ON

1680X1050 resolution

 

SDL video driver: Winlib

Video rendrer: OpenGL

 

Rendering: Textures

Double buffer: Yes

Shaders: Yes Scanline 3X

OpenGL overlay interface: Yes

 

 

Everything is much faster now. From launching the emulator, to running a game and back to the GUI. No more color depth change delays! :-) Now, if only the menu would stop disappearing! lol! :-)

Link to comment
Share on other sites

Better workaround : use a fullscreen window ! Actually I tested fullscreen only by using the ctrl+return short cut while in windowed mode and no problem there, so just avoid the real fullscreen, you shouldn't miss it.

There is even an option to have a borderless window if borders are a problem.

 

You can also try to force the directx driver for windows instead of the default windib (not sure it helps, but maybe).

 

The slow mode changes were only in windows, in linux you don't see much difference, but it's better to avoid useless mode changes anyway.

Edited by Tux
Link to comment
Share on other sites

Better workaround : use a fullscreen window ! Actually I tested fullscreen only by using the ctrl+return short cut while in windowed mode and no problem there, so just avoid the real fullscreen, you shouldn't miss it.

There is even an option to have a borderless window if borders are a problem.

 

You can also try to force the directx driver for windows instead of the default windib (not sure it helps, but maybe).

 

The slow mode changes were only in windows, in linux you don't see much difference, but it's better to avoid useless mode changes anyway.

 

I was hoping for an actual fix for this problem. I must use OpenGL the get the shader Scanline 3X I want so DirectX is out. ctrl+rerturn effectively put Raine in real fullscreen, so the problem is still there. Windowed mode with border is not acceptable for me and unfortunately, the border less mode shift the screen down so part of the bottom of the screen is hidden and there is black bar on top. So the real fullscreen is broken and the full window border less is broken too as you can see, the word "credit" at the bottom is nearly chopped in half and the black bar on top is clearly visible too:

 

Bad%20borderless%20full%20window_zpsh82u

 

So, until there is a fix for this, I'll keep using real fullscreen, and simply rapidly press escape 3 times to get the GUI.

 

Thanks!

Edited by ramonz
Link to comment
Share on other sites

Try this : video options / use double buffer (ignored by opengl) : set this to "never"

Then you can eventually use the opengl double buffer if you want : video options / renderer options / double buffer

And then tell me if the problem persists for you in fullscreen !

(didn't know the borderless rendering was broken in windows sorry, can't do anything about it it's sdl specific).

Link to comment
Share on other sites

Not here, can't reproduce, can't test, can't do anything about it.

I can test only with nvidia, and 1 very old intel card without hardware opengl support (it doesn't support any shader but the opengl rendering without shaders work).

So as far as I can tell the problem is on your side.

Link to comment
Share on other sites

congrats & thank you for you reactivity. i keep you informed if i notice some other big bugs.

Please, could you add the Emu-France banner again on the top left part of your site, like before ? thank you a lot.

If I ever make a 0.65 version, I'll take it back. For now it would be useless, and it's still unlikely...

Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...