Jump to content

MessUI Software Lists


Recommended Posts

Hi Robert,


this is what I wrote before:


1. I have noticed that there is a trouble, in MessUI, with the software lists of some systems which are downward compatible (MSX systems, ...) or have different interfaces to load games (cass, carts, flops...). There are duplicated names of games (the same software set name for cart, cass or flop and for MSX1/MSX2) and MessUI only shows one of them on Software tab.

2. Besides, I consider that it would be nice to have an easy-to-access round buttons, in (System Menu Bar)/Devices/Cassettes(Floppys), for selecting tape/disc 1, 2 ,3 ,4, ..., just reading the XML for every set as it's possible in MESS/File Manager. Please, see the image. I've retouched a picture adding what I'm talking about.


I'm going to try to explain it better although English is not my native language:


1. When you have a system that can loads apps/games from different software lists, MESSUI only shows one (e.g. see the image for cpc464 system, there are the same software names for cpc_cass and for cpc_flop and the Software List Tab on MESSUI doesn't list both games. Even worse on MSX systems, MSX2 is downward compatible so it can play msx1_cass, msx1_cart, msx1_flop, msx2_cass, msx2_cart, msx2_flop). To solve it I think you must distinguish between the same names from all the software lists that a system can loads.




2. Programing isn't one of my skills but the same way MESSUI reads the *.xml to display the software list and I can play a game double clicking a name I think it's possible the implementation of choosing cass/flop 1,2,3,4, .. MAME supports that function in FILE MANAGER so I guess it's possible, writing the code is another matter.


I hope you can understand it now.



A new issue, for me, has come out with the new version 0.162 but I think it's a problem in the source code of MAME (tried mame64.exe from mamedev, my compilation and mess64.exe from here, and messui64 fails too because it doesn't show the snaps of MSX2 systems). When I try lo load the software lists of any MSX2 system, MAME and MESS forces close itself (it was OK in 0.161)

I've been looking into this issue and the problem is msx2_flop.xml, using the one of 0.161 it works perfectly.

Error found. "towercab" entry in msx2_flop.xml is lack of datas according to softwarelist.dtd, deleting this entry the emulator works well.

Edited by julepe
Link to comment
Share on other sites

Wow, very fast!! You are actually a mameaholic. Thanks for your hard work!

Something that you could add, in the 0.163 release, is a new field to the "Software list" tab. Now, there are Name, List, Description, Year and Publisher. The one I'm talking about is a very important info to load the software. "Usage" from the entry "<info name="usage" value="Load with BLOAD"CAS:",R"/>".

As well, I've been thinking of my proposal about the round buttons for selecting the cass/flop number. I don't know if you will try to implement it but my conclusion is that it's not the best way; there is software which has up to cass50 (flop53). So, I think that it's better a pull-down menu. The example picture is from airborne (cpc_cass), it doesn't have the info "Side A;B;C;D" but that info exists in other software. It's from the entry
<part name="cass1" interface="msx_cass">
<feature name="part_id" value="Side A"/> and MAME displays it like "Cass1 (Side A)"




Thanks again.

Link to comment
Share on other sites

I really don't know about that cassette stuff at this stage. Need to think it over.


For the usage field, I had looked at this previously, but found it's a core problem. It might be able to be worked around, but I'm not sure.

Link to comment
Share on other sites

Well, it's not only a cassette stuff, floppy too. But, no matter; we can always use the common MAME menu pushing TAB key.


For the usage field, I asked you about it because I've seen it in other frontends (q___, M____); I'm not going to mention them here.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

I tried loading 'airborne' into the cpc464, but a few seconds into the first tape, it says it has run out of memory. Due to unfamiliarity with the system, I was not able to get it to work.


EDIT: Asked around, seems I had to use RUN"" to make it load, which it did. However it froze at the "Select your mission" screen, so looks like it's broken anyway.

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...