Jump to content

Sonic Adventure 2 graphics arrors


Recommended Posts

When I play SA2 in Chancast .25, I get errors much like these:

 

http://img294.imageshack.us/img294/4966/sonicxq1.jpg

 

Textures will pop up and block my view, making it difficult to play. It happens often too. Is there any way to fix this, or does the game just always run like this?

 

My specs are:

 

Athlon 64 3200+

1024mb PC3200 RAM

256mb nVidia 6800GS PCIexpress x16 Video Card

 

Thanks.

Link to comment
Share on other sites

  • Replies 23
  • Created
  • Last Reply

Top Posters In This Topic

Nvidia cards generally suck at emulating Sonic Adventure 2. Not that ATI cards are much better, but ATI cards have less texture bugs. Most of the problems stem from Chankast's inaccurate emulation.

 

In other words, you can't fix it and neither can we.

Link to comment
Share on other sites

Wow that pic shows worse graphics then I got when I played that game on Chankast. The sound on the games however greatly depends on how the audio files were compressed for those self boot images that everyone has. At least in the case of background music and stuff.

Link to comment
Share on other sites

  • 3 weeks later...

Indeed it does. To put it simple, Chankast doesn't work properly with any integrated graphics solutions (ATI's or NVidias integrated models might be an exception, but these are largely untested and/or unreported).

 

Needless to say, Intel's integrated models are the worst in terms of emulation, especially when emulating hardware that does true 3D graphics.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...