Jump to content

Raine 0.94.1


Tux
 Share

Recommended Posts

Hello Tux! Thanks for this new quick release!

So I made a quick test here and I can no longer feel the imprecision in the mouse cursor, so I guess it has been definitely fixed!

Except that, no other bug report for now.

But I have a feature request: would it be possible to have an option to deactivate the analog inputs from the controller? I felt the need for that because sometimes I play with my Dual Shock 4 controller resting in my lap and eventually this will make the R2 or L2 triggers be slightly pressed. Unfortunately these triggers are analog in the Dual Shock 4 controller so Raine will register those presses as analog inputs too. If this happens during a d-pad movement, the d-pad will immediately stop working for a moment, which will cancel the movement I'm making. Here's an example comparing with what we have in FBNeo:

https://drive.google.com/file/d/1TqIDy8Zb5acE2uCAlPJaSu5rvW4Tsz_V/view?usp=sharing

As you see in the video, if I'm pressing, for instance, up in the directional pad to make the character jump in King of Fighters and suddenly hit any analog inputs, this will interrupt the d-pad registration and stop the character from going up. Maybe if the analog inputs didn't interrupt the d-pad registration this could avoid the sequence break?

Anyway, it's not really a huge issue if you take care to not press those analog triggers and sticks accidentally, but it could happen eventually.

Interestingly these triggers aren't even bound to any command in Raine but still they interfere in this analog detection. I'm using all the default bindings suggested by Raine for the Dual Shock 4 controller.

Perhaps a "D-pad for movement: D-pad only" would work around that?

I'll wait your comments on that.

Thank you so much for your time and work. 👍

Edited by mer-curious
Link to comment
Share on other sites

Well the easiest solution is simply to put the controller on a table instead of on your lap ! ;-)

Yeah raine reacts to any "stick" in the gui, the code is from before game controllers so there was no way to identify a movement to know from which jostick or button it came,  and so it reacts to any stick movement. I guess I could at least remove this now so that for game controllers only the left stick is handled for that. I'll do that.

  • Like 1
Link to comment
Share on other sites

Hello Tux! Thanks for considering a work around for this nuisance with the controllers configuration.

I just would like to report that while trying to reproduce the sound associations bug in KOF95 discussed in the other thread, I guess I found a glitch in the sound associations menu. If you use "Test" to test a command and then "Play a track" in "Manage associations", both the sound command and the track will play simultaneously, which will result in a confusing sound. Perhaps selecting "Play a track" could stop the command which was playing before?

Anyway, that's just it for now. Thank you so much again for your time and work in the emulator.

 

Link to comment
Share on other sites

2 hours ago, mer-curious said:

Hello Tux! Thanks for considering a work around for this nuisance with the controllers configuration.

I just would like to report that while trying to reproduce the sound associations bug in KOF95 discussed in the other thread, I guess I found a glitch in the sound associations menu. If you use "Test" to test a command and then "Play a track" in "Manage associations", both the sound command and the track will play simultaneously, which will result in a confusing sound. Perhaps selecting "Play a track" could stop the command which was playing before?

Anyway, that's just it for now. Thank you so much again for your time and work in the emulator.

 

You are supposed to use "Stop" from the sound commands dialog 1st. If you forget that's not a disaster, just leave the associations dialog, use "Stop" here, and go back to the associations. Sorry stopping the song from here is not so easy for me !

Link to comment
Share on other sites

Hello Tux! So I made a quick test with my DS4 controller using the experimental 0.94.2 version posted in the other thread and here are my results so far:

- the issue with the analog triggers is still present in this version, that is, if I am using the d-pad the movement will still be interrupted if I press any of the analog triggers.
- I have noticed that the issue with the triggers will only occur if I first happen to use the left analog stick to move in the game, that is, the analog triggers movement won't interfere if I don't touch the left analog stick first in the game.
- the right analog stick apparently no longer interrupts the d-pad movement.

 

12 hours ago, Tux said:

You are supposed to use "Stop" from the sound commands dialog 1st. If you forget that's not a disaster, just leave the associations dialog, use "Stop" here, and go back to the associations. Sorry stopping the song from here is not so easy for me !

Ah, what a pity! I wasn't expecting it would be so hard to fix. Anyway, I just reported it because the result of two tracks playing at the same time is really awkward. But it's just a minor glitch though, so we can live with that for the time being.

Thank you so much again for your help.

Link to comment
Share on other sites

Sorry can't help you more with that, for me the triggers are completely ignored in the gui now and they were not before, can't do anything more about it.

Are you sure your ds4 thing is recognized as a game controller ? If so its inputs for the left stick should appear as "leftx" and "lefty" in the controls.

Edited by Tux
Link to comment
Share on other sites

1 hour ago, Tux said:

Sorry can't help you more with that, for me the triggers are completely ignored in the gui now and they were not before, can't do anything more about it.

Are you sure your ds4 thing is recognized as a game controller ? If so its inputs for the left stick should appear as "leftx" and "lefty" in the controls.

Hello Tux! Thank you for the fast reply.

Yes, this is exactly the configuration I have here, take a look:

https://imgur.com/a/qsw8Bw7

I use all the default settings suggested by Raine for the DS4 controller.

By the way, you said that you the analog triggers detection are ignored in the GUI but you also meant in-game, right?

Anyway, now that you mentioned the GUI I went and tried to trigger the interruption there and interestingly it does occur in the GUI too. I've also checked a little longer with the right analog stick to confirm that unfortunately it still interferes in the d-pad movement. So it seems that the fix hasn't worked as intended according to my tests. Just to remind that I used the experimental version provided in the other thread compiled on September 13, 13:29, according to the "About" information.

But the condition I mentioned above in my previous post is also valid for the GUI: you first need to use the left analog stick so that all the other analog inputs (the right stick and the R2/L2 triggers) can interfere in the d-pad movement. If you don't touch the left stick first, these analog inputs will never interrupt the d-pad movements. Perhaps this could help you come up with a work around for that?

Anyway, thank you so much again for your attention.

 

Link to comment
Share on other sites

No I meant only in the gui, of course these can still be mapped ingame to whatever you like (even though it's not easy to find a good usage for these!).

Well what you describe doesn't make any sense (L2 & R2 should be totally ignored if it's a game controller in the gui, if not there is really something broken somewhere, is there a joystick which is not a game controller connected at least ?), there is probably a problem somewhere, but I can't reproduce it here for now, maybe later when the weather will be more "reasonable" !

Edited by Tux
  • Like 1
Link to comment
Share on other sites

2 hours ago, Tux said:

No I meant only in the gui, of course these can still be mapped ingame to whatever you like (even though it's not easy to find a good usage for these!).

Well what you describe doesn't make any sense (L2 & R2 should be totally ignored if it's a game controller in the gui, if not there is really something broken somewhere, is there a joystick which is not a game controller connected at least ?), there is probably a problem somewhere, but I can't reproduce it here for now, maybe later when the weather will be more "reasonable" !

Hello Tux! Just to complete my report, I only have the DS4 connected to the PC via USB. In Control Panel it is identified as Wireless Controller.

I asked about whether the fix would apply to the in-game environment because that's where the issue may affect the player the most. But as you see it does occur in the GUI too. In order to reproduce it you have to respect the condition that I found.

No worries about an urgent fix since this is not a huge issue. At least the DS4 has been useful to find and fix these bugs in Raine's input system.

Thank you again for your work.

Link to comment
Share on other sites

There is a misunderstanding here, you are not saying your triggers can move the selection in the gui, just that they are interrupting the auto repeat feature of the dpad in the gui ? Well assuming they are seen as buttons too, and I guess it's the case here, it can't be avoided, the autorepeat works as long as it does not receive another button press. Eventually send the string for your controller either in userdb.txt or gamecontroller.txt to confirm they are seen as buttons, but if it's the case there's nothing which can be done, learn to live with it, that's all.

For info I use a very cheap generic Chinese controller found on amazon as my main one, it doesn't have this problem (although it has some other problems, the dpad is unprecise which can be very enerving at some places where you try to input some precise combination, and it can be used only wirelessly, the cable is only to recharge it, it can't be plugged as an usb controller, except that it's recognized as an xbox controller by default which is fine).

Well actually buttons other than buttons 0 & 1 could also be totally ignored (that is buttons A & B). Crazy thing...

Edited by Tux
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...