Jump to content

A dos version in 2020... !


Recommended Posts

I found a recent gcc (latest version actually) for dos in arch, so I got curious to see if I could make the dos version to run now... Weirdly I have some trouble with dosbox, raine crashes at launch with it in install_allegro, no idea why, I tried a few dosbox versions and always the same result.

With dosemu it's also harder, it had the best results before, now I am obliged to use a pre-version of their 2.0, which is not super stable. Here it works, sound and graphics (well vesa 2.0 linear which is not bad, but no triple buffer at all). Only file accesses are very slow for some reason, so I took a moment to add some basic cache for the rom directories in raine and it's now much faster, it will also benefit a little to the other versions, linux and windows.

And it also works in virtualbox, using a freedos boot ! No vesa support at all there, clearly their goal was not to allow some dos games to run, we are stuck in mode-x. There is a working soundblaster 16 emulation though, but only with the allegro sound driver, seal doesn't detect it at all. With that, it's a little slower than dosemu ingame, but much more stable, and what works is working perfectly ! Quite surprising and impressive !

Oh well, it's probably time for a very last raine dos binary then ! (I might make 2, one with the seal audio, the other with the allegro audio).

Edited by Tux
Link to comment
Share on other sites

The wonderful world of vesa modes in virtualbox :

I made some more research on the topic, I found odd that such a stable dpmi emulation had nothing about vesa.
It turns out it was yet another stupid bug from allegro, their mode list scan of vesa modes is broken, and since there is no 320x240 mode by default, I thought there was no mode at all. In fact I couldn't be more wrong !

They have the same support as dosemu, except you can add all the vesa modes you want !
For that you just do :
vboxmanage setextradata freedos CustomVideoMode1 320x240x8
to get the 320x240 in 8bpp. And so on... ! (here my virtual machine is called freedos)
Wow, virtualbox just got better than dosemu, maybe that's the reason why they take so long to release their 2.0 version ?
Hum, maybe they don't have any joystick support ?! ;-)

By the way I just fixed the bug in allegro with another patch, so you now get the correct list of modes. But I am probably the only one playing with this for now ! ;-)

Edited by Tux
Link to comment
Share on other sites

  • 1 month later...

Oops sorry I hadn't updated the old versions page, and it's 0.91.8. There were some very minor tweaks in 0.91.9 for the dos version, it now restores the dos screen when leaving, and fixes the web site name displayed in dos, but they are not worth building a new binary alone, but maybe you would be interested by the fixes anyway... !

Ok, I just built a 0.91.9 version for dos and uploaded it, you can find it in the latest version page : http://raine.1emulation.com/download/latest.html

The only question I have is for the sound, in dos there is the choice between seal which is dead since 1999 if I am not mistaken, or allegro which is a little more recent.
Seal seems to work a little better in dos emulators like dosemu, so it's the one used in this build. But I suspect the allegro version is better when you have the real hardware. So test this and report if you have problems with the sound.

Notice that with 32 Mb of ram you won't be able to load all the games, some are really big for dos standards !

Edited by Tux
Link to comment
Share on other sites

I know i need more ram :)  I'll test it as soon as i can and report , thanks again!  just for info my specs are  :

"cpu : IBM 6x86MX PR266
m/b : J-591A
Soundcard : Reveal (Aztech) sc400 rev2 (it's with OPL3 , sbpro compatible)
gfx cards : diamond stealth 3d 3000 2mb virge/vx pci
hdd : 4gb cf card
ram : 32

and a gameport joystick with 3 buttons"

Edited by psy8765
Link to comment
Share on other sites

Should be ok, 32 bits versions are optimized for pentium3, but not the dos version which is still optimized for pentium in case of old hardware like this one so there should be no trouble. Maybe the sound ? I'll wait for news from you then !


Link to comment
Share on other sites

Hi, i test it today with gfx vesa 2,3 and modx, soundblaster and roms toki, bobble bubble, final fight

can't set triple buffering on any mode,

in toki the sound/music works but the music have low volume and sound distorted compared to older versions like 0.34 (in 0.64.8 the music is bad too)

in bobble bubble the music and sound seems ok but low volume compared to 0.34 version

the fps on final fight is not 60frames all the time so it has some skipping frames, the sound and music sounds ok but low volume,

when i load some big games it freezes due to little memmory i presume...

sometimes if i load a game and then exit to dos the audio turns on and play distorted like static noise even if i'm not in the emulator,

overall it works :) but has some sound problems, didn't have time to test many games,, i'd like to try the other dos version with allegro sound to see if it's better , thx!

Link to comment
Share on other sites

Yeah that's what I was going to propose too, it was to be expected, this seal is too old to be reliable now...

The download page is not used to having 2 dos versions so they show both as "Dos binary", the new one is 1.8 Mb (almost the same size, just a little shorter), and is named rainead- (a like allegro).

Good luck and thanks for testing ! :)

Annoying for the triple buffer, not a big surprise too, this triple buffer worked because of some old hacks from Antiriad, we tried to maintain them with new versions of allegro, but something clearly broke somewhere, and it's going to be very hard to find where exactly since I didn't make these and I don't really know how it's supposed to work ! I might eventually test later with some binary which has a working triple buffer, I guess 0.34 worked with triple buffer then ? But it's very old... ! Oh well... ! Maybe later, at least it's good to know !

Edited by Tux
Link to comment
Share on other sites

Hum, not here, but the sound is regularly interrupted by silences here in the virtual machine when using allegro, so it's really not ideal.

Maybe try a different sample rate, but otherwise out of ideas !

On my side I checked the triple buffer, in fact maybe you can do it with this good old display doctor to get some very special vesa modes, but with my setup in a virtual machine, no vesa mode can work with triple buffer. It actually requires to allocate 3 times the mode and switch the active page between the 3 buffers.

There are some very specific modes which work with mode-x : 240x256 (and I confirm this one works, although it's not very convenient), 320x256. Then there is a serie of modes which divide their vertical lines, for those very wide games : 640x100 !, 400x150, 640x150, 640x200, 640x120, 640x160, 640x240, 800x150, 800x200, 800x300... For all these modes, it setups a vesa mode with 3 times the vertical lines before dividing the displayed lines by 3, but they would probably never appear in the mode selection list since it would require that the final mode is supported (640x100 !!! never seen something like that !). So these triple buffer modes were very rare actually ! It would be possible to painfully update the list displayed to add these weird modes, but it's not worth the trouble, too few of these games, and they always look very strange with these impossibly wide screens...

So to sum up : more problems with the allegro sound version, and triple video modes work, but are a pain to setup and so very rarely used in reality ! Oh well, these were hard times !

Link to comment
Share on other sites

Hard times yes :D , i tried all different sample rates , i got the same result 😕 also i tried windows sound system (cause my card is compatible with that) but not working (with the previous latest version the WSS worked ok like soundblaster),  don't care too much about tripple buffer but would be nice for sound to work with this version, i see there is a max volume mixer option but i see no difference at all when i enable disable,

thanks for your time ! it's nice to see a new dos version even with little problems.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...