Jump to content

NullDC Ecco the Dolphin Error, Help Needed


Recommended Posts

Let's review a bit.

 

1. You open up the VMS Manager, Click edit next to the first slot in Port A.

2. You click Create Vms, give a filename of your choice and click Save.

2b. Click Format Vms. Shouldn't really do much since there aren't any data to format. For shits and giggles.

3. Close the Vms editor with OK. The filename you gave now occupies one space in the VMS list under Port A.

4. You start the game, but the game still insists to clear blocks.

 

Are we on the same page here?

 

Anyway, if the game still goes on and on about freeing slots, try Formatting the VMU/VMS via the Dreamcasts internal VMU Manager, if possible.

Link to comment
Share on other sites

  • Replies 22
  • Created
  • Last Reply

Top Posters In This Topic

Let's review a bit.

 

1. You open up the VMS Manager, Click edit next to the first slot in Port A.

2. You click Create Vms, give a filename of your choice and click Save.

2b. Click Format Vms. Shouldn't really do much since there aren't any data to format. For shits and giggles.

3. Close the Vms editor with OK. The filename you gave now occupies one space in the VMS list under Port A.

4. You start the game, but the game still insists to clear blocks.

 

Are we on the same page here?

 

Anyway, if the game still goes on and on about freeing slots, try Formatting the VMU/VMS via the Dreamcasts internal VMU Manager, if possible.

Weird, I did that earlier but nothing appeared in the window. I guess I made a mistake somewhere, too many projects going at once :) Now there is a VMS file in slot one & I got past the memory card select in the game.

 

Now the only problem seems to be that after it gets pasted the Dreamcast start, a loud extended beep sound rings out. This didn't happen till this step. BTW, what folder should the VMS be in?

Link to comment
Share on other sites

It doesn't matter which folder the VMS is in, since the one you created is the active one (i.e. its filename is in the box under Port A in the VMS Manager). Sure, if you want some consistency, put it in the memsaves folder, but you have to re-select the file in the VMS manager afterwards.

 

Sorry, can't say tell you anything about the loud beep. Google it, it has happened to other people, I'm sure. It might have to do with the Dreamcast hardware itself rather than the game or the emulator, but I'm just guessing here.

Link to comment
Share on other sites

It doesn't matter which folder the VMS is in, since the one you created is the active one (i.e. its filename is in the box under Port A in the VMS Manager). Sure, if you want some consistency, put it in the memsaves folder, but you have to re-select the file in the VMS manager afterwards.

 

Sorry, can't say tell you anything about the loud beep. Google it, it has happened to other people, I'm sure. It might have to do with the Dreamcast hardware itself rather than the game or the emulator, but I'm just guessing here.

Thanks a lot for your help. If I find a solution to the beep I will post here so others can benefit from it :)

Link to comment
Share on other sites

Sure thing. After that loud beep, does the game just stop (no graphics, sound etc.) or does the game keep running? What does the console window say?

The beep just goes on forever and the game plays, curiously the game music still plays as well but the beep is louder than the music. Are there better sound plugins to use? Is there anything specific I should edit in the Sound menu?

Link to comment
Share on other sites

No, there are no alternatives to the bundled plugins. At least not to my knowledge. I don't think there are any settings that would affect one loud beep. Changing the sound buffer setting only applies if the sound is scratchy or skips.

 

All I can think of is that DEmul doesn't know how to properly emulate the game, the game is somehow corrupt, or the beep is a trait of the BIOS/Flash you use (being corrupt or something else). maybe DEmul doesn't like your audio hardware. I'm just speculating, though. Having said that, what does the console window say? Anything relating to sound?

Link to comment
Share on other sites

No, there are no alternatives to the bundled plugins. At least not to my knowledge. I don't think there are any settings that would affect one loud beep. Changing the sound buffer setting only applies if the sound is scratchy or skips.

 

All I can think of is that DEmul doesn't know how to properly emulate the game, the game is somehow corrupt, or the beep is a trait of the BIOS/Flash you use (being corrupt or something else). maybe DEmul doesn't like your audio hardware. I'm just speculating, though. Having said that, what does the console window say? Anything relating to sound?

Nope, nothing about sound. Only thing on the console window is GpuDXLegacy | spg: (goes from 34-60) gpu: 26-61 That's it. But I did want to say I selected the Multi Threaded box underneath the Sound plugin and now the beep is gone. Now the only problem is any talking on the game repeats itself (so instead of saying "Go ahead" it would say "go go ahead ahead") but this really isn't a problem for me because the small parts in the game with talking aren't that important to me. The game music itself does not repeat itself. I'll be trying Sonic Adventure once I get it, which the doubled sound would be a problem on that game... So if you have any idea what that could be let me know :) Thanks again!

Link to comment
Share on other sites

If the sound doubles itself or skips, then you can experiment with the sound buffer slider under the sound plugin options. Since you seem have a computer with a multi-core processor, you'll definitely want to enable multi-threading options, both in graphics and sound.

Link to comment
Share on other sites

If the sound doubles itself or skips, then you can experiment with the sound buffer slider under the sound plugin options. Since you seem have a computer with a multi-core processor, you'll definitely want to enable multi-threading options, both in graphics and sound.

I just messed with the buffer slider a little and it looks like it just makes it worse, actually effects the music. It was naturally on 512 which is the lowest, I doubled it and it made the skipping in the music. So it looks like I might be stuck with that :/

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...