Jump to content

need some help for SDL_sound


celiswen
 Share

Recommended Posts

what has to be install?
i can't find SDL_sound for mingw from yay
 

Building Raine, Fully optimized version with x86_64-w64-mingw32-gcc for mingw32 CPU=
dependencies : if you get an error here, install the required dev package
libpng:1.6.37
SDL:2.0.20
Linking Raine...
/usr/lib/gcc/x86_64-w64-mingw32/11.2.0/../../../../x86_64-w64-mingw32/bin/ld: cannot find -lSDL_sound
collect2: error: ld returned 1 exit status
make: *** [makefile:1396: raine.exe] Error 1

 

Edited by celiswen
Link to comment
Share on other sites

You forgot to tell how you did that, what you try to build... it seems to be in mingw32 ?

Well normally there is no SDL_sound, it was merged inside for SDL2. But you might have found an old place in the makefile where it's still used... I'll check in mingw32...

Ok, after checking there is something you did obviously wrong here, but I don't know what it is. Did you check the short guide on how to compile ?

It's there : http://raine.1emulation.com/download/install.html

Normally from mingw32/mingw64 native, you don't need to edit the makefile at all, just git pull to update the source, eventually edit it if you want a debug build, and that's all, just make.

Here your try to use x86_64-w64-mingw32-gcc as gcc, did you try to uncomment 1 of the targets ? It's useless in mingw, it autodetects what you are trying to build from your environment, and adjusts, these targets are useful only when you crosscompile and it can't guess, usually from linux.

Edited by Tux
Link to comment
Share on other sites

i uncommented target=x86_64-w64-mingw32 in the make file

i see so i may need wait for your 32bit fix today. btw I cant find 32 bits version of muparser to 2.3.3 on google

Edited by celiswen
Link to comment
Share on other sites

Ok, don't do that, there are 2 shells, it builds depending on the shell you are running, if it's mingw32 it tries to build a 32 bits binary if it's mingw64, it's a 64 bits binary.

But anyway I found a forgotten -lSDL_sound, just committed the change now, use git pull to update the makefile.

I didn't notice it earlier because the lib doesn't even appear in ldd in the resulting binary, and I have a SDL_sound lib in my path so it's working here.

I needed someone to test this in real mingw32 to find it, sorry for the problem and thanks for trying this !

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...