Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
petran79

Art of Fighting 3 black screen at DEMO CUT OFF

Recommended Posts

In order to activate the story sequence and dialog encounters with every character when choosing Ryo or Robert, this option has to be off. It is on by default.

Problem is that after picking either Ryo or Robert, there is a black screen with sound during story mode.

 

Other characters play fine since there is not any story mode.

 

This happens only with Raine. NeoRaine plays Robert and Ryo sequence fine

Share this post


Link to post
Share on other sites

You didn't even mention if it's with the neocd or neogeo version ! There is indeed a problem with at least the neogeo version, interesting that it's reported only now.

For info raine incorporates the code from neocd but it's newer, so if it worked with neoraine it just means that a fix for something else created this black screen problem.

Sorry I won't look into this right now, but I'll probably take a look later...

Edited by Tux

Share this post


Link to post
Share on other sites

Ok, sorry for the long delay, anyway it doesn't require a release to fix this at least, it's because of the speed hack for mslug2 which interferes here.

So the solution is to simply disable speed hacks from the neocd options before playing this game.

I'll put a fix and some comments in the code for that.

 

Code updated in git, next release will have a workaround for this.

(actually it was the garou speed hack which was creating problems here, but this started to happen because of some changes for mslug2... sigh !).

 

EDIT : on 2nd look the problem is very specific to aof3, it shouldn't happen in any other game.

Edited by Tux

Share this post


Link to post
Share on other sites

Sorry for the bump again.

 

A new issue has emerged in the game:

 

In v0.64.11, in-game fight screen appears to be all white now, with just some in-game bars and letters appearing.

Problem disappears only if I go to layers and disable the first option,leaving just sprite layer active.

 

But then I cant see the energy bar or in-game dialogue during the pre-fight scenes.

Edited by petran79

Share this post


Link to post
Share on other sites

disable speed hacks in neocd options ?

Sorry testing this requires to restart from scratch, no saved game because they would contain the speed hack.

Edited by Tux

Share this post


Link to post
Share on other sites

I did disable them but there is no difference. I'll try different options.

After reverting to 0.64.9, stage 1 and menus appear fine. But I notice that there are some missing sky backgrounds

 

Only the last version of Neoraine 1.4.3 plays the game fine.

Share this post


Link to post
Share on other sites

For now I'd say use neoraine-1.4.3 then, I am in no mood to debug this for now !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...