Jump to content

Problem with promiscuous mode


moncul
 Share

Recommended Posts

Hello,

 

i'm trying to capture packets the same way it's done ds_wifi_lib_test :

Wifi_EnableWifi();
Wifi_SetChannel(3); //my AP channel
Wifi_RawSetPacketHandler(PacketCaptureHandler);
Wifi_SetPromiscuousMode(1);

(i tried with auto TX Rate, then forced to 1 and 2 mbps : always same result)

my problems are :

1. the DS captures on all channels (i see packes from AP on other channels, and mine too of course)

2. the DS doesn't capture my AP arp requests (the one i send with my connected PC) : it only captures beacon frames

 

any ideas for these behaviours ? (especially the 2 ! i can easily filter the 1).

 

Thank you.

 

edit: same pb with 0.3.1 and 0.3.2

Edited by moncul
Link to comment
Share on other sites

Hiya,

1) this is a side effect of how wireless works - several channels overlap, so it's possible for a channel 7 station to receive data from channels 2 through 12, though it's much better at receiving data on channel 7. This is why channels 1, 7, and 13 are often used by the firmware, because 1,7,13 are sufficiently spaced that they don't receive packets from each other.

2) This is known, the "promiscuous mode" of the wifi lib is not perfect. There are some people who have managed to make it work, but I don't have the solution around at the moment. It involces changing the filter register on the arm7... I will post a reply if I find the value it needs to be set to.

 

-Stephen

Link to comment
Share on other sites

  • 4 weeks later...

Hello,

 

i've set W_RXFILTER (0x80D0) to 0xFFFF.

Now i seem to receive all packets if my access point is configured to not use security.

But once i enable WEP on my AP, i only capture beacons again.

 

So I think it may be the "DS hardware WEP engine" that prevents the lib from getting the "raw no decryptable by hardware" packets.

I tried to disable it (0x0032 set to 0x0000), but this doesn't change anything.

 

am i missing something for disabling totally the hardware WEP engine ? do you think i am on the "good way" ?

 

Thank you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...