Jump to content

Problems with Ruby/Sapphire VBA Link


Recommended Posts

I tried to link Ruby and Sapphire together but after entering the trade room, i got "Link Error....Check connection then turn off and on GBA...(Something like that )". I've done all the steps the websites and forum mention and found out that many other people manage to link without problem..Can someone help me?

Link to comment
Share on other sites

I will be glad to help you. My first question is what version of vba-link are you using? Second, what exactly are you doing in order to link? You should note that there is a setting the pauses the emulator when it's inactive and this could be why you're loosing the link.

 

To disable this feature go to Options->Emulator. Now just click on "Pause when inactive window" to unselect it (only if it has a check mark next to it, if not then it is already disabled). Make sure you do this for both windows before you start the link.

Edited by Haldrie
Link to comment
Share on other sites

Hm...check the link settings and make sure that they match. They should be set for "Single Computer" and the timeout should be set to 1000. If it still doesn't work try changing the timeout to 500 and try that. Make sure that when you are linking that you do not open any of

the menus as that will pause the emulator and break the link.

 

There's not that much else to tell about linking. I hope that works for you. If it doesn't then it's either something you're doing wrong that emulator. I am also using 1.8 beta 0 and I haven't had any problems.

Link to comment
Share on other sites

I tired to download the emulator ( VBA link ) and start all over again but i still have the same problem... :( But thanks for your respond...I tried to link between two pc with LAN but one of the emulator on the other pc's not responding once the character enter the trading chamber... In single pc, one of the emulator become not responding a while then the link error message appear...My pc is Pentium duo core 3.4 ghz, 1024ram....i tried to switch off the sound but it wont work either... :P

Link to comment
Share on other sites

In order to connect between two computers you have to set up the LAN properly. I've never done this myself but I will do some tests with this feature and see if I can still help you out. I assumed you were using the same computer with two sessions of VBA-link.

 

[EDIT]

Ok I did some tests with some simple games that let you play simple multiplayer game from the start of the game and was able to get it working.

 

Setting up a LAN network between two computers:

 

You will need:

1 patched CAT5 cable to connect each computer together with one cable (these cables have the wire reversed at each end so there is no need to use a hub) or

2 standard CAT5 cable and a simple network hub to connect each compter to each other

 

Connecting the compters with the patch cable:

simple connect the patch cable to the LAN port of each compter

 

Connecting the compters with a hub:

Plug the hub into it's power source (usually a simple AC adapter)

Connect one end of each of the standard CAT5 cables to one of the numbered ports on the back of the hub (except for the last numbered port as that is used for another purpose)

Connect the other end of the cables to the computers you are trying to network

 

Configuring the computers:

The only thing you need to do with the computers is make sure that they are set to use the same workgroup and that the computers' network names are not the same and the network should work. If you want to share files between the computers you will have to enable File and Printer Shareing. If you need help doing this let me know.

 

Using vba-link in a LAN network:

 

Open the same version of vba-link on each computer

Go to Options->Link->Settings (or press Ctrl+M)

Under the General tab choose "Network"

On one computer go to the Server tab and click "Start", you will be given the IP address of that compter

On the other compter go to the Client tab and enter the IP address of the Server computer and then click "Start"

The Server computer should now pop-up a window saying that a player has connected and will ask you if you want to wait for more players

Click "No" and "Ok" on all the other windows and start your game

You should now be able to link between the two computers just like you were linking two GBAs

 

Make sure that you do not interrupt the link by opening one of the drop-down options when the games are linked or you will loose the link between the games. You should still be connected on the LAN though so in order to get the link back just reset the games and start the link again.

 

I hope this helps and if there's anything you don't understand just let me know.

Edited by Haldrie
Link to comment
Share on other sites

  • 2 years later...
I tired to download the emulator ( VBA link ) and start all over again but i still have the same problem... :( But thanks for your respond...I tried to link between two pc with LAN but one of the emulator on the other pc's not responding once the character enter the trading chamber... In single pc, one of the emulator become not responding a while then the link error message appear...My pc is Pentium duo core 3.4 ghz, 1024ram....i tried to switch off the sound but it wont work either... :)

 

 

im new arround here... xD

 

sorry, but i had the same problem trying to do that with my pokemon ruby and saphire... but i was like trying anythng just because i lost faith on it xD... and put 10000 on the 'link time ut' at the Link Options and it worked!!! :huh:

 

hahahah it was so funny xD...

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...