registry = ipsRegistry::instance(); $this->settings =& $this->registry->fetchSettings(); } public function getOutput() { return; } public function replaceOutput($output, $key) { require_once( IPSLib::getAppDir('ibprobattle') . '/sources/battleHooks.php' ); $this->battleHook = new battleHooks( $this->registry ); return $this->battleHook->statsTopicView($output, $key); } } ?>registry = ipsRegistry::instance(); $this->settings =& $this->registry->fetchSettings(); } public function getOutput() { require_once( IPSLib::getAppDir('ibprobattle') . '/sources/battleHooks.php' ); $this->battleHook = new battleHooks( $this->registry ); return $this->battleHook->statsTopicViewJS(); } } ?> OpenGL shader + Windows 10 - Raine - 1Emulation.com

Jump to content

Welcome to 1Emulation.com
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account
Photo

OpenGL shader + Windows 10

- - - - -

  • Please log in to reply
3 replies to this topic

#1
Parse

Parse

    Newbie Poster

  • Members+
  • 3 posts

Somehow after I updated to Windows 10, most of the OpenGL shaders are fuzzy or show a black screen. The only working are simple scaler and scanline. Is it a problem on my PC or Win10? How can I get to work?

 

Selecting Normal Blits I can get HQ2X/3X but the screen is not full, it's a little square at the center. Can it be possible to strech to fill the screen an maintain 4:3?

 

I don't know if it's a bug, but even when using win8 + fullscreen in OpenGL, when I pressed ESC the menu just wouldn't show up, like the screen freezes.



#2
Tux

Tux

    Author of Raine

  • Emulator Author
  • 191 posts
  • Gender:Male
  • Location:Nantes, France

These are opengl shaders, so they depend on your opengl implementation only, I'd say your best bet is to update the video driver then...

 

Eventually try windowed mode instead of fullscreen it might help for the menu issue you have (just resize the window to fullscreen).


Edited by Tux, 12 December 2015 - 04:02 PM.


#3
Parse

Parse

    Newbie Poster

  • Members+
  • 3 posts

Thanks.

 

However updating my video drivers is what caused it. I just confirmed it on my notebook and desktop.

 

Is it a problem with OpenGL 4.5? Or the new 359.xx nvidia drivers? Or even Windows 10?

 

I have not this problem using opengl shaders in other emulators though.



#4
Tux

Tux

    Author of Raine

  • Emulator Author
  • 191 posts
  • Gender:Male
  • Location:Nantes, France

It's obvious it's a problem with your opengl implementation, now I can't help you anymore on this, I don't know what's wrong there, maybe nvidia broke something in its latest drivers... These are not opengl 4 shaders, it's some rather old stuff mainly, but there are different versions out there.

 

By the way you can just disable the shaders and then use the default opengl output, you have 2 options there, it should be enough, shaders are not mandatory here. To disable the shaders, select a new shader, when the list appears either press esc or the mouse button 2, it will ask you if you want to disable them, it's probably your best option here. You can also try to use the drawpixel opengl rendering, it has no shaders.

 

I hope it helps !

By the way I won't switch to windows 10, I don't want to have anything to do with microsoft spyware mess...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users