Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
DrTech

Raine closes when loading a game with a shader enabled.

Recommended Posts

Has anyone had this problem and managed to solve?

My Raine emulator closes when trying to load a game with a shader enabled. If the shader is disabled, the emulator works normally.

My settings are as follows:
SDL Video driver: SDL Default (windib since 1.2.10)
Video renderer: OpenGL

When enabling the CRT.shader or any other shader in renderer options / Shader, the emulator closes when loading a game.

Thank you all.

Share this post


Link to post
Share on other sites

That's a good one... You forgot the video card ? I never saw shaders crashing the program so far, usually it works or it doesn't that's all, it's a 1st time here.

Well it works here of course, but it's very likely something related to your video card. I'll check later in windows, but since it works in linux here it should also in windows.

Also you can try to run the emu from the command line and redirect the output, like this :

raine > log

when it has closed because of your shader check the log file to see if there is something interesting in it, at the end.

edit : yeah no problem for me in windows fullscreen with the crt shader, as expected.

Edited by Tux

Share this post


Link to post
Share on other sites

Well it's worth trying a driver update, it shouldn't crash normally even if the video card can't handle it if the driver is well done it just returns an error message which is displayed by raine.

2nd solution : it just doesn't work, doing nothing noticeable on screen.

3rd : yours, never seen before, it crashes -> something is probably wrong somewhere, try to update your driver.

Share this post


Link to post
Share on other sites

It may not be the video card driver. I run the LOG and Raine returned the following message:

RAINE (680x0 Arcade Emulation) 0.91.7 (c) 1998-2020 (!) Raine Team

CPU:
joy 0 opened (Controller (XBOX 360 For Windows)), numaxes 5
read_shader ...
shader: couldn't find file E: \ Emu \ Consoles \ SNK Neo Geo CD \ shaders \
adjust gui res from execute
default anim: c190e2
read_shader ...
Errors validating shader program 0: (len 89 max 90) Validation warning! - Sampler value rubyTexture has not been set.
Validation successful.

fixing aspect ratio to 0.75 - new res 304 x 228
fixing aspect ratio to 0.75 - new res 304 x 228
driver name: SDL dsound

It looks like there is something wrong in the <shaders> folder. I think my shaders are old or don't match the current Reine version.

Where can I download the shaders for Raine?
 

Share this post


Link to post
Share on other sites

Yes it means the driver has a problem, rubyTexture is the base of this shader, it contains the game bitmap, it's sent for all the frames.

I don't get any warning about rubyTexture with my nvidia, so there is definitely something wrong with the way the shader is interpreted by your video driver.

2 choices : just ignore the shaders, you can live without them after all, or find a better video driver... !

And the reason you don't see the message on screen is because it's said it's a warning, the validation succeeds in the end, but if it misses rubyTexture, it misses the main point, the crash could very well be a divide by 0 at this point !

Edited by Tux

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...