Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
zero5

New Fba-xxx With Source

Recommended Posts

I don't think you can make the path with a drive letter yet. You have to use the "root path" which is normally D:

 

This is what I have for paths and I just stick all my ROMs in the Roms folder. If you wanted to split them up you could use seperate folders under there and edit them in the ini.

 

// default path

szAppRomPaths[1] d:\roms\

 

// cps1 menu path

szAppRomPaths[2] d:\roms\

 

// cps2 menu path

szAppRomPaths[3] d:\roms\

 

// Neo geo menu path

szAppRomPaths[4] d:\roms\

 

// Other menu path

szAppRomPaths[5] d:\roms\others\

Share this post


Link to post
Share on other sites

i use definite paths and it works with mine...

 

my ini...

 

// default path

szAppRomPaths[1] f:\emus\Kawa-X 0.11\roms\

 

// cps1 menu path

szAppRomPaths[2] f:\emus\fbaxb4.1\roms\

 

// cps2 menu path

szAppRomPaths[3] f:\emus\fbaxb4.1\roms\

 

// Neo geo menu path

szAppRomPaths[4] f:\emus\Kawa-X SE\roms\

 

// Other menu path

szAppRomPaths[5] f:\emus\Kawa-X Plus\roms\

 

as you can see my neogeo roms are all scattered, it's a mess cuz i have regular roms in one dir and the different banned sets in others...

 

my only complaint with xxx is it doesnt read all the dirs for everything, instead it reads the first dir if you have independent dirs off... and only 2-5, but not the first 1, and only one for each menu if you have it on

Share this post


Link to post
Share on other sites

hmm well it doesn't seem to work for me at all and i'm not sure exactly how i can dupe fba-xxx to making a new ini (the controller configs got their own ini's so that doesn't help me).

 

btw, this same ini worked fine in the version that came out a 2 days before the latest

Share this post


Link to post
Share on other sites

Have you tried putting a path for every menu (even if they're the same ones)?? That's the only thing I see different so far between the inis posted.

Share this post


Link to post
Share on other sites

tried that and nothing

 

EDIT: found my problem, the ini name was off one damn x (was fbaxx.ini and now is fbaxxx.ini)

 

another thing thats been bugging me lately too is eveytime i start to work on his src, visual studio will keep getting the hourglass like crazy (seeing not responding in the title bar as well) but this never happens when compiling the normal source.

 

any help on that?

Edited by Prican25

Share this post


Link to post
Share on other sites
well i just compiled using the lastest source but now it won't see my roms  :D

 

this how my fbaxx.ini is:

// FBA Config File

// Don't edit this file manually unless you know what you're doing
// FBA will restore default settings when this file is deleted







// The paths to search for rom zips. (include trailing backslash)

// default path
szAppRomPaths[1] e:\Emulators\Kawa-X\Roms\

// cps1 menu path
szAppRomPaths[2] 

// cps2 menu path
szAppRomPaths[3] 

// Neo geo menu path
szAppRomPaths[4] 

// Other menu path
szAppRomPaths[5] 




// Sound options
bAppBassFilter 0
nInterpolation 1
nFMInterpolation 0




// Video Options
nHardwareFilter 0
nCurrentFilter 1

// Neo geo Options
AutoUnibios 0
bAppOC 1
TurboOn 1

// Menu Options
firstmenu 1
secondmenu 1
thirdmenu 1
fourthmenu 1
counterfirst 0
countersecond 1
counterthird 2
counterfourth 3
choosepath 0

I compiled the latest source too. And I find that he has changed the name of fbaxx.ini to fbaxxx.ini. So rename your fbaxx.ini to fbaxxx.ini will fix your problem. :P

Share this post


Link to post
Share on other sites

:D:P:P

 

Thank you Vermillion. I'm an idiot when it comes to this stuff and your post put me on the right track. Now I have everything up and running without any problems. Thanks again.

Edited by Foolius

Share this post


Link to post
Share on other sites

HK$ thx but if you read my last post i figured that out :lol:

 

now i still need to figure out why in the hell visual studio always acts so busy when i start edited his src (getting the hourglass from the mouse and the title bar saying "not responding") yet when i do the normal src it didn't act like that :lol:

Share this post


Link to post
Share on other sites
FBA-xxx 25.04.2004 was released today, was there a xbe with support for banned roms as well?

This has already been posted before, but you can get the latest xbe with banned roms enabled from here:

Edited by Prican25

Share this post


Link to post
Share on other sites

I thought that special xbe was for 20.04.2004? They updated this link for 25.04.2004 already??

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...