Jump to content

Raine 0.93.5


Tux
 Share

Recommended Posts

Linux appimage version not has good vsync without problems.

That problem with vsync not is related with adaptive v sync ?

 

Thanks Tux for your improvements in Raine.

Link to comment
Share on other sites

Posted (edited)

Ok finally found mer-curious inversion problem, the 64 bits version doesn't have the same indexes for this dialog, so I check directly the labels now to work around that... !

And finally fixed the inputs dialog problem when using the mouse (index error).

That makes a 0.93.5b package : http://raine.1emulation.com/download/latest.html

I hope there won't be any 0.93.5c !

Edited by Tux
  • Like 1
Link to comment
Share on other sites

Hello Tux! I'm so glad you could reproduce and fix these little issues. I hope it haven't taken too much of your time.

I went and tried it and everything is fixed indeed. Thank you so much for that. 👍

By the way, you forgot to update the download links in the Downloads page. I was clever enough to remember the first revision link was "0.93.5a.7z", then I just edited the link to "0.93.5b.7z" and gained access to the file.

Anyway, thank you again for your work.

Link to comment
Share on other sites

No, it's just a static page so it isn't updated if you viewed the old version with your browser.

You need to use refresh, or F5, or quit your browser and relaunch it.

Link to comment
Share on other sites

1 hour ago, Tux said:

No, it's just a static page so it isn't updated if you viewed the old version with your browser.

You need to use refresh, or F5, or quit your browser and relaunch it.

I did that and it kept the same unfortunately. Now that you said it could be a browser issue (I was using Firefox) I went and tried loading the page with another browser (Chrome) and still couldn't see the updated link.

Anyway, thanks again for your fast response.

Link to comment
Share on other sites

Oops, my bad, this page is static but generated by a script, usually it selects the latest version by itself, but here it was lost because of these letters at the end... !

It's fixed and the page is updated, sorry !

  • Like 1
Link to comment
Share on other sites

and for adaptive vsync, it's used if supported by your hardware, just run a game, then go to video infos. If it's supported you'll have the last line which reads :

Opengl vsync : Adaptive

But it's not a big deal anyway, it's just about enabling vsync when the fps becomes too high and disabling it when it's too low, normally it's never too low in raine.

We don't like to wait for anything in raine, so we use double buffer here, and it's possible to disable it in the menus, it allows to display a frame while we work on another one, and the swapping of frames is done automatically when a vsync arrives. It works well if you don't have a crappy monitor like mine which doesn't support 60 fps, but it's not far, it's 59.88, that's why I added an option to be able to lower the fps used by the drivers.

Link to comment
Share on other sites

Hey Tux! I guess I've just found a bug in the game selection screen in which the highlighted string will not follow the mouse cursor. It seems that the highlighted string remains stuck in the first page of the game list, which makes the navigation with mouse very confusing.

I don't remember experiencing this issue before revision 0.93.5b, so maybe it was introduced in it?

Anyway, I didn't want you to make a third revision of this version, but I'm reporting it so you can check it if/when you have the time to.

By the way, I've recorded a short video so you can check what I'm experiencing here. Take a look:
https://drive.google.com/file/d/1vumoOjPwnsBo-9Ve_foFCDM-r41JyacG/view?usp=sharing

 

Thank you so much again for your work. 👍


PS: I tried deleting my raine32_sdl.cfg file but it didn't help much unfortunately.

Link to comment
Share on other sites

Yeah I feared that, the bug with mouse sensitivity forced me to change a function in the core of the gui, which is very dangerous, and I was almost sure there would be a problem... Maybe I should have taken more time to check things. Well I got a cold + some covid from a friend lately, so it's a little hard currently, I'll go and check for this covid a little later.

So at least I know where the problem comes from, even if it's not obvious to fix, I'll look into it later.

Meanwhile, use the keyboard for the game selection !

  • Like 1
Link to comment
Share on other sites

Ok, so the error was very limited, forgot a variable was linked to menu_disp and not to menu directly, which is normal since this code is almost never changed, I should just have waited longer to check things, blame the covid for that ! So it makes a new binary for a 1 line change only !

Find 0.93.5c there, and sorry !

http://raine.1emulation.com/download/latest.html

  • Like 1
Link to comment
Share on other sites

Hey Tux! I'm so sorry for your being sick lately. Curiously I was feeling really sick too a couple of weeks ago. I don't know if it was Covid or "normal" influenza virus because I didn't go to the health care center to test (I preferred to just rest at home), but I suffered a lot in the first days. Hopefully I'm much better now.

About the bug in the GUI, I went and tried version 0.93.5c but couldn't see if the fix worked because the emulator is crashing every time I visit the Change/Load Rom menu. I'm coming from a new installation (without the raine32_sdl.cfg file), so maybe this is triggering the crash?

Anyway, I hope you get better soon and, when you do, check this issue if you have the time.

Thank you again for your work.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...