Jump to content

A last one : 0.91.18 !


Recommended Posts

I might have released 0.91.16 & 0.91.17 too fast, but this one finally holds its promise : all the cps2 games supported (at least those using qsound, gigaman2 being a bootleg without any z80 rom it's out of the list, I even added it to non working games !).

Except that I finally added some breakpoints in the console for the z80 which helped me a lot to finish this. And updated the help for the regs and break commands, still in the console.

Sorry for all the bad binaries lately, it should be finished this time !

http://raine.1emulation.com/download/latest.html (refresh the page if it shows something else than 0.91.18 !).

  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

Hi Tux

Long time no see, glad to see that you're still so active and busy with Raine support! :)

Just a bug report about the new Raine releases, 64-bit Windows version.

I tried the 'emuDX' versions of the 5 supported games, using the required ROMs and the .dx2 files from the Rainemu online repository.

Unfortunately none of the emuDX games seems to run well. All transparencies are shown as purple pixels. I note the original bmp included in the .dx2 files do have purple backgrounds, so it appears to me like what was is purple was supposed to be treated as 'transparent' but this is not happening.

Tried with the SDL and DirectX renderers, no change. I have an i7 with a recent Nvidia card, running on Windows 10 64-bit with all latest updates and drivers.

Please let me know if you require more info. Tnx


Link to comment
Share on other sites

That's another incompatibility added when switching to the opengl gui in 0.91.8, so as I said earlier I just reuploaded the 0.91.7 windows binary, you'll find it at the top of the old versions page since I just reuploaded it, it's seen as a 2021 binary :


Of course I didn't make this change only for the joy to have more bugs, it was fixing the really annoying bugs of the windows version in fullscreen, so you'll find them again in this 0.91.7 binary. This was using some functions branded as unstable from sdl-1.2 and the docs says not to use them, so there was a price to pay of course...

The real fix is to switch to sdl2, but for now I'm out of motivation, sorry !

Link to comment
Share on other sites

Hey there - sorry I just read this reply a bit late (did not activate the push notifications)

Thanks for the kind response, will try the 'old' version 0.91.7.

Needless to say, hope to see the DX support fixed permanently.

But I do understand what it means to fight against the lack of motivation. Be well my friend, things will get better, I promise. :)

Link to comment
Share on other sites

Hm.... just wanted to post a tiny attachment to show you something to lift the mood and give you some motivation... but although the image is just 64Kb, I am getting a 'file too big' error on the board. If this can be fixed, I can post something you will love :)

Link to comment
Share on other sites

14 hours ago, Robert said:

According to the admin settings, you can post up to 100KB total of all your attachments.

Yep, I have tried to upload a single image of 64 Kb but got that error and could not upload it. And I have never uploaded anything before.

Edited by _MADrigal
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...