Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Tux

Raine 0.91.7

Recommended Posts

Posted (edited)

No rush, it just surprised me. I don't think I've ever played Opwolf on Raine before, always on mame...

Edited by jvidal

Share this post


Link to post
Share on other sites
Posted (edited)

Finally it's a quiet day here and I was curious, so I looked into it.

The opwolf in raine uses the z80 rom from opwolfb to emulate the c-chip, so it's a kind of improved bootleg but not exactly the real opwolf, the c-chip is not emulated.

The sound problem was not as hard to find as I thought first. There were 7 bytes for the sound commands from 0 to 6, Antiriad tried byte 6 as sound activator, it was byte 4 (as found in mame). This means he never finished stage 1, or didn't care. Also the aiming is a little too high in opwolf (not in opwolfb). So I fixed the sound and the aiming, which are very short fixes.

There are hacks everywhere in this driver... anyway ! It's fixed but not released, it's ultra low priority since it's been like that for 20 years, but it will be fixed in next release then.

 

Edited by Tux

Share this post


Link to post
Share on other sites
Posted (edited)

like I said, no rush! but, I'm glad you found the bug. I guess it'll be fixed in the next release.

Thanks!!!

 

On a different note, as I mentioned before, there are some games that do not match the MAME sets, so they don't work. For example, terra force won't run because it's missing a file, but the file exists in a clone set in mame.

So, my question is: is there a way to make Raine search for roms in clone sets as well? In this particular case, the file required is not present in set terraf, but it is present in set terrafb (MAME naming).

 

just in case you didn't notice, I'm using the mame ROMs folder as the ROMs folder for Raine.

Edited by jvidal

Share this post


Link to post
Share on other sites

Yeah it's an endless race to try to keep compatibility at the rom level with mame, all that because when they find a newer set, instead of adding it as a new set, they replace the main one by the newest they just found, breaking compatibility with all the sets all the time. Too tiresome. I do it mainly for cps & neogeo, for the others it's from time to time, but very rarely. terraf is a horrible game anyway !

On my side I hate breaking compatibility with existing sets (I mean the ones which worked in previous versions on raine), even if there are utilities to fix that.

Share this post


Link to post
Share on other sites

Finally updated the opwolf driver, a real update this time, the 1st one in more than 10 years !

 - Automatic rom loading
 - samples live decoding instead of the long static sample list + the hack to insert the sample codes in the rom
 - the driver is now shorter and uses the mame rom - actually the only difference is the last 68000 rom which was probably badly dumped in the raine version, never found where it creates a problem if it creates one, but it's probably safer to update this romset anyway !

It won't interest a lot of people since this bug survived for so long, but really this code needed some care... !

Share this post


Link to post
Share on other sites
On 7/15/2020 at 5:08 AM, Tux said:

Finally updated the opwolf driver, a real update this time, the 1st one in more than 10 years !

 - Automatic rom loading
 - samples live decoding instead of the long static sample list + the hack to insert the sample codes in the rom
 - the driver is now shorter and uses the mame rom - actually the only difference is the last 68000 rom which was probably badly dumped in the raine version, never found where it creates a problem if it creates one, but it's probably safer to update this romset anyway !

It won't interest a lot of people since this bug survived for so long, but really this code needed some care... !

Unfortunately something got screwed-up in the process.

Everything looks good dutring attract mode, but the minute I insert a coin and press 1p start, all sounds go mute (music, speech, effects). Completely mute.

Oh, and another thing I noticed is that when you press the "insert coin" button, you get 7 credits at once, instead of just 1...

Edited by jvidal

Share this post


Link to post
Share on other sites

The 7 credits at once has always been here, I won't fix it for now (not one of my prefered games by far, so I won't loose too much time on it).

For any other problem : weather way too hot for now, maybe later, I don't know when !

tested it in the heat : only the music goes mute for me, but slowly, it's a fade out and it comes back at the end of the level.

The other sound effects seem ok. And it's not 7 credits but 4, but it's still too much anyway.

I'll probably leave it as it is !

Edited by Tux

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...