Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Robert

ARCADE64 0.220 released

Recommended Posts

Maybe they are in fact 5% too fast and  that causes the sound  suffering. I'm unsure. 

Share this post


Link to post
Share on other sites

Most of the changes were because of efforts from the original programmer (before I took over), of fixing bugs of some kind.

 

Perhaps it's time to rip all that out? It's up to you guys if I should.

 

You'll need to identify which games need to be adjusted - I have no idea.

Share this post


Link to post
Share on other sites
Posted (edited)

I could investigated this too but I need examples. Problems with option triple buffering, sync to monitor refresh or similiar ?

Wait for vertical sync, sync to monitor refresh and tripple buffering - all options are slowing or speed up games depends on frequency used by game and by desktop.

 

Does sync audio with avideo is still present in ARCADE32/64? It was imported from groovymame long time ago?

It is still in source, I should check this at first and it works with proper options combinations :)

Edited by haynor666

Share this post


Link to post
Share on other sites

Very good hint! Thank you.

It's easy to test with "Turtles" because the intro music will significally slow down when "Triple buffer" or "Sync to monitor refresh" or "wait for vertical sync" are on. When all three options are off, the music is back to normal. Highest impact seems to be "wait for vertical sync".  Does this help investigating?

Share this post


Link to post
Share on other sites

Try delete entire ini folder and run ARCADE32/64 again. Set just one option for example wait for sync. See if this makes difference.

Share this post


Link to post
Share on other sites

I deleted the INI folder but it didn't help much. When I  turn on wait for vertical sync, sync to monitor refresh or even triple buffer, the sound is slower and sometimes suffering oder stuttering. When I leave these options off, the sound is fine. Try Phoenix, it's a good example.

Share this post


Link to post
Share on other sites
Posted (edited)

With vertical sync enabled I can confirm sound pitch change in Phoenix. With sync to monitor refresh also Phoenix has slight pitch change. In both cases game speed is also changing. Just press F11 and observe game start. Note - this does not happen all the time. But other games like Aero Fighters working at 61,31 Hz is fine. It has constant 98 % speed with not speed changing during game. Air Duel originally working at 55 Hz speeds up to 109% together with sound but that is expected and working as it should in this case. Turtles is also working fine at 99% speed and sound is also slowed down as it should.

Edited by haynor666

Share this post


Link to post
Share on other sites

Can someone tell me how to enable hiscore support for this version? I enabled the plug in put the hi score dat in the folder tried putting it in the hi folder. Enabled it in ini. Every game I play the score is not saving. What Am I doing wrong? 

Share this post


Link to post
Share on other sites
Posted (edited)

You better try to create a new mame folder from the 0 and move only the data you need. Roms, samples, images etc... and try again. It can be the nvram or cfg file.

Edited by Hyperscorpio

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...