Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Robert

ARCADE 0.198

Recommended Posts

Hi robert, how can i mame mom run neogeo games and cps1 cps2 in 60hz?

if I enable monitor synchronization (syncmonitor) the games run at a higher speed. example: the current neogeo speed is 59.1hz ... but the correct one would be 60hz, and everything would run smoothly and correctly!

Edited by therodridie

Share this post


Link to post
Share on other sites

 

Now what about the what i said about the mouse is no longer locked and i can get it outside from the games?

This might be a problem if you use the mouse for shooter games with a lightgun.

Share this post


Link to post
Share on other sites

Yes the mouse is allowed to roam free on the desktop, like any windows app, and like SDLMAME.

 

If you have a game where that could be a problem, switch to fullscreen.

 

 

 

@therodridie: this is something i don't know about. Maybe someone else knows. Or maybe you might need to use groovymame. Let's see what others have to say.

Share this post


Link to post
Share on other sites

Syncrefresh in ARCADE32/64 works just like like in groovymame so running with this option speed/sound pitch change is expected either slightly slower (galaxian driver) or slightly faster (cps2, neogeo drivers) or even far too fast (m72 driver).

Share this post


Link to post
Share on other sites

@haynor666 activating the syncrefresh causes the sound of the game to be + accelerated and jumping from time to time ... the correct one would be 60Hz for all games with a frequency of 57hz up!

 

 

@Robert You're excellent mamedev.
So you can see with mame time a way to put at least one frequency option for the drivers like cps1 cps2 and neogeo, because these units have frequencies very close to 60Hz, it does not cost anything to add a frequency choice option! Think about it Robert ... thanks!

Share this post


Link to post
Share on other sites

Sound hiccups sometimes happen and I'm affraid I don't have one 100% solution. It not just sound but also video or in general game speed but most users will only notice sound. Just make sure that only syncrefresh option is mark under Advanced menu. Some people reports that disabling Intel Speed Step or automatic clock ratio may help as well.

 

Options for choosing frequency is available for many years but to use it You have to enable cheat in mame. After this run game, hit TAB and enter slider controls. It will available from now on. Note that game speed will be changed just like with syncrefresh option.

Edited by haynor666

Share this post


Link to post
Share on other sites

@haynor666 screen refresh rate in sliders controls changes only the first 2 digits, it is not possible to change the frequency completely ... example: 59.18hz - it is possible to change only 59 ... it is not possible to change 18 ... then the frequency will be 60.18hz and this it's wrong.

the correct one is 60.0hz exactly.

Share this post


Link to post
Share on other sites

That's true but Your monitor frequency is also not exactly 60 Hz but 59,8 for example.

Share this post


Link to post
Share on other sites

@haynor666 I do not understand why mame time solve the frequency of neogeo cps1 cps2

in the old mame up to 0.100 and 0.012 neogeo cps1 cps2 ran the games perfectly and with smooth scrolling at 60.0hz
this change in the frequencies of the current mame, is a mistake of the mame time, because this interferes in the originality

Share this post


Link to post
Share on other sites

No, 60 Hz was wrong. As mame progressed (devs, hardware for analysis) they discover exact frequencies for many games. 60 Hz is just a theory and a symbol of NTSC signal. In practice many consoles, arcade machines run at different frequencies (even 62 Hz), some even use 55 Hz (many Irem games) some 57,444 (many Data East games). Changing frequency always cause change in game speed tjat is not true/intended by game/hardware developer.

Share this post


Link to post
Share on other sites

I'm seeing Kung Fu Master (US) running about double it's normal frame rate (too fast). Throttle is on. Any idea what is going on?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...