Jump to content

ARCADE 0.188


Recommended Posts

Thank you as always Robbert and Mamesick!

About the bug that Chanbara said, I could test it on XP and 7 and reproduce it on both.

'gui/interface.ini' has no problem but 'ini/ui.ini' gets broken.
It happens in both 32 and 64 version ARCADE.

I tried various directory names like these:

C:\MAME Support\DATs	> NG
C:\MAME_Support\DATs	> NG
MAME Support\dats	> NG
C:\test\dats		> OK
c:\te st\dats		> OK
dats			> OK
dat s			> OK
test\dats		> OK
te st\dats		> OK
test\test\dats		> OK
test\test\test\dats	> NG
aaaaaaaaaa\dats		> OK
aaaaaaaaaaa\dats	> NG
datttttttttttts		> OK
dattttttttttttts	> NG

It seems that bug is caused by the number of characters regardless of whether '\', ':' or space is included.
I also tried double-byte characters and it was same result.
(over 16 bytes with single-byte characters?)




After that, I also tested plain official MAME and MAMEUI.

In MAME, this bug didn't occur.

In MAMEUI, it's more broken. Even if you open the directory dialog and press [Cancel] without making any changes, it will crash. (Some directories are displayed as garbled characters)
In ARCADE, only broken historypath in UI.ini for some reason.

And at 0.187 this bug doesn't seem to happen in any MAME.
So it is certain that this happened with some change in 0.188.

This is the only thing that I can do but I hope this will help.

Edited by demonkatze
  • Like 1
Link to comment
Share on other sites

This is really a good catch, demonkatze and looks to me a MAME core bug, because our INTERFACE.INI is ok, instead the core UI.INI that we use only for External DAT View gets corrupted. Curious thing, isn't it Robert? We use core functions to save both the files but it seems that UI_OPTS (UI.INI related options) are handled differently, or, better I suspect that Nathan Woods changes in the options section of the core broken something. It should be tested with plain official MAME.

Chanbara aka Big Karnak, good news for you! Maybe it will be fixed!

Link to comment
Share on other sites

Man, it's years I know you so don't take this suggestion in the wrong way but..... XP should go in the toilet today. It's been a very good OS but it's too outdated now.


I know, I agree. I'm hoping to get a top-of-the-line PC in a few months for Christmas. :christmas:



Chanbara aka Big Karnak, good news for you! Maybe it will be fixed!


Thanks :thumbsup1:

Link to comment
Share on other sites

While playing with MAMEUI suddenly noticed weird stuff was happening, directories were getting corrupted. Checking further showed that any directory that could only have one entry was broken. Anyway just fixed it. It shouldn't have had any effect on the "ROMS" folder though, so I still don't know what could cause it to crash when Cancel pressed.

Link to comment
Share on other sites

I tested again ARCADE32 here at work with a laptop with WIN 10. I set a very long path, with spaces, slashes, etc. but my UI.INI didn't get corrupted. Is it a random thing? I cannot confirm the issue at the moment.

Link to comment
Share on other sites

Sample support in toaplan2 has been removed.


The other change should not affect us much if at all. The only difference will be that startup will be slower because it has to check the status of not only the games, but all the attached devices as well.

Link to comment
Share on other sites



Oops, I'm sorry to wrote incorrectly.

It intended to write about ARCADE. (Corrected post #29)


As I wrote in post #23, it doesn't happen in official MAME and even ARCADE 0.187 or earlier.

What happens if you manually update ui.ini with a very long name. Does MAME or ARCADE corrupt it?


Yes, even if I manually rewrite historypath in UI.ini, When ARCADE is started, it is automatically replaced with the directory set in datafile_directory in INTERFACE.ini.

(and it's corrupted)


I also tried ARCADE 0.187 and replaced it the same way, but it isn’t corrupted.

(Maybe a problem has occurred during this replacement...?)

Edited by demonkatze
Link to comment
Share on other sites

So looks like the problem is here:

void OptionsInit(void)
	// setup our INI folder
	// gamelist creation
	// now load the options and interface settings
	// setup directory for datafiles in the Internal UI

​Specifically, these seems have broken during 0.187-0.188 development cycle:

const char * GetDatsDir(void)
	return winui_opts.value(MUIOPTION_DATS_DIRECTORY);

void SetDatsDir(const char *path)
	SaveInternalUI();	// ensure we store again the new dats dir for the core

I don't know what could happened, because all worked as expected in 0.187. Also, I'm still not able to reproduce this. My UI.INI didn't get corrupted and the value from INTERFACE.INI is correctly copied.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...