Jump to content

Final Burn Legends 1.5


+ T +
 Share

Recommended Posts

@ +T+, can you re-introduce the transparency/alpha for the screenshots/artwork please.

Custom artwork looks rubbish with a black space where it should be transparent.

Thanks in advance.

How do you mean "re-introduce"? Is this something that was working previously then? More info please.

 

 

+T+, I can't change skin, the alone working are the 3 you put in the emulator ;)

I modify the ini file of others with the two line, but nothing to do ... always crash and go to unleashx :(

Can you help me please ?

Post a link to the skin you're trying to run (the whole skin, not just the ini) and I'll see if I can get it working.

 

 

Did the show fps option disappear? Moar debug optionz plz. ;)

It's still there under Video Options in the in-game menu. I've got it on my todo list to make a global setting for this in 1.6 but right now it can only be enabled while emulation is running.

 

EDIT: Some weird stuff just happened with the reply button. Sorry for posting twice.

Edited by + T +
Link to comment
Share on other sites

  • Replies 265
  • Created
  • Last Reply

Top Posters In This Topic

When i say re-introduce, what i mean was that the alpha for artwork wasn't added for png's in 1.3.

I asked NES6502 to add it to the next update he did but instead he gave me the code and where to put it in the source, along with Kenshiro's updates at the time, i had to recompile myself. I believe some people regarded this recompile as 1.3u (not my idea).

So i believe this little fix wasn't actually in the original sources.

Link to comment
Share on other sites

Ah, hmm, new PC, new HDD since then.

If i do have anything it will be on an old dvd somewhere but the chances are extremely slim.

I wouldn't have kept the code seperate in any case it would have been entered in the sources.

In all honesty im 99.99% sure i don't have any of the sources anymore, sorry mate.

Link to comment
Share on other sites

Scuse me for Double Dragon, i just say that for help ... no problem for me, i can play with it like that ... thanks for the work ;)

 

Good idea if you can add PNG transparency ... code ;)

So bad cba.gy lost it ... maybe NES6502 always have it ?

We will can make some beautiful skins ...

 

For my Skin problem, take this file and test it please :(

Link : http://www.mediafire.com/?h39hdd8fbrclhcb

Edited by darknior
Link to comment
Share on other sites

Ah, hmm, new PC, new HDD since then.

If i do have anything it will be on an old dvd somewhere but the chances are extremely slim.

I wouldn't have kept the code seperate in any case it would have been entered in the sources.

In all honesty im 99.99% sure i don't have any of the sources anymore, sorry mate.

It's probably straightforward. I'm just being lazy.

 

 

For my Skin problem, take this file and test it please ;)

Link : http://www.mediafire.com/?h39hdd8fbrclhcb

I checked the skin over and I have no idea why it doesn't work. This is the problem with FBL; many of the main emulator settings are initially taken from the ini file of the skin. So every time I want to add a new option, it affects compatibility with skins built for past versions. The same is true for game configs; any new per-game options I add have the potential to break compatibility with configs created in past versions. So really it's a choice between maintaining full compatibility with old skins and configs, and adding new features. So I decided to go with the latter as my interest is in moving the emulator forward. I'll leave it up to skin creators to update skins to be compatible with those changes. The default skins will always work 100%.

Link to comment
Share on other sites

Yes i understand and i'm agree with you ;)

Adding new feature is perfect ;)

 

But i really want to make this skin work on FBL 1.5+ ...

It is not a problem for me if i must adjust every time the skins ... i can take time ...

But here without your help, i don't understand what it is crashing :(

 

I have test again and remove : MainMenuMovieSwitchEnabled=0

Because it is at the beginning and the end of the file ... but always crash :D

I really want to make myself a new skin too, but if i don't understand what is crashing ... i can't make nothing :D

The ini is 100% same than your.

 

An other question, you write one day that when we modify a skin, FBL don't save in the skin but in a temporary fine ... if i fine understand ...

But where ?

 

Thanks

Link to comment
Share on other sites

Yes i understand and i'm agree with you :D

Adding new feature is perfect :D

 

But i really want to make this skin work on FBL 1.5+ ...

It is not a problem for me if i must adjust every time the skins ... i can take time ...

But here without your help, i don't understand what it is crashing :(

 

I have test again and remove : MainMenuMovieSwitchEnabled=0

Because it is at the beginning and the end of the file ... but always crash :(

I really want to make myself a new skin too, but if i don't understand what is crashing ... i can't make nothing :(

The ini is 100% same than your.

 

An other question, you write one day that when we modify a skin, FBL don't save in the skin but in a temporary fine ... if i fine understand ...

But where ?

 

Thanks

As you say, the ini file is the same so it's unlikely that's the problem. It could be one of the other skin files; one way to find out would to replace them one at a time with files from the default skins. But if you want to make your own skin then I would suggest using one of the default skins as your base and work from that. Then you know that your skin will work correctly.

 

As to your question about skin settings; when you modify the skin in the UI, the settings are saved in the \ini\FinalBurnLegends.ini file. You can copy this file to your skin folder and rename it to the name of your skin if you want to make your changes permanent. I hope that helps.

Link to comment
Share on other sites

Ok, hate to bother you guys again but has anyone got Sengoku 3, Oriental Legend Plus, & Knights of Valor Plus to work?

 

Maybe you guys can help me out again? :D

 

For Sengoku 3, I keep getting ROM Error: ROM size Invalid

 

& For Oriental Legends & Knights of Valor Plus, I keep getting ROM Error: Unable to load the ROM.

 

Any Suggestions?

 

Thanks!

Edited by Rick_Son
Link to comment
Share on other sites

For Sengoku 3, I keep getting ROM Error: ROM size Invalid

 

& For Oriental Legends & Knights of Valor Plus, I keep getting ROM Error: Unable to load the ROM.

All 3 of those games work perfectly.

 

Anything that says 'ROM Error' translates to: "Your ROM is incorrect. Use the DATs!".

Link to comment
Share on other sites

Again, a tremendous thanks to +T+, iq_132, kenshiro, everyone else mentioned in the latest readme, and...last but not least.. nes6502 for porting such a great app to the Xbox game system.

 

Ditto! Im loving the widescreen fix with scanlines, looks really authentic in 720p however the scanlines dont look right on vertical/rotated games, could you possibly take a look?

 

 

I have not tested yet, but at least in 1.4 version with the rotated screen fix

the scanlines were working perfectly fine ---ALTHOUGH THEY ARE ROTATED AS WELL.

 

I have no tested the 1.5 version yet, but i doubt +T+ have changed anything

regarding the scanlines, since they were working good since the previous fix in 1.4.

 

Are you setting your screen (patiently) to pixel perfect?

Its very simple to adjust the width of the image (on a rotated game) with scanlines turned on.

 

Just try keep increasing (or decreasing) screen width and you will notice that there are

some "waves" that come and go. There will be a point where no waves could be noticed,

and this will be the pixel perfect width!

 

Try using the D-PAD instead of the thumbstick to increase and decrease width

on minimum amounts per touch.

 

Regards,

C.

Thanks for the info, I had a play and managed to get the scanlines looking good however I was not too explicit in my last post.

 

+ T +: I assume there is a default setting for the screen resolution for games in regular/upright rotation giving a universal appearance for the scanlines, I was wondering if this same setup could be applied to games using vertical/rotation displays, I understand there may be some issues as different games use different resolutions but currently the scanlines look out of place/different thickness etc. for all the ones I have tried (mainly Cave). I myself am not to fussed about perfect pixel but more interested in the scanlines being consistent throughout the screen as a default setting similar to the upright games. Hope I am making sense and Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...