Jump to content

Final Burn Legends 1.0


nes6502
 Share

Recommended Posts

  • Replies 234
  • Created
  • Last Reply

Top Posters In This Topic

About the NeoGeo greenscreen. In FBA-XXX Pro you can switch between all the different bioes, including the different UniBios versions. In version 2.0 and onward of the UniBios, there are options at a game's first boot which you can set, which include under 'General Bios settings' the option to 'Disable BootUp HW test'. This gets rid of the green screen, which in some cases like KOF 2003 cuts some wait time, as that game displays the green screen for quite a while. I always used UniBios 2.0 in XXX-Pro coz it also has the option to disable the UniBios Logo splash screen which I don't like. For some reason in the later versions you can't. Now I haven't actually tried FBL yet, but I'm guessing there's not an option to use the UniBioes? If there was you could all kiss goobye to the green screen forever.

 

Should be under the dip settings. The green screen skip is a hack. That's the actual neogeo hardware doing a "self test" and the reason it is slow is that it fills the video ram with garbage, which causes the vmm to read random graphics from random places.

Link to comment
Share on other sites

Nes, does FBL implement any type of frameskipping or autoframeskipping? If so, is there a way to toggle it on or off? I would personally disable it in every case where it's not needed because I'm a fan of keeping all of the original animation in most cases. In the FBAXXX Pro ini, frameskip could be disabled completely.

 

Just a question. So far I can't tell that it's skipping any frames on any of the games in FBL, but I haven't tried out the most sprite heavy titles yet either.

Link to comment
Share on other sites

thanks again nes this emulator is very nice. ;)

 

A question. why is the sound on some games extremely low, can it be boosted somehow ?

 

also on fbaxxxpro I used to overclock the neogeo cpu to 150 to get rid of slowdown on "last resort" etc.. can this be done in FBA legends ?

 

hope there are some new skins going to be arriving for this soon, although the pm3 type one at the moment is nice especially the main start screen with the videos is really smooth and polished looking.

 

also what format do videos have to be in ?

 

i have a few avi ones, what do i need to convert them if I have to ?

Edited by silkworm
Link to comment
Share on other sites

Hmmm.. my arcade settings are not saving. Each time I exit a game (or FBL in general) I have to go into the diagnostic settings and set everything how I previously had it all over again. I'm playing mostly CPS2 games now at 720P. My current settings = Point filtering on, Software filters off.

 

Any ideas nes?

Edited by neoryu
Link to comment
Share on other sites

Nes....well done mate!!!!!....awesome job!!! to see these games running with the filters I want, at 60fps, and being able to adjust the screen per game.....priceless mate!

 

 

Few bugs....but I'm sure they won't be there long!

 

Cheers

 

K

Edited by oldpainless
Link to comment
Share on other sites

Hmmm.. my arcade settings are not saving. Each time I exit a game (or FBL in general) I have to go into the diagnostic settings and set everything how I previously had it all over again. I'm playing mostly CPS2 games now at 720P. My current settings = Point filtering on, Software filters off.

 

Any ideas nes?

 

No not really. I just tried starting a CPS2 game. The default settings in the GUI are Bilinear and SuperScale2X for 480. When the game started I checked the settings and that's what they were because it was the first time I had run that particular game. I changed it to Point and Scanlines and exited the game. I then started the game again and it was still Point and Scanline. Are you running off a DVD, change the Path.ini, etc...?

Link to comment
Share on other sites

thanks again nes this emulator is very nice. :thumbsup1:

 

A question. why is the sound on some games extremely low, can it be boosted somehow ?

 

also on fbaxxxpro I used to overclock the neogeo cpu to 150 to get rid of slowdown on "last resort" etc.. can this be done in FBA legends ?

 

hope there are some new skins going to be arriving for this soon, although the pm3 type one at the moment is nice especially the main start screen with the videos is really smooth and polished looking.

 

also what format do videos have to be in ?

 

i have a few avi ones, what do i need to convert them if I have to ?

 

Overclocking the CPU is a great way to mess up the emulation. If it slowed down in the arcade it should slow down on an emulator. It's kind of like genetic tinkering. Sure 100 pound apples are great but it's bound to cause problems somewhere down the line. :D

 

Someone asked about auto frameskipping. It's enabled with no way to disable it. I could add an option to do so but keep in mind:

 

It is only used when needed. Check the FPS display to see if a game is using it. If the FPS is 59 it's not. If it goes below 59 it is until it is at 59 again.

 

It keeps the game running at the correct speed with audio.

 

If it is disabled then anytime a game can't run at 60 FPS the game will run in slow motion and the audio will hiss, crackle, etc...

Edited by nes6502
Link to comment
Share on other sites

Hmmm.. my arcade settings are not saving. Each time I exit a game (or FBL in general) I have to go into the diagnostic settings and set everything how I previously had it all over again. I'm playing mostly CPS2 games now at 720P. My current settings = Point filtering on, Software filters off.

 

Any ideas nes?

 

No not really. I just tried starting a CPS2 game. The default settings in the GUI are Bilinear and SuperScale2X for 480. When the game started I checked the settings and that's what they were because it was the first time I had run that particular game. I changed it to Point and Scanlines and exited the game. I then started the game again and it was still Point and Scanline. Are you running off a DVD, change the Path.ini, etc...?

 

Oh, I'm sorry nes, but I meant the in-game Service menu settings aren't saving for my CPS2 games. For example: turning on Free Play, Increasing the difficulty, and such changes in the Arcade settings have to be redone each time I run a game I've already played. Sorry for the confusion.

 

My video options are saved for each game just fine. It's the changes in the arcade settings menu that don't save. This might be the same for the rest of the games besides CPS2 too. I'll check again to confirm.

 

EDIT: This affects both CPS1 and CPS2 games. The settings for turning on Free Play, changing the number of rounds, turning on the Demo sound, etc in the Arcade settings menu do not save when you exit a game and restart. The arcade settings for NeoGeo games is saved fine though.

Edited by neoryu
Link to comment
Share on other sites

Hmmm.. my arcade settings are not saving. Each time I exit a game (or FBL in general) I have to go into the diagnostic settings and set everything how I previously had it all over again. I'm playing mostly CPS2 games now at 720P. My current settings = Point filtering on, Software filters off.

 

Any ideas nes?

 

No not really. I just tried starting a CPS2 game. The default settings in the GUI are Bilinear and SuperScale2X for 480. When the game started I checked the settings and that's what they were because it was the first time I had run that particular game. I changed it to Point and Scanlines and exited the game. I then started the game again and it was still Point and Scanline. Are you running off a DVD, change the Path.ini, etc...?

 

Oh, I'm sorry nes, but I meant the in-game Service menu settings aren't saving for my CPS2 games. For example: turning on Free Play, Increasing the difficulty, and such changes in the Arcade settings have to be redone each time I run a game I've already played. Sorry for the confusion.

 

My video options are saved for each game just fine. It's the changes in the arcade settings menu that don't save. This might be the same for the rest of the games besides CPS2 too. I'll check again to confirm.

 

It's a bug. I'll add it to the fix list.

Edited by nes6502
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...