Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
sbpaabck

Micromachines too fast on NeoGenesis

Recommended Posts

Am using Neogenesis for the xbox, playing micromachines 2 and '96

 

The game seems to be slightly throttled up too fast, this is especially noticable when you beep the horn, it doesn't beep but goes "peeep" as though the sound has been speeded up,

 

any thoughts anyone,

 

any and all help is much appreciated ;)

 

micro machines was my favourite game of all time I just want to emulate it accurately

Share this post


Link to post
Share on other sites

I've noticed that about the horn noise too. It's not just NeoGenesis that does this. I remember Gens on the PC being the same too. I didn't think that the games were too fast though. By the way, what's this doing in the SNES forum?

Share this post


Link to post
Share on other sites
I've noticed that about the horn noise too. It's not just NeoGenesis that does this. I remember Gens on the PC being the same too. I didn't think that the games were too fast though. By the way, what's this doing in the SNES forum?

 

Apologies I am a fool that is why thanks for the reply tho

Share this post


Link to post
Share on other sites

I've just checked Micro Machines 2 in Kega Fusion and it's fine. In Gens it seems to run the same speed as in Fusion, but the horn sound effect is wrong. It doesn't make a difference whether you set it to 50fps or 60fps either. NeoGenesis is based on Gens I think, so the error carried over to the xbox.

Share this post


Link to post
Share on other sites

If you have the rom set for Auto change it to Euro (if you're playing the UE rom) or play the Canadian rom of MM1, ive played the MM on a real genesis and i know the sound is too fast unless you change the settings. Hopefully this helps.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...