Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
onetrueblade

Music looping

Recommended Posts

Well, I finally got tracks for all of my stages, but imagine my horror when I realized the tracks don't loop, instead crapping out sometime in the second round if the fight lasts too long. What do I do?

Share this post


Link to post
Share on other sites

First, open you Mugen.cfg. Head down near the bottom where you'll see the heading 'Sound Configuration'. Then you'll see the following:

 

;Set the following to 1 to enable and 0 to disable MIDI, MP3, MOD and CD

;playback.

PlayMIDI = 1

PlayMP3 = 1

PlayMOD = 1

PlayCDA = 1

 

MAKE SURE THERE IS A ONE AFTER ALL THESE. If there is not, add the ones and try your game again. If it still doesn't work, go up in the CFG a little ways, a couple lines above the 'Sound Configuration', you'll SOMETHING like this:

 

plugin = plugins/in_mp3.dll, mp3, mp2, mpg

plugin = plugins/in_vorbis.dll, ogg

plugin = plugins/in_adx.dll, adx

 

Simply head to the first line and add a word, make it look like:

 

plugin = looptype=1, plugins/in_mp3.dll, mp3, mp2, mpg

 

That should do the trick.

Share this post


Link to post
Share on other sites
First, open you Mugen.cfg. Head down near the bottom where you'll see the heading 'Sound Configuration'. Then you'll see the following:

 

;Set the following to 1 to enable and 0 to disable MIDI, MP3, MOD and CD

;playback.

PlayMIDI = 1

PlayMP3 = 1

PlayMOD = 1

PlayCDA = 1

 

MAKE SURE THERE IS A ONE AFTER ALL THESE. If there is not, add the ones and try your game again. If it still doesn't work, go up in the CFG a little ways, a couple lines above the 'Sound Configuration', you'll SOMETHING like this:

 

plugin = plugins/in_mp3.dll, mp3, mp2, mpg

plugin = plugins/in_vorbis.dll, ogg

plugin = plugins/in_adx.dll, adx

 

Simply head to the first line and add a word, make it look like:

 

plugin = looptype=1, plugins/in_mp3.dll, mp3, mp2, mpg

 

That should do the trick.

 

Thanks. It worked.

Edited by onetrueblade

Share this post


Link to post
Share on other sites

Yeah, no problem. Anytime I can help, let me know.

Share this post


Link to post
Share on other sites

I'm posting this here because it's sort of related. My sound effects(The character sounds) are way louder than the music. Is there a way I can turn the sounds down instead of having to adjust all the stage mp3s?

Share this post


Link to post
Share on other sites

ooh, yeah, that sucks, I know. Also, I found the perfect thing to use for music.

 

mp3s like to skip a LOT. instead, use a device called SUPER. It can change anything from one type of media file to any other media file, and many other things for FREE, unlike a lot of programs that CANT do it for MONEY.

 

Transfer them from mp3 to ogg. Dont worry, you'll still have the mp3 (the new file will be named FILENAME.mp3.ogg)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...