Jump to content

FBA-XXX Pro v1.28


+ T +
 Share

Recommended Posts

  • Replies 638
  • Created
  • Last Reply

Top Posters In This Topic

Graphics are corrupt in Ms5boot, the other bootlegs seem fine though, have not tried all yet

Well, Magic Plus 2 (kf2k2mp2) is still has the garbled graphics, but Magic Plus (kf2k2mp) is now working fine.

These are fixed and will be working in the next build.

Link to comment
Share on other sites

I don't know if it's my place here to make a request, but I have 2 easy sounding requests (not that I know if they are or not)

 

 

* Along with the hide clones option, possibly add a hide non-working games option? I like to have the romset finished, but I don't want to see the ones I can't play.

 

* The diganostis mode button be triggable (Like in Kawa-X)(Same screen as setting start and coin prehaps?) without going into the pause menu. Handy for when I decide to put my whole system into a cabinet. :banghead:

 

 

Thanks in advance, and thanks for having a constantly updated emulator for the Xbox that isn't 2 years old like everything else now.

Edited by twen
Link to comment
Share on other sites

I don't know if it's my place here to make a request, but I have 2 easy sounding requests (not that I know if they are or not)

 

 

* Along with the hide clones option, possibly add a hide non-working games option? I like to have the romset finished, but I don't want to see the ones I can't play.

 

* The diganostis mode button be triggable (Like in Kawa-X)(Same screen as setting start and coin prehaps?) without going into the pause menu. Handy for when I decide to put my whole system into a cabinet. :banghead:

 

 

Thanks in advance, and thanks for having a constantly updated emulator for the Xbox that isn't 2 years old like everything else now.

FBA-XXX had the option to hide non-working games but I removed it from Pro since it caused the emulator to crash when playing a clone of a non-working parent. I'll take a quick look at the code to see if there's anything obvious that might fix it but don't get your hopes up. Though technically, since Pro is designed for ROM collectors and not just playing games it shouldn't really have the option to hide clones anymore either. :banghead:

 

Diagnostics mode already has a gamepad shortcut. It's Back + White. And for Service mode, Back + Black.

Link to comment
Share on other sites

+T+ two small observation about the emu, wanted to know if you noticed this(im probably being anal). When you scroll quickly through the NeoGeo roms in the menu it pauses slightly on the Samsho5 special sets and a few others i cant name right now. Just wanted to know why that is(no big deal). The other thing is a little strage after the last update and swapping default xbe's i noticed that when i went to toggle between cpu speeds on Neo games when I'm in a game it lags between selections( its worse if the set is encypted and less is decrypted, Metal slug 4 for example, you can hear the HD access between selection as well) As an experiment i swapped xbe's and used 1.01, it did not work, still did it. Then i went back to 1.08a and deleted fff504 in E and T Data as well as ini and cfg in the root, and presto it was fine. Just a few observations, gameplay seems fine though. Thanks

Link to comment
Share on other sites

+T+ two small observation about the emu, wanted to know if you noticed this(im probably being anal). When you scroll quickly through the NeoGeo roms in the menu it pauses slightly on the Samsho5 special sets and a few others i cant name right now. Just wanted to know why that is(no big deal). The other thing is a little strage after the last update and swapping default xbe's i noticed that when i went to toggle between cpu speeds on Neo games when I'm in a game it lags between selections( its worse if the set is encypted and less is decrypted, Metal slug 4 for example, you can hear the HD access between selection as well) As an experiment i swapped xbe's and used 1.01, it did not work, still did it. Then i went back to 1.08a and deleted fff504 in E and T Data as well as ini and cfg in the root, and presto it was fine. Just a few observations, gameplay seems fine though. Thanks

I am aware of the slight pausing. It isn't just in the ROMlist but also in the setup menus. This is an FBA-XXX bug. I'll look into fixing it if I can at some point but I really have no clue as to what the cause could be.

 

The delay when changing CPU speeds is interesting. It's no doubt due to the fact that a CPU speed adjustment causes a write to the ini file. Though why deleting previous config files makes this easier for the emu I don't know. To be honest, I really don't like the way FBA-XXX uses the root directory for its savefiles if being run from HDD. For the next build I may consider just having the emulator use the TDATA folder whatever it's being run from. At least then everybody's savegame will be in the same place and issues like this will be easier to address.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...