registry = ipsRegistry::instance(); $this->settings =& $this->registry->fetchSettings(); } public function getOutput() { return; } public function replaceOutput($output, $key) { require_once( IPSLib::getAppDir('ibprobattle') . '/sources/battleHooks.php' ); $this->battleHook = new battleHooks( $this->registry ); return $this->battleHook->statsTopicView($output, $key); } } ?>registry = ipsRegistry::instance(); $this->settings =& $this->registry->fetchSettings(); } public function getOutput() { require_once( IPSLib::getAppDir('ibprobattle') . '/sources/battleHooks.php' ); $this->battleHook = new battleHooks( $this->registry ); return $this->battleHook->statsTopicViewJS(); } } ?> "Not a valid Win32 application" message. Dll libraries missing? - Raine - 1Emulation.com

Jump to content

Welcome to 1Emulation.com
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account
Photo

"Not a valid Win32 application" message. Dll libraries missing?

- - - - -

  • Please log in to reply
4 replies to this topic

#1
petran79

petran79

    Newbie Poster

  • Members+
  • 7 posts

Raine runs on desktop PC fine.

Recently I decided to use Raine on the laptop as well.

 

On the laptop I had used  the older Neoraine versions and they do run fine. Hadnt upgraded the application ever since.

But with new Raine I get a "Not a valid Win32 application" message,  

Same OS (Windows 7 64-bit)

 

To be certain that laptop has not any issues, I tried it on a another PC with clean Windows 8 installed and got the same message. 

Is there any Microsoft library Raine needs to be present in order to run? Desktop obviously has it but I do not know which.

 

 



#2
Tux

Tux

    Author of Raine

  • Emulator Author
  • 194 posts
  • Gender:Male
  • Location:Nantes, France

When it's a missing dll you see a message with the name of the missing dll if I remember correctly.

Try to google the exact message you are getting, if it's really a missing dll they should tell you how to get the missing dll name, but I doubt that's the cause here...



#3
petran79

petran79

    Newbie Poster

  • Members+
  • 7 posts

Just the "not a Win32 application"  message appeared. I assumed a missing library was the issue, eg like VC

Also the raine32.exe icon was blank (default blue-gray color) instead of the Bubble Bobble sprite. 

Problem appeared two weeks ago and I hadnt tested it ever since.

 

Now that  I unzipped the file to a new Raine folder, icon appeared fine and Raine launched. Strange.

Windows occasionally does those whims...I hadnt touched anything.


Edited by petran79, 05 December 2015 - 08:55 AM.


#4
Tux

Tux

    Author of Raine

  • Emulator Author
  • 194 posts
  • Gender:Male
  • Location:Nantes, France

I'd say the most likely cause is a disk corruption and since it's a laptop maybe after some power failure... run a scandisk !



#5
petran79

petran79

    Newbie Poster

  • Members+
  • 7 posts

I will, thanks! 

Hence why I prefer to run the program on Linux...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users