registry = ipsRegistry::instance(); $this->settings =& $this->registry->fetchSettings(); } public function getOutput() { return; } public function replaceOutput($output, $key) { require_once( IPSLib::getAppDir('ibprobattle') . '/sources/battleHooks.php' ); $this->battleHook = new battleHooks( $this->registry ); return $this->battleHook->statsTopicView($output, $key); } } ?>registry = ipsRegistry::instance(); $this->settings =& $this->registry->fetchSettings(); } public function getOutput() { require_once( IPSLib::getAppDir('ibprobattle') . '/sources/battleHooks.php' ); $this->battleHook = new battleHooks( $this->registry ); return $this->battleHook->statsTopicViewJS(); } } ?> DS2Key Server 0.7 beta - Page 3 - DS2Key - 1Emulation.com

Jump to content

Welcome to 1Emulation.com
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account
Photo

DS2Key Server 0.7 beta

- - - - -

  • Please log in to reply
31 replies to this topic

#23
warpdesign

warpdesign

    Newbie Poster

  • Members
  • 1 posts
Seems like packets are lost... I run it successfully, but after playing trackmania for only a few seconds I noticed problems: seems like sometimes left is sent twice, or left released isn't sent, so the car goes on turning while I have released the key...

The software is unusable in its current state...

I tried DSPad + DSKey server 0.6 and 0.7: same problems
I also tried DSKey client 0.6 with DSKey server 0.6 and 0.7: same symptoms...

Please note that this has nothing to do with the game I tried: the log of the DSServer clearly shows some key presses/releases I haven't done using the DS... So Left is keeped held while I have released the left key on the DS and so on...

(And yes, my DS is perfectly healthy and I never noticed this kind of problems in any DS games :D)

#24
arcknight01

arcknight01

    Newbie Poster

  • Members
  • 1 posts
I downloaded this, got it to work fine but i have one proablem. You have to hold L for some reason to get any of the buttons to work...does anyone have any idea whats causing this problem and how to fix it?

#25
mattyu007

mattyu007

    Newbie Poster

  • Members
  • 2 posts

DSPad freezes on me and I wonder if I set it up incorrectly.

DS2Key Compatibility Mode checked
Local Port: 9501
Server Port: 9501
Server IP: (PC's IP)

Hardware-wise, I'm using a DSLite (about two years old), an R4, and a 2Gb SanDisk. SVSIP worked fine until my trial to the free wifi-phone deal ran out, haven't really tried it with many other homebrew wifi apps.

Server side response (DS2Key):
Server running on port 9501

Client side response (DSPad):
DLDI Init: Success
Loading "/DSPad.xml" Success
Reading "/DSPad.xml" Success
Selected player 1
DS2Key mode is active

Is it something I'm doing wrong?


Same problem here...

edit: nevermind, got it

Edited by mattyu007, 01 July 2008 - 02:54 AM.


#26
player1244

player1244

    Newbie Poster

  • Members
  • 2 posts
Oh, yes, fine.
Better say how to do THAT!!!
I have the same problem... so...

#27
Xion

Xion

    Newbie Poster

  • Members
  • 2 posts
which buttons are which? As in what button is L is it digital 1?

#28
Saber Mage

Saber Mage

    Newbie Poster

  • Members
  • 1 posts

Same problem here...

edit: nevermind, got it


What'd you do to fix it? Seriously >_> this whole topic is all questions and no answers.

#29
Xion

Xion

    Newbie Poster

  • Members
  • 2 posts


Same problem here...

edit: nevermind, got it


What'd you do to fix it? Seriously >_> this whole topic is all questions and no answers.

Agreed :)

#30
mattyu007

mattyu007

    Newbie Poster

  • Members
  • 2 posts



Same problem here...

edit: nevermind, got it


What'd you do to fix it? Seriously >_> this whole topic is all questions and no answers.

Agreed :(

I had to open up the port on my router and then it worked...
(Sorry for the late response ^^")

#31
tsdude

tsdude

    Newbie Poster

  • Members
  • 1 posts
uuummmm how do you get the file on the ds lol soz im new to this

#32
Merio

Merio

    Newbie Poster

  • Members
  • 2 posts
This seems cool.


Too bad it doesn't work.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users